Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Построение графика при пустых значениях - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Построение графика при пустых значениях (Формулы/Formulas)
Построение графика при пустых значениях
Faul1 Дата: Вторник, 16.08.2016, 13:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Добрый день!

На листе А есть значения для каждого имени, на листе В строится график относительно выбранного человека из раскрывающегося списка.

На листе А у Сергея за первые 2 даты нету значений, но на листе В если выбрать из списка Сергей, то график строится как будто значение 0, хотя его нету.

Возможно ли написать так формулу, что бы график строился правильно? Т.е. у имени Сергей должно быть только 2 точки на графике.

Спасибо.
К сообщению приложен файл: Data_2.xlsx(16Kb)
 
Ответить
СообщениеДобрый день!

На листе А есть значения для каждого имени, на листе В строится график относительно выбранного человека из раскрывающегося списка.

На листе А у Сергея за первые 2 даты нету значений, но на листе В если выбрать из списка Сергей, то график строится как будто значение 0, хотя его нету.

Возможно ли написать так формулу, что бы график строился правильно? Т.е. у имени Сергей должно быть только 2 точки на графике.

Спасибо.

Автор - Faul1
Дата добавления - 16.08.2016 в 13:07
Manyasha Дата: Вторник, 16.08.2016, 13:24 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1589
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
Faul1, здравствуйте, например так
Код
=ЕСЛИ(ЕПУСТО(ИНДЕКС(A!$B3:$E8;$A2;ПОИСКПОЗ(E2;A!$B2:$AV2;)));НД();ИНДЕКС(A!$B3:$E8;$A2;ПОИСКПОЗ(E2;A!$B2:$AV2;)))
К сообщению приложен файл: Data_2-1.xlsx(16Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеFaul1, здравствуйте, например так
Код
=ЕСЛИ(ЕПУСТО(ИНДЕКС(A!$B3:$E8;$A2;ПОИСКПОЗ(E2;A!$B2:$AV2;)));НД();ИНДЕКС(A!$B3:$E8;$A2;ПОИСКПОЗ(E2;A!$B2:$AV2;)))

Автор - Manyasha
Дата добавления - 16.08.2016 в 13:24
Faul1 Дата: Вторник, 16.08.2016, 13:26 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010

=ЕСЛИ(ЕПУСТО(ИНДЕКС(A!$B3:$E8;$A2;ПОИСКПОЗ(E2;A!$B2:$AV2;)));НД();ИНДЕКС(A!$B3:$E8;$A2;ПОИСКПОЗ(E2;A!$B2:$AV2;)))
К сообщению приложен файл: Data_2-1.xlsx(16Kb)


Здорово, спасибо большое!
 
Ответить
Сообщение

=ЕСЛИ(ЕПУСТО(ИНДЕКС(A!$B3:$E8;$A2;ПОИСКПОЗ(E2;A!$B2:$AV2;)));НД();ИНДЕКС(A!$B3:$E8;$A2;ПОИСКПОЗ(E2;A!$B2:$AV2;)))
К сообщению приложен файл: Data_2-1.xlsx(16Kb)


Здорово, спасибо большое!

Автор - Faul1
Дата добавления - 16.08.2016 в 13:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Построение графика при пустых значениях (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!