Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Изменение выделенного диапазона при изменения значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменение выделенного диапазона при изменения значения (Формулы/Formulas)
Изменение выделенного диапазона при изменения значения
Faul1 Дата: Вторник, 16.08.2016, 13:24 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Добрый день!

На листе А есть табличка с именами и соответствующими им значениями относительно дат. На этом же листе построен график для имения Вася на первых 2-х значениях.

Возможно ли так сделать, что выделенный диапазон построения графика (2 значения) будет изменятся относительно даты указанной на листе В в ячейке D1. Т.е. график должен строится из 3 точек, а не из 2 как сейчас.
К сообщению приложен файл: Data_3.xlsx(13Kb)
 
Ответить
СообщениеДобрый день!

На листе А есть табличка с именами и соответствующими им значениями относительно дат. На этом же листе построен график для имения Вася на первых 2-х значениях.

Возможно ли так сделать, что выделенный диапазон построения графика (2 значения) будет изменятся относительно даты указанной на листе В в ячейке D1. Т.е. график должен строится из 3 точек, а не из 2 как сейчас.

Автор - Faul1
Дата добавления - 16.08.2016 в 13:24
Manyasha Дата: Вторник, 16.08.2016, 14:08 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 662 ±
Замечаний: 0% ±

Excel 2007, 2010
Faul1, можно использовать именованные диапазоны (см. ctrl+f3):
Код
=ИНДЕКС(A!$B$8:$G$8;ПОИСКПОЗ(1;--ЕЧИСЛО(A!$B$8:$G$8);0)):ИНДЕКС(A!$B$8:$G$8;ПОИСКПОЗ(B!$D$1;A!$B$1:$G$1;0))
К сообщению приложен файл: Data_3-1.xlsx(13Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеFaul1, можно использовать именованные диапазоны (см. ctrl+f3):
Код
=ИНДЕКС(A!$B$8:$G$8;ПОИСКПОЗ(1;--ЕЧИСЛО(A!$B$8:$G$8);0)):ИНДЕКС(A!$B$8:$G$8;ПОИСКПОЗ(B!$D$1;A!$B$1:$G$1;0))

Автор - Manyasha
Дата добавления - 16.08.2016 в 14:08
gling Дата: Вторник, 16.08.2016, 15:36 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Тоже с именованными диапазонами.
К сообщению приложен файл: 1285085.xlsx(17Kb)


Сообщение отредактировал gling - Вторник, 16.08.2016, 15:50
 
Ответить
СообщениеТоже с именованными диапазонами.

Автор - gling
Дата добавления - 16.08.2016 в 15:36
Faul1 Дата: Вторник, 16.08.2016, 15:52 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010

=ИНДЕКС(A!$B$8:$G$8;ПОИСКПОЗ(1;--ЕЧИСЛО(A!$B$8:$G$8);0)):ИНДЕКС(A!$B$8:$G$8;ПОИСКПОЗ(B!$D$1;A!$B$1:$G$1;0))
К сообщению приложен файл: Data_3-1.xlsx(13Kb)

Спасибо, все работает!

Но хотел бы разобраться как?

Что означает "1" и "--" в этой части ПОИСКПОЗ(1;--ЕЧИСЛО(A!$B$8:$G$8);0)?
 
Ответить
Сообщение

=ИНДЕКС(A!$B$8:$G$8;ПОИСКПОЗ(1;--ЕЧИСЛО(A!$B$8:$G$8);0)):ИНДЕКС(A!$B$8:$G$8;ПОИСКПОЗ(B!$D$1;A!$B$1:$G$1;0))
К сообщению приложен файл: Data_3-1.xlsx(13Kb)

Спасибо, все работает!

Но хотел бы разобраться как?

Что означает "1" и "--" в этой части ПОИСКПОЗ(1;--ЕЧИСЛО(A!$B$8:$G$8);0)?

Автор - Faul1
Дата добавления - 16.08.2016 в 15:52
Manyasha Дата: Вторник, 16.08.2016, 16:01 | Сообщение № 5
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 662 ±
Замечаний: 0% ±

Excel 2007, 2010
Faul1, из справки:
Цитата
Функция ПОИСКПОЗ выполняет поиск указанного элемента в диапазоне (Диапазон. Две или более ячеек листа. Ячейки диапазона могут быть как смежными, так и несмежными.) ячеек и возвращает относительную позицию этого элемента в диапазоне.

ЕЧИСЛО(A!$B$8:$G$8) вернет массив из Истина/Ложь, -- преобразовывает эти значения в 1/0 (читаем тут).
Ищем "1" в массиве из 0 и 1, т.е. первую ячейку с числом.


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеFaul1, из справки:
Цитата
Функция ПОИСКПОЗ выполняет поиск указанного элемента в диапазоне (Диапазон. Две или более ячеек листа. Ячейки диапазона могут быть как смежными, так и несмежными.) ячеек и возвращает относительную позицию этого элемента в диапазоне.

ЕЧИСЛО(A!$B$8:$G$8) вернет массив из Истина/Ложь, -- преобразовывает эти значения в 1/0 (читаем тут).
Ищем "1" в массиве из 0 и 1, т.е. первую ячейку с числом.

Автор - Manyasha
Дата добавления - 16.08.2016 в 16:01
Faul1 Дата: Вторник, 16.08.2016, 16:22 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
ЕЧИСЛО(A!$B$8:$G$8) вернет массив из Истина/Ложь, -- преобразовывает эти значения в 1/0 (читаем тут).
Ищем "1" в массиве из 0 и 1, т.е. первую ячейку с числом.

Спасибо, разобрался.
 
Ответить
Сообщение
ЕЧИСЛО(A!$B$8:$G$8) вернет массив из Истина/Ложь, -- преобразовывает эти значения в 1/0 (читаем тут).
Ищем "1" в массиве из 0 и 1, т.е. первую ячейку с числом.

Спасибо, разобрался.

Автор - Faul1
Дата добавления - 16.08.2016 в 16:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменение выделенного диапазона при изменения значения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!