Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение чисел - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение чисел (Формулы/Formulas)
Сравнение чисел
Volkofx Дата: Четверг, 18.08.2016, 17:40 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 61
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Господа, вопрос на 2 секунды.
Имеется столбец с числом (например с цифрой 5, второй следующий столбец-знак (меньше, меньше или равно и тп, пусть будет - <) и третий столбец - другое число (например с цифрой 6) меньше или больше которое первого числа. Мне нужно определить соответствии двух чисел в соответствии со знаком. Химичил склейками наподобие =A1;A2;A3 (условно 5;<;6 чтобы вывело истину), но не работает, как сделать условие чтобы тупо склеить 3 столбца и мне он показывал истину или ложь? Если невозможно, тогда формулу сам напишу на условие если, можно будет не писать ее. Всем спасибо!!!

И да, не нашел кстати такого случае нигде, искал честно.
 
Ответить
СообщениеГоспода, вопрос на 2 секунды.
Имеется столбец с числом (например с цифрой 5, второй следующий столбец-знак (меньше, меньше или равно и тп, пусть будет - <) и третий столбец - другое число (например с цифрой 6) меньше или больше которое первого числа. Мне нужно определить соответствии двух чисел в соответствии со знаком. Химичил склейками наподобие =A1;A2;A3 (условно 5;<;6 чтобы вывело истину), но не работает, как сделать условие чтобы тупо склеить 3 столбца и мне он показывал истину или ложь? Если невозможно, тогда формулу сам напишу на условие если, можно будет не писать ее. Всем спасибо!!!

И да, не нашел кстати такого случае нигде, искал честно.

Автор - Volkofx
Дата добавления - 18.08.2016 в 17:40
Volkofx Дата: Четверг, 18.08.2016, 17:42 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 61
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
это пример что нужно
К сообщению приложен файл: 3256021.xlsx(8Kb)


Сообщение отредактировал Volkofx - Четверг, 18.08.2016, 17:43
 
Ответить
Сообщениеэто пример что нужно

Автор - Volkofx
Дата добавления - 18.08.2016 в 17:42
AlexM Дата: Четверг, 18.08.2016, 17:51 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Код
=ЕСЛИ(B2=">";A2>C2;C2>A2)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ЕСЛИ(B2=">";A2>C2;C2>A2)

Автор - AlexM
Дата добавления - 18.08.2016 в 17:51
Volkofx Дата: Четверг, 18.08.2016, 17:55 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 61
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
=ЕСЛИ(B2=">";A2>C2;C2>A2)

Нет, так не подходит, тк у меня видов знаков 4 и на самом деле столбца 2 должно быть, и сразу несколько условий нужно будет проверять, формулу я могу написать, просто нужно понимать возможно ли сделать это таким простым способом как просто подставить эти значения рядом и вышел ответ, тогда формула будет куда короче, раз в 20))))
Может есть какой то символ склейки преобразующий в условие например A1*A2*A3 - что то вроде этого.


Сообщение отредактировал Volkofx - Четверг, 18.08.2016, 18:04
 
Ответить
Сообщение
=ЕСЛИ(B2=">";A2>C2;C2>A2)

Нет, так не подходит, тк у меня видов знаков 4 и на самом деле столбца 2 должно быть, и сразу несколько условий нужно будет проверять, формулу я могу написать, просто нужно понимать возможно ли сделать это таким простым способом как просто подставить эти значения рядом и вышел ответ, тогда формула будет куда короче, раз в 20))))
Может есть какой то символ склейки преобразующий в условие например A1*A2*A3 - что то вроде этого.

Автор - Volkofx
Дата добавления - 18.08.2016 в 17:55
sboy Дата: Четверг, 18.08.2016, 18:03 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 196
Репутация: 48 ±
Замечаний: 0% ±

Excel 2007
 
Ответить
СообщениеДобрый день.
Вот это должно помочь

Автор - sboy
Дата добавления - 18.08.2016 в 18:03
Светлый Дата: Четверг, 18.08.2016, 19:44 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 56 ±
Замечаний: 0% ±

Excel 2007
Код
=СЧЁТЕСЛИ(A1;B1&C1)>0

Для всех не проверял, но должно работать.
Даже с текстовыми данными работает. Пока ошибок не нашёл.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 18.08.2016, 19:49
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИ(A1;B1&C1)>0

Для всех не проверял, но должно работать.
Даже с текстовыми данными работает. Пока ошибок не нашёл.

Автор - Светлый
Дата добавления - 18.08.2016 в 19:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение чисел (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!