Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подсчет процента износа изделия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет процента износа изделия (Формулы/Formulas)
подсчет процента износа изделия
alexa1965 Дата: Пятница, 19.08.2016, 14:09 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 2 ±
Замечаний: 0% ±

2003, 2010
Добрый день! Формулой в ячейке D1 просчитан процент просрочки изделий. Но к сожалению данная формула искажает данные при отборе по фильтру любого наименования, так как СУММПРОИЗВ выдает одно и тоже количество независимо от фильтра.
Можно ли как то это поправить?
Заранее спасибо
К сообщению приложен файл: 9483597.xlsx(9Kb)


Главное не быть балабастиком

Сообщение отредактировал alexa1965 - Пятница, 19.08.2016, 14:16
 
Ответить
СообщениеДобрый день! Формулой в ячейке D1 просчитан процент просрочки изделий. Но к сожалению данная формула искажает данные при отборе по фильтру любого наименования, так как СУММПРОИЗВ выдает одно и тоже количество независимо от фильтра.
Можно ли как то это поправить?
Заранее спасибо

Автор - alexa1965
Дата добавления - 19.08.2016 в 14:09
Manyasha Дата: Пятница, 19.08.2016, 14:12 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 662 ±
Замечаний: 0% ±

Excel 2007, 2010
alexa1965, название темы не соответствует п2 Правил форума, исправьте.


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеalexa1965, название темы не соответствует п2 Правил форума, исправьте.

Автор - Manyasha
Дата добавления - 19.08.2016 в 14:12
Manyasha Дата: Пятница, 19.08.2016, 14:42 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 662 ±
Замечаний: 0% ±

Excel 2007, 2010
alexa1965, вот так подойдет?
Код
=СУММПРОИЗВ(--(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;ДВССЫЛ("C"&СТРОКА(C3:C15)))*(C3:C15<B1)))/ПРОМЕЖУТОЧНЫЕ.ИТОГИ(102;$C$3:$C$15)
К сообщению приложен файл: 9483597-1.xlsx(9Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеalexa1965, вот так подойдет?
Код
=СУММПРОИЗВ(--(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;ДВССЫЛ("C"&СТРОКА(C3:C15)))*(C3:C15<B1)))/ПРОМЕЖУТОЧНЫЕ.ИТОГИ(102;$C$3:$C$15)

Автор - Manyasha
Дата добавления - 19.08.2016 в 14:42
alexa1965 Дата: Пятница, 19.08.2016, 16:40 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 2 ±
Замечаний: 0% ±

2003, 2010
Спасибо! То что нужно!


Главное не быть балабастиком
 
Ответить
СообщениеСпасибо! То что нужно!

Автор - alexa1965
Дата добавления - 19.08.2016 в 16:40
buchlotnik Дата: Пятница, 19.08.2016, 16:56 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
ещё вариант:
Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;СМЕЩ(A1;СТРОКА(A3:A15)-1;;1;1))*(C3:C15<B1))/ПРОМЕЖУТОЧНЫЕ.ИТОГИ(102;$C$3:$C$15)
К сообщению приложен файл: 0610047.xlsx(10Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеещё вариант:
Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;СМЕЩ(A1;СТРОКА(A3:A15)-1;;1;1))*(C3:C15<B1))/ПРОМЕЖУТОЧНЫЕ.ИТОГИ(102;$C$3:$C$15)

Автор - buchlotnik
Дата добавления - 19.08.2016 в 16:56
alexa1965 Дата: Воскресенье, 21.08.2016, 11:25 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 2 ±
Замечаний: 0% ±

2003, 2010
Спасибо! Попробую оба варианта, который быстрее работает, тот и применю, т.к. массив данных очень большой, а комп слабоват как у всех бюджетников


Главное не быть балабастиком
 
Ответить
СообщениеСпасибо! Попробую оба варианта, который быстрее работает, тот и применю, т.к. массив данных очень большой, а комп слабоват как у всех бюджетников

Автор - alexa1965
Дата добавления - 21.08.2016 в 11:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет процента износа изделия (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!