Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Оставить строку без числа 0, заменить 0 на пусто - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Оставить строку без числа 0, заменить 0 на пусто (Формулы/Formulas)
Оставить строку без числа 0, заменить 0 на пусто
Nikitos79 Дата: Суббота, 20.08.2016, 07:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Есть формула
Код
=ЕСЛИ(ЕПУСТО(C2);E2;G2)
Надо изменить формулу, т.е. если в заданных столбцах нет чисел, букв, то строка с формулой оставалась бы пустой, а не писала цифру 0.
К сообщению приложен файл: _Microsoft_Exce.xlsx(9Kb)


Сообщение отредактировал Nikitos79 - Суббота, 20.08.2016, 07:38
 
Ответить
СообщениеЕсть формула
Код
=ЕСЛИ(ЕПУСТО(C2);E2;G2)
Надо изменить формулу, т.е. если в заданных столбцах нет чисел, букв, то строка с формулой оставалась бы пустой, а не писала цифру 0.

Автор - Nikitos79
Дата добавления - 20.08.2016 в 07:37
Pelena Дата: Суббота, 20.08.2016, 07:44 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11007
Репутация: 2459 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=ЕСЛИ(ЕПУСТО(C2);E2&"";G2&"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕПУСТО(C2);E2&"";G2&"")

Автор - Pelena
Дата добавления - 20.08.2016 в 07:44
Nic70y Дата: Суббота, 20.08.2016, 08:12 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3920
Репутация: 830 ±
Замечаний: 0% ±

Excel 2013
ЕПУСТО(C2)
ни когда не использую, может я и не прав (привычка такая)
Код
=ЕСЛИ(C2="";E2;G2)&""


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
ЕПУСТО(C2)
ни когда не использую, может я и не прав (привычка такая)
Код
=ЕСЛИ(C2="";E2;G2)&""

Автор - Nic70y
Дата добавления - 20.08.2016 в 08:12
Pelena Дата: Суббота, 20.08.2016, 08:59 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11007
Репутация: 2459 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Насколько я понимаю, ЕПУСТО() различает действительно пустую ячейку и ту, где, скажем, формула возвращает путую строку "", а С2="" этого не различает.
В данном конкретном примере без разницы, что использовать


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНасколько я понимаю, ЕПУСТО() различает действительно пустую ячейку и ту, где, скажем, формула возвращает путую строку "", а С2="" этого не различает.
В данном конкретном примере без разницы, что использовать

Автор - Pelena
Дата добавления - 20.08.2016 в 08:59
Nic70y Дата: Суббота, 20.08.2016, 09:01 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3920
Репутация: 830 ±
Замечаний: 0% ±

Excel 2013
Елена, та да.
после поста уже догадался, прост на практике мне такое не попадалось (наверное)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеЕлена, та да.
после поста уже догадался, прост на практике мне такое не попадалось (наверное)

Автор - Nic70y
Дата добавления - 20.08.2016 в 09:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Оставить строку без числа 0, заменить 0 на пусто (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!