Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как оставить строку пустой при условии - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как оставить строку пустой при условии (Формулы/Formulas)
Как оставить строку пустой при условии
Nikitos79 Дата: Понедельник, 22.08.2016, 14:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(ЕПУСТО(B2);"";ИНДЕКС('2'!B2:B2;ПОИСКПОЗ(B2;'2'!A2:A2;0)))


Требуется чтобы строка A6 и B6 оставались пустыми, а не выдавали значение #Н/Д, если в столбце B2 нет числа или буквы. Не пойму куда прописать &"" или может как то по другому надо???

Заранее спасибо)))
К сообщению приложен файл: 5275814.xlsx(12Kb)


Сообщение отредактировал Nikitos79 - Понедельник, 22.08.2016, 14:46
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕПУСТО(B2);"";ИНДЕКС('2'!B2:B2;ПОИСКПОЗ(B2;'2'!A2:A2;0)))


Требуется чтобы строка A6 и B6 оставались пустыми, а не выдавали значение #Н/Д, если в столбце B2 нет числа или буквы. Не пойму куда прописать &"" или может как то по другому надо???

Заранее спасибо)))

Автор - Nikitos79
Дата добавления - 22.08.2016 в 14:44
buchlotnik Дата: Понедельник, 22.08.2016, 14:49 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС('2'!B2:B2;ПОИСКПОЗ(B2;'2'!A2:A2;0));"")
К сообщению приложен файл: 5070069.xlsx(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС('2'!B2:B2;ПОИСКПОЗ(B2;'2'!A2:A2;0));"")

Автор - buchlotnik
Дата добавления - 22.08.2016 в 14:49
Nikitos79 Дата: Понедельник, 22.08.2016, 14:55 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
так нужно?

Пробовал не получается, ведь В2 берет значение листа №1 а не прописывается на этом листе и высвечивает #ЗНАЧ!...


Сообщение отредактировал Nikitos79 - Понедельник, 22.08.2016, 15:04
 
Ответить
Сообщение
так нужно?

Пробовал не получается, ведь В2 берет значение листа №1 а не прописывается на этом листе и высвечивает #ЗНАЧ!...

Автор - Nikitos79
Дата добавления - 22.08.2016 в 14:55
buchlotnik Дата: Понедельник, 22.08.2016, 14:57 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
Пробовал не получается
покажите в файле


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
Пробовал не получается
покажите в файле

Автор - buchlotnik
Дата добавления - 22.08.2016 в 14:57
Nikitos79 Дата: Понедельник, 22.08.2016, 15:01 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
покажите в файле


Вот фаил, прописал "" в конце
К сообщению приложен файл: 33.xlsx(12Kb)
 
Ответить
Сообщение
покажите в файле


Вот фаил, прописал "" в конце

Автор - Nikitos79
Дата добавления - 22.08.2016 в 15:01
buchlotnik Дата: Понедельник, 22.08.2016, 15:05 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
вы пробовали мою формулу использовать?
Код
=ЕСЛИОШИБКА(ИНДЕКС('2'!B1:B2;ПОИСКПОЗ(B2;'2'!A1:A2;0));"")
К сообщению приложен файл: 8871705.xlsx(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениевы пробовали мою формулу использовать?
Код
=ЕСЛИОШИБКА(ИНДЕКС('2'!B1:B2;ПОИСКПОЗ(B2;'2'!A1:A2;0));"")

Автор - buchlotnik
Дата добавления - 22.08.2016 в 15:05
китин Дата: Понедельник, 22.08.2016, 15:08 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или вашу немного переделать
Код
=ЕСЛИ(ЕТЕКСТ(B2);"";ИНДЕКС('2'!B:B;ПОИСКПОЗ(B2;'2'!A:A;0)))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 22.08.2016, 15:34
 
Ответить
Сообщениеили вашу немного переделать
Код
=ЕСЛИ(ЕТЕКСТ(B2);"";ИНДЕКС('2'!B:B;ПОИСКПОЗ(B2;'2'!A:A;0)))

Автор - китин
Дата добавления - 22.08.2016 в 15:08
Nikitos79 Дата: Понедельник, 22.08.2016, 15:23 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
вы пробовали мою формулу использовать?

Извеняюсь у Вас все правильно, вы поставили условие ЕСЛИОШИБКА, а я этого не заметил... Спасибо))) и менял только в конце на ""
 
Ответить
Сообщение
вы пробовали мою формулу использовать?

Извеняюсь у Вас все правильно, вы поставили условие ЕСЛИОШИБКА, а я этого не заметил... Спасибо))) и менял только в конце на ""

Автор - Nikitos79
Дата добавления - 22.08.2016 в 15:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как оставить строку пустой при условии (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!