Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск результата при совпадении в нескольких столбцах. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск результата при совпадении в нескольких столбцах. (Формулы/Formulas)
Поиск результата при совпадении в нескольких столбцах.
Sashagor1982 Дата: Вторник, 23.08.2016, 19:35 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 160
Репутация: 12 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте уважаемые форумчане. Подскажите как с помощью формулы аналогичной ВПР или что-то в этом роде найти значение если поиск необходимо организовать с использованием нескольких столбцов

В файле примере в листе данные содержатся некоторые исходные данные.

В листе результат на основании данных в в столбце А и В надо найти значение С в данном случае должно быть 3. Спасибо
К сообщению приложен файл: 111.xls(20Kb)
 
Ответить
СообщениеЗдравствуйте уважаемые форумчане. Подскажите как с помощью формулы аналогичной ВПР или что-то в этом роде найти значение если поиск необходимо организовать с использованием нескольких столбцов

В файле примере в листе данные содержатся некоторые исходные данные.

В листе результат на основании данных в в столбце А и В надо найти значение С в данном случае должно быть 3. Спасибо

Автор - Sashagor1982
Дата добавления - 23.08.2016 в 19:35
Nic70y Дата: Вторник, 23.08.2016, 19:41 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
варианты:
формулой массива:
Код
=ИНДЕКС(Данные!C2:C17;ПОИСКПОЗ(A2&B2;Данные!A2:A17&Данные!B2:B17;))
для данного примера можно обычной:
Код
=СУММПРОИЗВ((Данные!A2:A17=A2)*(Данные!B2:B17=B2);Данные!C2:C17)
для данного примера и для новых версий
Код
=СУММЕСЛИМН(Данные!C2:C17;Данные!A2:A17;A2;Данные!B2:B17;B2)
К сообщению приложен файл: 4859343.xls(25Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 23.08.2016, 19:44
 
Ответить
Сообщениеварианты:
формулой массива:
Код
=ИНДЕКС(Данные!C2:C17;ПОИСКПОЗ(A2&B2;Данные!A2:A17&Данные!B2:B17;))
для данного примера можно обычной:
Код
=СУММПРОИЗВ((Данные!A2:A17=A2)*(Данные!B2:B17=B2);Данные!C2:C17)
для данного примера и для новых версий
Код
=СУММЕСЛИМН(Данные!C2:C17;Данные!A2:A17;A2;Данные!B2:B17;B2)

Автор - Nic70y
Дата добавления - 23.08.2016 в 19:41
Pelena Дата: Вторник, 23.08.2016, 19:46 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9869
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
ВПР по двум критериям
А если результат, который надо получить, числовой (как в примере), то можно ещё и так
Код
=СУММПРОИЗВ((Данные!$A$2:$A$17=A2)*(Данные!$B$2:$B$17=B2)*Данные!$C$2:$C$17)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
ВПР по двум критериям
А если результат, который надо получить, числовой (как в примере), то можно ещё и так
Код
=СУММПРОИЗВ((Данные!$A$2:$A$17=A2)*(Данные!$B$2:$B$17=B2)*Данные!$C$2:$C$17)

Автор - Pelena
Дата добавления - 23.08.2016 в 19:46
Sashagor1982 Дата: Вторник, 23.08.2016, 19:58 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 160
Репутация: 12 ±
Замечаний: 0% ±

Excel 2007
Спасибо, но в примере числа, а так может быть и текст.
Код
=ИНДЕКС(Данные!C2:C17;ПОИСКПОЗ(A2&B2;Данные!A2:A17&Данные!B2:B17;))

с текстом работает, а другие нет...
 
Ответить
СообщениеСпасибо, но в примере числа, а так может быть и текст.
Код
=ИНДЕКС(Данные!C2:C17;ПОИСКПОЗ(A2&B2;Данные!A2:A17&Данные!B2:B17;))

с текстом работает, а другие нет...

Автор - Sashagor1982
Дата добавления - 23.08.2016 в 19:58
jakim Дата: Вторник, 23.08.2016, 21:22 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 680
Репутация: 172 ±
Замечаний: 0% ±

Ещё два варианта.

Код
=LOOKUP(2;1/(A2:A17=F2)/(B2:B17=G2);C2:C17)

Код
=MAX(INDEX(C2:C17*(A2:A17=F2)*(B2:B17=G2);0))
К сообщению приложен файл: 111-1.xls(25Kb)


Сообщение отредактировал jakim - Вторник, 23.08.2016, 21:23
 
Ответить
Сообщение
Ещё два варианта.

Код
=LOOKUP(2;1/(A2:A17=F2)/(B2:B17=G2);C2:C17)

Код
=MAX(INDEX(C2:C17*(A2:A17=F2)*(B2:B17=G2);0))

Автор - jakim
Дата добавления - 23.08.2016 в 21:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск результата при совпадении в нескольких столбцах. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!