Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт при многовариантных/нескольких условиях - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт при многовариантных/нескольких условиях (Формулы/Formulas)
Подсчёт при многовариантных/нескольких условиях
Glip Дата: Четверг, 25.08.2016, 13:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Здравствуйте!

Помогите, пожалуйста, со следующей проблемой. Есть 6 групп с определённым набором маркеров (30 различных значений, в каждой группе различное количество маркеров), уникальным для каждой группы. Следует подсчитать количество групп, где используется каждый из данных маркеров. Пробовал по формуле:

Код
=СУММ($C$2:$C$31=$A$2:$A$7)*($D$2:$D$31=B2)


где ($C$2:$C$31) - столбец групп, сгруппированных по маркерам; ($A$2:$A$7) - столбец групп, сортированных по порядковому номеру,
($D$2:$D$31) - столбец маркеров, соответствующих определённым группам; B2 - ячейка со значением маркера (маркер1, условно говоря).

Но что-то неправильно делаю.

Надеюсь на помощь в решении задачки.
К сообщению приложен файл: __.xlsx(13Kb)


Сообщение отредактировал Manyasha - Четверг, 25.08.2016, 13:51
 
Ответить
СообщениеЗдравствуйте!

Помогите, пожалуйста, со следующей проблемой. Есть 6 групп с определённым набором маркеров (30 различных значений, в каждой группе различное количество маркеров), уникальным для каждой группы. Следует подсчитать количество групп, где используется каждый из данных маркеров. Пробовал по формуле:

Код
=СУММ($C$2:$C$31=$A$2:$A$7)*($D$2:$D$31=B2)


где ($C$2:$C$31) - столбец групп, сгруппированных по маркерам; ($A$2:$A$7) - столбец групп, сортированных по порядковому номеру,
($D$2:$D$31) - столбец маркеров, соответствующих определённым группам; B2 - ячейка со значением маркера (маркер1, условно говоря).

Но что-то неправильно делаю.

Надеюсь на помощь в решении задачки.

Автор - Glip
Дата добавления - 25.08.2016 в 13:48
buchlotnik Дата: Четверг, 25.08.2016, 13:53 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Glip, а в пределах группы маркер может повторяться?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеGlip, а в пределах группы маркер может повторяться?

Автор - buchlotnik
Дата добавления - 25.08.2016 в 13:53
Glip Дата: Четверг, 25.08.2016, 13:55 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
buchlotnik, нет, повторяться не может. В каждой группе все маркеры уникальные.


Сообщение отредактировал Glip - Четверг, 25.08.2016, 13:56
 
Ответить
Сообщениеbuchlotnik, нет, повторяться не может. В каждой группе все маркеры уникальные.

Автор - Glip
Дата добавления - 25.08.2016 в 13:55
китин Дата: Четверг, 25.08.2016, 14:08 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а может так ? если правильно понял
Код
=ЕСЛИ(D2="";"";СЧЁТЕСЛИ($D$2:$D$31;B2))
К сообщению приложен файл: 555555.xlsx(14Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа может так ? если правильно понял
Код
=ЕСЛИ(D2="";"";СЧЁТЕСЛИ($D$2:$D$31;B2))

Автор - китин
Дата добавления - 25.08.2016 в 14:08
buchlotnik Дата: Четверг, 25.08.2016, 14:10 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
если повторяться не могут их просто можно посчитать:
Код
=СЧЁТЕСЛИ($D$2:$D$31;B2)
или
Код
=СУММПРОИЗВ(--($D$2:$D$31=B2))
К сообщению приложен файл: -1-.xlsx(15Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеесли повторяться не могут их просто можно посчитать:
Код
=СЧЁТЕСЛИ($D$2:$D$31;B2)
или
Код
=СУММПРОИЗВ(--($D$2:$D$31=B2))

Автор - buchlotnik
Дата добавления - 25.08.2016 в 14:10
Glip Дата: Четверг, 25.08.2016, 14:29 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
а может так ? если правильно понял
[Перевод / Translate]
=ЕСЛИ(D2="";"";СЧЁТЕСЛИ($D$2:$D$31;B2))


Нет, надо подсчитать число групп, в которых встречаются маркеры от 1 до 30. А тут формула как-то считает не совсем то...
 
Ответить
Сообщение
а может так ? если правильно понял
[Перевод / Translate]
=ЕСЛИ(D2="";"";СЧЁТЕСЛИ($D$2:$D$31;B2))


Нет, надо подсчитать число групп, в которых встречаются маркеры от 1 до 30. А тут формула как-то считает не совсем то...

Автор - Glip
Дата добавления - 25.08.2016 в 14:29
Glip Дата: Четверг, 25.08.2016, 14:35 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
излишнее цитирование удалено
buchlotnik, по-моему самое то!! :) Надо осмыслить, но в ручном режиме проверяется на ура! Я затупил, видимо, пытаясь встраивать значения самих групп в решение...
 
Ответить
Сообщениеизлишнее цитирование удалено
buchlotnik, по-моему самое то!! :) Надо осмыслить, но в ручном режиме проверяется на ура! Я затупил, видимо, пытаясь встраивать значения самих групп в решение...

Автор - Glip
Дата добавления - 25.08.2016 в 14:35
китин Дата: Четверг, 25.08.2016, 14:39 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Glip, а чем отличается моя формула от формулы Михаила buchlotnik, ??????? Только тем, что там где пусто она не считает :D
а хотя да, условие ЕСЛИ тут лишнее
К сообщению приложен файл: -1-0.xlsx(15Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 25.08.2016, 14:43
 
Ответить
СообщениеGlip, а чем отличается моя формула от формулы Михаила buchlotnik, ??????? Только тем, что там где пусто она не считает :D
а хотя да, условие ЕСЛИ тут лишнее

Автор - китин
Дата добавления - 25.08.2016 в 14:39
Glip Дата: Четверг, 25.08.2016, 15:05 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
buchlotnik, китин, огромнейшее спасибо! Собственно, решение найдено без задействования групп в принципе. Как правильно отметил buchlotnik, для каждой группы в набор входят неповторяющиеся, уникальные в рамках группы маркеры. Обычным счётом, зная такую особенность, количество повторений маркеров можно приравнять к количеству групп, где повторяется определённый маркер. :)

Ещё раз спасибо всем!

P.S.: плюсики вроде бы поставил :)


Сообщение отредактировал Glip - Четверг, 25.08.2016, 15:11
 
Ответить
Сообщениеbuchlotnik, китин, огромнейшее спасибо! Собственно, решение найдено без задействования групп в принципе. Как правильно отметил buchlotnik, для каждой группы в набор входят неповторяющиеся, уникальные в рамках группы маркеры. Обычным счётом, зная такую особенность, количество повторений маркеров можно приравнять к количеству групп, где повторяется определённый маркер. :)

Ещё раз спасибо всем!

P.S.: плюсики вроде бы поставил :)

Автор - Glip
Дата добавления - 25.08.2016 в 15:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт при многовариантных/нескольких условиях (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!