Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/оставить только одно значение для данного идентификатора - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » оставить только одно значение для данного идентификатора (Формулы/Formulas)
оставить только одно значение для данного идентификатора
SergeyKorotun Дата: Понедельник, 29.08.2016, 12:13 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 300
Репутация: 15 ±
Замечаний: 0% ±

Excel 2007
Есть
1 100
1 100
3 130
2 120
2 120
2 120
Нужно
1 100 100
1 100
3 130 130
2 120 120
2 120
2 120
т.е. для одинаковых значений из первого столбца во втором столбце оставить только одно значение (любое, т.к. они равны).
К сообщению приложен файл: qwerty.xlsx(9Kb)
 
Ответить
СообщениеЕсть
1 100
1 100
3 130
2 120
2 120
2 120
Нужно
1 100 100
1 100
3 130 130
2 120 120
2 120
2 120
т.е. для одинаковых значений из первого столбца во втором столбце оставить только одно значение (любое, т.к. они равны).

Автор - SergeyKorotun
Дата добавления - 29.08.2016 в 12:13
китин Дата: Понедельник, 29.08.2016, 12:18 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам здравствуйте.как то так
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$1:A1;D1)=1;ВПР(D1;$A$1:$B$9;2;0);"")
К сообщению приложен файл: 222222.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи вам здравствуйте.как то так
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$1:A1;D1)=1;ВПР(D1;$A$1:$B$9;2;0);"")

Автор - китин
Дата добавления - 29.08.2016 в 12:18
buchlotnik Дата: Понедельник, 29.08.2016, 12:20 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ЕСЛИ(СЧЁТЕСЛИ($D$1:D1;D1)>1;"";B1)
К сообщению приложен файл: 4129921.xlsx(11Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=ЕСЛИ(СЧЁТЕСЛИ($D$1:D1;D1)>1;"";B1)

Автор - buchlotnik
Дата добавления - 29.08.2016 в 12:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » оставить только одно значение для данного идентификатора (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!