Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/При изменении в формуле строк по каким искать, нет значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » При изменении в формуле строк по каким искать, нет значения (Формулы/Formulas)
При изменении в формуле строк по каким искать, нет значения
Nikitos79 Дата: Вторник, 30.08.2016, 07:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Я копирую формулу с D4 в J4 и меняю в ней только данные по каким нужно искать, то есть $C4 на $I4 и C$2 на I$2. И в формуле должно появиться время, но строка остается пустой. Я не могу понять, что не так.
К сообщению приложен файл: 1111111.xlsx(14Kb)
 
Ответить
СообщениеЯ копирую формулу с D4 в J4 и меняю в ней только данные по каким нужно искать, то есть $C4 на $I4 и C$2 на I$2. И в формуле должно появиться время, но строка остается пустой. Я не могу понять, что не так.

Автор - Nikitos79
Дата добавления - 30.08.2016 в 07:14
китин Дата: Вторник, 30.08.2016, 07:46 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4351
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Вы в массиве из одного столбца ищете № строки и № столбца. в случае с 01.02.2016 это прокатит, т.к. № строки 1 и № столбца 1. а вот дальше не пройдет: № столбца будет 2, а у вас столбец всего один
Код
Общее!$C$2:$C$41
.попробуйте так формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Общее!$C$2:$C$41;ПОИСКПОЗ($I4&$I$2;Общее!$B$2:$B$41&Общее!$A$2:$A$41;));"")
или обычная формула
Код
=СУММПРОИЗВ(Общее!$C$2:$C$41*(Общее!$B$2:$B$41='1'!$I4)*('1'!$I$2:$N$2=Общее!$A$2:$A$41))
К сообщению приложен файл: 11111.xlsx(14Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеВы в массиве из одного столбца ищете № строки и № столбца. в случае с 01.02.2016 это прокатит, т.к. № строки 1 и № столбца 1. а вот дальше не пройдет: № столбца будет 2, а у вас столбец всего один
Код
Общее!$C$2:$C$41
.попробуйте так формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Общее!$C$2:$C$41;ПОИСКПОЗ($I4&$I$2;Общее!$B$2:$B$41&Общее!$A$2:$A$41;));"")
или обычная формула
Код
=СУММПРОИЗВ(Общее!$C$2:$C$41*(Общее!$B$2:$B$41='1'!$I4)*('1'!$I$2:$N$2=Общее!$A$2:$A$41))

Автор - китин
Дата добавления - 30.08.2016 в 07:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » При изменении в формуле строк по каким искать, нет значения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!