Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск совпадений и копирование недостоющих данных в листах - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск совпадений и копирование недостоющих данных в листах (Формулы/Formulas)
Поиск совпадений и копирование недостоющих данных в листах
I-Cube Дата: Вторник, 30.08.2016, 11:25 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем привет!
Столкнулся недавно с проблемой, в Active Directory пропали записи DNS. Теперь пытаюсь восстановить исходя из данных DHCP.
Таблица получается очень большой, чтобы не искать все руками, решил прибегнуть к помощи Excel.

Есть лист "DNS", он должен искать совпадения по столбцу "host" с листом "DHCP". В случае если на листе есть такое значение "host", тогда копировать рядом стоящий "IP" на лист "DNS'.

Ща наверное попробую объяснить проще...
На лист "DNS" надо скопировать значения "IP" с листа "DHCP". Если там есть такой "Host".

Пробовал делать на одном листе сначала. Сортировал, форматировал по уникальным значениям, фильтровал - но результата не добился.
Я так понимаю, надо все это делать при помощи макросов...
К сообщению приложен файл: _______.xlsx(11Kb)
 
Ответить
СообщениеВсем привет!
Столкнулся недавно с проблемой, в Active Directory пропали записи DNS. Теперь пытаюсь восстановить исходя из данных DHCP.
Таблица получается очень большой, чтобы не искать все руками, решил прибегнуть к помощи Excel.

Есть лист "DNS", он должен искать совпадения по столбцу "host" с листом "DHCP". В случае если на листе есть такое значение "host", тогда копировать рядом стоящий "IP" на лист "DNS'.

Ща наверное попробую объяснить проще...
На лист "DNS" надо скопировать значения "IP" с листа "DHCP". Если там есть такой "Host".

Пробовал делать на одном листе сначала. Сортировал, форматировал по уникальным значениям, фильтровал - но результата не добился.
Я так понимаю, надо все это делать при помощи макросов...

Автор - I-Cube
Дата добавления - 30.08.2016 в 11:25
Pelena Дата: Вторник, 30.08.2016, 11:38 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Код
=ВПР(A2;dhcp!$A$2:$B$6;2;0)
К сообщению приложен файл: 4817613.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ВПР(A2;dhcp!$A$2:$B$6;2;0)

Автор - Pelena
Дата добавления - 30.08.2016 в 11:38
I-Cube Дата: Вторник, 30.08.2016, 11:50 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena,
Спасибо, просто гениально!!!
 
Ответить
СообщениеPelena,
Спасибо, просто гениально!!!

Автор - I-Cube
Дата добавления - 30.08.2016 в 11:50
китин Дата: Вторник, 30.08.2016, 12:09 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
можно так
Код
=ПРОСМОТР(1;1/($A2=dhcp!$A$2:$A$6);dhcp!$B$2:$B$6)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеможно так
Код
=ПРОСМОТР(1;1/($A2=dhcp!$A$2:$A$6);dhcp!$B$2:$B$6)

Автор - китин
Дата добавления - 30.08.2016 в 12:09
I-Cube Дата: Вторник, 30.08.2016, 13:59 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин,
тоже хороший вариант thumb
 
Ответить
Сообщениекитин,
тоже хороший вариант thumb

Автор - I-Cube
Дата добавления - 30.08.2016 в 13:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск совпадений и копирование недостоющих данных в листах (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!