Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Преобразование столбца ячеек и автозаполнение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразование столбца ячеек и автозаполнение (Формулы/Formulas)
Преобразование столбца ячеек и автозаполнение
Sanyonchen Дата: Пятница, 02.09.2016, 14:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
За помощь буду крайне благодарен.
1. В общем, что имеется в виду под преобразованием столбца:
Есть столбец A, состоящий из списка фраз, его надо преобразовать в такой же столбец, в котором эти же фразы уже будут повторяться трижды
Пример на скриншоте

2. Автозаполнение - Надо растянуть столбец (1;1;1;2;2;2;3;3;3.....т.д.), чтобы он логически продолжался (4;4;4;5;5;5;6;6;6)
то, что у меня выходит - на втором скриншоте
Заранее очень благодарен всем, кто подскажет, в чем моя проблема :)
К сообщению приложен файл: 1273446.gif(6Kb) · 3185633.gif(49Kb)
 
Ответить
СообщениеЗа помощь буду крайне благодарен.
1. В общем, что имеется в виду под преобразованием столбца:
Есть столбец A, состоящий из списка фраз, его надо преобразовать в такой же столбец, в котором эти же фразы уже будут повторяться трижды
Пример на скриншоте

2. Автозаполнение - Надо растянуть столбец (1;1;1;2;2;2;3;3;3.....т.д.), чтобы он логически продолжался (4;4;4;5;5;5;6;6;6)
то, что у меня выходит - на втором скриншоте
Заранее очень благодарен всем, кто подскажет, в чем моя проблема :)

Автор - Sanyonchen
Дата добавления - 02.09.2016 в 14:16
_Boroda_ Дата: Пятница, 02.09.2016, 14:22 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Первый вопрос
Код
=ИНДЕКС(A$1:A$4;(СТРОКА(A1)-1)/3+1)

Второй вопрос нужно задавать в отдельной теме.
И свои файлы прикладывайте, по картинкам здесь редко кто работать будет
К сообщению приложен файл: 78675286.xlsm(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПервый вопрос
Код
=ИНДЕКС(A$1:A$4;(СТРОКА(A1)-1)/3+1)

Второй вопрос нужно задавать в отдельной теме.
И свои файлы прикладывайте, по картинкам здесь редко кто работать будет

Автор - _Boroda_
Дата добавления - 02.09.2016 в 14:22
Udik Дата: Пятница, 02.09.2016, 14:27 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1208
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
ещё вариант
Код

=ИНДЕКС($A$1:$A$5;ОКРУГЛВВЕРХ(СТРОКА()/3;0))
К сообщению приложен файл: 0t.xlsx(9Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениеещё вариант
Код

=ИНДЕКС($A$1:$A$5;ОКРУГЛВВЕРХ(СТРОКА()/3;0))

Автор - Udik
Дата добавления - 02.09.2016 в 14:27
Sanyonchen Дата: Пятница, 02.09.2016, 14:36 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Огромное спасибо, Udik и Boroda

Второй вопрос нужно задавать в отдельной теме.
И свои файлы прикладывайте, по картинкам здесь редко кто работать будет


Хорошо, теперь буду знать
 
Ответить
СообщениеОгромное спасибо, Udik и Boroda

Второй вопрос нужно задавать в отдельной теме.
И свои файлы прикладывайте, по картинкам здесь редко кто работать будет


Хорошо, теперь буду знать

Автор - Sanyonchen
Дата добавления - 02.09.2016 в 14:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразование столбца ячеек и автозаполнение (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!