Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование значений колонки по уникальным значениям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование значений колонки по уникальным значениям (Формулы/Formulas)
Суммирование значений колонки по уникальным значениям
ds79 Дата: Вторник, 06.09.2016, 10:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем привет!
поиск не помог, возможно сформулировать проблему не могу)
Просто, имеется две колонки, в одной наименование, в соседней сумма.
Помогите плиз, получить итог по каждому наименованию, т.е суммы похожих наименований нужно сложить.
К сообщению приложен файл: 0110554.xlsx(9Kb)
 
Ответить
СообщениеВсем привет!
поиск не помог, возможно сформулировать проблему не могу)
Просто, имеется две колонки, в одной наименование, в соседней сумма.
Помогите плиз, получить итог по каждому наименованию, т.е суммы похожих наименований нужно сложить.

Автор - ds79
Дата добавления - 06.09.2016 в 10:39
amfor Дата: Вторник, 06.09.2016, 10:43 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 36 ±
Замечаний: 0% ±

Excel 2010
Так?
К сообщению приложен файл: 0809825.xlsx(12Kb)


Семь бед - один RESET.
 
Ответить
СообщениеТак?

Автор - amfor
Дата добавления - 06.09.2016 в 10:43
buchlotnik Дата: Вторник, 06.09.2016, 10:50 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Сводная таблица в помощь
К сообщению приложен файл: 2561823.xlsx(13Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеСводная таблица в помощь

Автор - buchlotnik
Дата добавления - 06.09.2016 в 10:50
_Boroda_ Дата: Вторник, 06.09.2016, 10:58 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Уникальные можно формулой. Например, такой
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$24;ПОИСКПОЗ(;СЧЁТЕСЛИ(E$1:E1;$A$2:$A$24);));"")

А дальше СУММЕСЛИ

Но сводной лучше - даже на средних объемах формула будет тормозить
К сообщению приложен файл: 0110554_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУникальные можно формулой. Например, такой
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$24;ПОИСКПОЗ(;СЧЁТЕСЛИ(E$1:E1;$A$2:$A$24);));"")

А дальше СУММЕСЛИ

Но сводной лучше - даже на средних объемах формула будет тормозить

Автор - _Boroda_
Дата добавления - 06.09.2016 в 10:58
ds79 Дата: Вторник, 06.09.2016, 11:10 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
спасибо! :yes:
только это пример, на самом деле значений сотни, как применить СУММАЕСЛИ теперь самому? :( 1c-ciob.msk.ru


Сообщение отредактировал ds79 - Вторник, 06.09.2016, 13:27
 
Ответить
Сообщениеспасибо! :yes:
только это пример, на самом деле значений сотни, как применить СУММАЕСЛИ теперь самому? :( 1c-ciob.msk.ru

Автор - ds79
Дата добавления - 06.09.2016 в 11:10
_Boroda_ Дата: Вторник, 06.09.2016, 11:15 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вы в приложенных нами файлах примеры посмотрите и по аналогии напишите. Там просто всё.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВы в приложенных нами файлах примеры посмотрите и по аналогии напишите. Там просто всё.

Автор - _Boroda_
Дата добавления - 06.09.2016 в 11:15
sv2014 Дата: Вторник, 06.09.2016, 11:20 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 156
Репутация: 37 ±
Замечаний: 0% ±

Excel 2013
ds79, добрый день,если данных много,вариант макроса,кнопки test и очистка

[vba]
Код
Sub test()
     Dim z, i&, j&, m&: z = Range("A1:B" & Range("A" & Rows.Count).End(xlUp).Row).Value
    With CreateObject("scripting.dictionary"): .CompareMode = 1
    For i = 1 To UBound(z): t = z(i, 1)
         If .exists(t) = False Then
            m = m + 1: .Item(t) = m: For j = 1 To UBound(z, 2): z(m, j) = z(i, j): Next
         Else
            z(.Item(t), 2) = z(.Item(t), 2) + z(i, 2)
         End If
   Next
   Range("D3").Resize(.Count, UBound(z, 2)).Value = z
   End With
End Sub
[/vba]
К сообщению приложен файл: 9099201.xls(44Kb)
 
Ответить
Сообщениеds79, добрый день,если данных много,вариант макроса,кнопки test и очистка

[vba]
Код
Sub test()
     Dim z, i&, j&, m&: z = Range("A1:B" & Range("A" & Rows.Count).End(xlUp).Row).Value
    With CreateObject("scripting.dictionary"): .CompareMode = 1
    For i = 1 To UBound(z): t = z(i, 1)
         If .exists(t) = False Then
            m = m + 1: .Item(t) = m: For j = 1 To UBound(z, 2): z(m, j) = z(i, j): Next
         Else
            z(.Item(t), 2) = z(.Item(t), 2) + z(i, 2)
         End If
   Next
   Range("D3").Resize(.Count, UBound(z, 2)).Value = z
   End With
End Sub
[/vba]

Автор - sv2014
Дата добавления - 06.09.2016 в 11:20
buchlotnik Дата: Вторник, 06.09.2016, 11:34 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
на самом деле значений сотни
Цитата
даже на средних объемах формула будет тормозить
Цитата
Сводная таблица в помощь
yes


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Вторник, 06.09.2016, 11:37
 
Ответить
Сообщение
Цитата
на самом деле значений сотни
Цитата
даже на средних объемах формула будет тормозить
Цитата
Сводная таблица в помощь
yes

Автор - buchlotnik
Дата добавления - 06.09.2016 в 11:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование значений колонки по уникальным значениям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!