Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма чисел при нахождении условия ( название товара) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма чисел при нахождении условия ( название товара) (Формулы/Formulas)
Сумма чисел при нахождении условия ( название товара)
ВладимирR Дата: Вторник, 06.09.2016, 20:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Друзья, приветствую всех. Помогите, пожалуйста, составить формулу. Пытался сам через "если" - не смог ((
Есть ~ 60 столбцов, в 30 из них навзание грубо говоря товара в других 30 количество на складе. Столбцы рядом (название и кол-во).
Нужно чтобы если встречается то или иное название товара в столбцах, то количество этого товара суммировалось в какой то ячейке.

Другими словами встречается в 1м столбце товарА берется его количество из 2го столбца. Далее встречается,к примеру, снова товарА в 43 столбце и берется из 44 столбца его количество и суммируется к другим числам и в итоге в целевой ячейке мы получаем общее количество товараА со всем столбцов.

Прикрепляю фаил примера.
Буду очень благодарен!!
К сообщению приложен файл: 7804006.xlsx(9Kb)


Сообщение отредактировал ВладимирR - Вторник, 06.09.2016, 20:42
 
Ответить
СообщениеДрузья, приветствую всех. Помогите, пожалуйста, составить формулу. Пытался сам через "если" - не смог ((
Есть ~ 60 столбцов, в 30 из них навзание грубо говоря товара в других 30 количество на складе. Столбцы рядом (название и кол-во).
Нужно чтобы если встречается то или иное название товара в столбцах, то количество этого товара суммировалось в какой то ячейке.

Другими словами встречается в 1м столбце товарА берется его количество из 2го столбца. Далее встречается,к примеру, снова товарА в 43 столбце и берется из 44 столбца его количество и суммируется к другим числам и в итоге в целевой ячейке мы получаем общее количество товараА со всем столбцов.

Прикрепляю фаил примера.
Буду очень благодарен!!

Автор - ВладимирR
Дата добавления - 06.09.2016 в 20:40
Nic70y Дата: Вторник, 06.09.2016, 20:54 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3662
Репутация: 759 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММЕСЛИ(
найдите отличие в файле
К сообщению приложен файл: 9216411.xlsx(11Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММЕСЛИ(
найдите отличие в файле

Автор - Nic70y
Дата добавления - 06.09.2016 в 20:54
ВладимирR Дата: Вторник, 06.09.2016, 21:21 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
отличие не нашел между верхней частью и нижней. К сожалению, не понял почему вверху не суммирует частично, несмотря на то, что формулы одинаковые.
Также попробовал в свой фаил рабочий перенести - тоже не суммирует
 
Ответить
Сообщениеотличие не нашел между верхней частью и нижней. К сожалению, не понял почему вверху не суммирует частично, несмотря на то, что формулы одинаковые.
Также попробовал в свой фаил рабочий перенести - тоже не суммирует

Автор - ВладимирR
Дата добавления - 06.09.2016 в 21:21
Nic70y Дата: Вторник, 06.09.2016, 21:24 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3662
Репутация: 759 ±
Замечаний: 0% ±

Excel 2013
а между этими буквами A и А можете найти отличие?
(одна на кириллице, а другая на латинице)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 06.09.2016, 21:24
 
Ответить
Сообщениеа между этими буквами A и А можете найти отличие?
(одна на кириллице, а другая на латинице)

Автор - Nic70y
Дата добавления - 06.09.2016 в 21:24
ВладимирR Дата: Вторник, 06.09.2016, 21:26 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Дурья моя голова :D )))
благодарю)
 
Ответить
СообщениеДурья моя голова :D )))
благодарю)

Автор - ВладимирR
Дата добавления - 06.09.2016 в 21:26
_Boroda_ Дата: Вторник, 06.09.2016, 21:37 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9822
Репутация: 4147 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Чтобы не морочиться, можно еще вот так написать
Код
=СУММПРОИЗВ(СУММЕСЛИ(B1:L5;{"товарA";"товарА"};A1:K5))

Ну или СУММЕСЛИ + СУММЕСЛИ
К сообщению приложен файл: 7804006_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЧтобы не морочиться, можно еще вот так написать
Код
=СУММПРОИЗВ(СУММЕСЛИ(B1:L5;{"товарA";"товарА"};A1:K5))

Ну или СУММЕСЛИ + СУММЕСЛИ

Автор - _Boroda_
Дата добавления - 06.09.2016 в 21:37
ВладимирR Дата: Вторник, 06.09.2016, 21:46 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Отличный вариант,более гибкий! его буду использовать!
Nic70y и Boroda огромное спасибо!!
 
Ответить
СообщениеОтличный вариант,более гибкий! его буду использовать!
Nic70y и Boroda огромное спасибо!!

Автор - ВладимирR
Дата добавления - 06.09.2016 в 21:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма чисел при нахождении условия ( название товара) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!