Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/найти количество заключенных договоров по дате - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » найти количество заключенных договоров по дате (Формулы/Formulas)
найти количество заключенных договоров по дате
velikoleg Дата: Понедельник, 12.09.2016, 18:49 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем доброго времени суток!
В очередной раз обращаюсь к Вам за помощью. Появилась необходимость в одной из таблиц найти количество заключенных договоров по дате. Вычислить и высчитать ОБЩЕЕ количество получилось сразу. А вот посчитать кто сколько заключил за определённый промежуток например с 01.07.2016 по 20.07.2016 или с 01.07.2016 по 01.08.2016 никак не соображу как написать формулу. Подскажите пожалуйста кто знает!
К сообщению приложен файл: _2016.xlsx(90Kb)
 
Ответить
СообщениеВсем доброго времени суток!
В очередной раз обращаюсь к Вам за помощью. Появилась необходимость в одной из таблиц найти количество заключенных договоров по дате. Вычислить и высчитать ОБЩЕЕ количество получилось сразу. А вот посчитать кто сколько заключил за определённый промежуток например с 01.07.2016 по 20.07.2016 или с 01.07.2016 по 01.08.2016 никак не соображу как написать формулу. Подскажите пожалуйста кто знает!

Автор - velikoleg
Дата добавления - 12.09.2016 в 18:49
Pelena Дата: Понедельник, 12.09.2016, 18:59 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Так подойдёт?
Код
=СЧЁТЕСЛИМН(П_К!$B$6:$B$300;"<="&$A$6;П_К!$B$6:$B$300;">="&$A$5;П_К!$H$6:$H$300;B2)

Первую формулу тоже немного подкорректировала
К сообщению приложен файл: 8161008.xlsx(90Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Так подойдёт?
Код
=СЧЁТЕСЛИМН(П_К!$B$6:$B$300;"<="&$A$6;П_К!$B$6:$B$300;">="&$A$5;П_К!$H$6:$H$300;B2)

Первую формулу тоже немного подкорректировала

Автор - Pelena
Дата добавления - 12.09.2016 в 18:59
velikoleg Дата: Понедельник, 12.09.2016, 19:46 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
ДА ТО ЧТО НУЖНО!!! hands СУПЕР! Я ВАС ОБОЖАЮ ВСЕХ!!!
 
Ответить
СообщениеДА ТО ЧТО НУЖНО!!! hands СУПЕР! Я ВАС ОБОЖАЮ ВСЕХ!!!

Автор - velikoleg
Дата добавления - 12.09.2016 в 19:46
_Boroda_ Дата: Понедельник, 12.09.2016, 21:13 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А поизвращаться?
Код
=СУММПРОИЗВ(--ТЕКСТ(П_К!B$6:B$300*(П_К!H$6:H$300=B2);"[<"&A$5&"]\0;[>"&A$6&"]\0;1"))

и массивная
Код
=СЧЁТ(1/ТЕКСТ(П_К!B$6:B$300*(П_К!H$6:H$300=B2);"[<"&A$5&"]\0;[>"&A$6&"]\0;0"))


Кстати, Олег, в Вашей формуле за год поменяйте доллары и тогда там не нужен массивный ввод
Было
Код
=СЧЁТЕСЛИМН(П_К!$B6:$B300;"<="&A$3;П_К!$H6:$H300;B2)

Нужно
Код
=СЧЁТЕСЛИМН(П_К!B$6:B$300;"<="&A$3;П_К!H$6:H$300;B2)
К сообщению приложен файл: _2016867468464_.xlsx(90Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА поизвращаться?
Код
=СУММПРОИЗВ(--ТЕКСТ(П_К!B$6:B$300*(П_К!H$6:H$300=B2);"[<"&A$5&"]\0;[>"&A$6&"]\0;1"))

и массивная
Код
=СЧЁТ(1/ТЕКСТ(П_К!B$6:B$300*(П_К!H$6:H$300=B2);"[<"&A$5&"]\0;[>"&A$6&"]\0;0"))


Кстати, Олег, в Вашей формуле за год поменяйте доллары и тогда там не нужен массивный ввод
Было
Код
=СЧЁТЕСЛИМН(П_К!$B6:$B300;"<="&A$3;П_К!$H6:$H300;B2)

Нужно
Код
=СЧЁТЕСЛИМН(П_К!B$6:B$300;"<="&A$3;П_К!H$6:H$300;B2)

Автор - _Boroda_
Дата добавления - 12.09.2016 в 21:13
velikoleg Дата: Вторник, 13.09.2016, 11:01 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо Александр за советы! Попробую сегодня поизвращаться :D !
Формулу =СЧЁТЕСЛИМН(П_К!$B6:$B300;"<="&A$3;П_К!$H6:$H300;B2) брал с Вашего примера из другой таблицы, потому и сделал её массивом как там. (Со школьных лет не перечу учителям) :)
Спасибо ВСЕМ, что помогаете и учите работать в EXCEL и тем самым упрощать работу.
 
Ответить
СообщениеСпасибо Александр за советы! Попробую сегодня поизвращаться :D !
Формулу =СЧЁТЕСЛИМН(П_К!$B6:$B300;"<="&A$3;П_К!$H6:$H300;B2) брал с Вашего примера из другой таблицы, потому и сделал её массивом как там. (Со школьных лет не перечу учителям) :)
Спасибо ВСЕМ, что помогаете и учите работать в EXCEL и тем самым упрощать работу.

Автор - velikoleg
Дата добавления - 13.09.2016 в 11:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » найти количество заключенных договоров по дате (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!