Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка значений из заданного диапазона - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений из заданного диапазона (Формулы/Formulas)
Подстановка значений из заданного диапазона
Catcrew Дата: Вторник, 13.09.2016, 16:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!

Помогите, пожалуйста, с решением задачки:
У меня есть столбец А, в него я вручную вбиваю текст.
Есть столбец B, в котором я руками из списка выбираю категорию, к которой принадлежит значение из соседней A.
Хочу сделать так, чтобы категории в столбце B автоматически проставлялись на основании содержания ячейки в А.
Вижу так - на отдельном листе создается список из категорий и список ключевых слов без падежей и окончаний к каждой категории.
Когда я ввожу в А значение, B смотрит, если ли в тексте А слово из списка на отдельном листе. Если есть совпадение - то B заполняется категорией, соответствующей ключевому слову.

Формула должна видеть - какую ячейку сканировать, на наличие каких слов ее проверять, из какого диапазона выбирать подставляемое значение.
Категорий около 7, ключевых слов к каждой около 10.
 
Ответить
СообщениеДобрый день!

Помогите, пожалуйста, с решением задачки:
У меня есть столбец А, в него я вручную вбиваю текст.
Есть столбец B, в котором я руками из списка выбираю категорию, к которой принадлежит значение из соседней A.
Хочу сделать так, чтобы категории в столбце B автоматически проставлялись на основании содержания ячейки в А.
Вижу так - на отдельном листе создается список из категорий и список ключевых слов без падежей и окончаний к каждой категории.
Когда я ввожу в А значение, B смотрит, если ли в тексте А слово из списка на отдельном листе. Если есть совпадение - то B заполняется категорией, соответствующей ключевому слову.

Формула должна видеть - какую ячейку сканировать, на наличие каких слов ее проверять, из какого диапазона выбирать подставляемое значение.
Категорий около 7, ключевых слов к каждой около 10.

Автор - Catcrew
Дата добавления - 13.09.2016 в 16:42
Pelena Дата: Вторник, 13.09.2016, 17:32 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9864
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Файл с примером?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл с примером?

Автор - Pelena
Дата добавления - 13.09.2016 в 17:32
Catcrew Дата: Вторник, 13.09.2016, 18:14 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena,
Вложил, красным выделил связь.
Надеюсь, понятно.
К сообщению приложен файл: __.xlsx(10Kb)
 
Ответить
СообщениеPelena,
Вложил, красным выделил связь.
Надеюсь, понятно.

Автор - Catcrew
Дата добавления - 13.09.2016 в 18:14
Pelena Дата: Вторник, 13.09.2016, 18:44 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9864
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($F$2:$F$27;ПОИСКПОЗ(1;($H$2:$H$27<>"")*ЕЧИСЛО(ПОИСК($H$2:$H$27;B2));0));"Прочее")
К сообщению приложен файл: -3-.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($F$2:$F$27;ПОИСКПОЗ(1;($H$2:$H$27<>"")*ЕЧИСЛО(ПОИСК($H$2:$H$27;B2));0));"Прочее")

Автор - Pelena
Дата добавления - 13.09.2016 в 18:44
Catcrew Дата: Вторник, 13.09.2016, 19:09 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Черт возьми, Pelena! Но как?!
Огромное спасибо за помощь!
Пол дня искал решение
 
Ответить
СообщениеЧерт возьми, Pelena! Но как?!
Огромное спасибо за помощь!
Пол дня искал решение

Автор - Catcrew
Дата добавления - 13.09.2016 в 19:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений из заданного диапазона (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!