Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подстановка значений через Индекс поискпоз - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подстановка значений через Индекс поискпоз (Формулы/Formulas)
подстановка значений через Индекс поискпоз
Pickwik Дата: Вторник, 13.09.2016, 18:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем привет!

Есть список клиентов которые находятся во вкладках: ПН,ВТ,СР,,,,,,
Дни недели (ПН,ВТ,,,,) делятся на зоны, всего зон пять (5). Во вкладках (ПН,ВТ,,,,) в столбце "J" видно к какой зоне относится конкретный клиент.
Необходимо, что бы клиенты из конкретного дня недели переносились в свою зону во вложении "одеяло"
Если в одной зоне клиент повторяется, то в "одеяле" не отображается.
К сообщению приложен файл: --.xlsx(48Kb)
 
Ответить
СообщениеВсем привет!

Есть список клиентов которые находятся во вкладках: ПН,ВТ,СР,,,,,,
Дни недели (ПН,ВТ,,,,) делятся на зоны, всего зон пять (5). Во вкладках (ПН,ВТ,,,,) в столбце "J" видно к какой зоне относится конкретный клиент.
Необходимо, что бы клиенты из конкретного дня недели переносились в свою зону во вложении "одеяло"
Если в одной зоне клиент повторяется, то в "одеяле" не отображается.

Автор - Pickwik
Дата добавления - 13.09.2016 в 18:07
Pelena Дата: Вторник, 13.09.2016, 18:34 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10462
Репутация: 2362 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(ПН!$C$2:$C$100;НАИМЕНЬШИЙ(ЕСЛИ(B$1=ПН!$J$2:$J$100;СТРОКА(ПН!$J$2:$J$100)-1);A2));"")
К сообщению приложен файл: 4609929.xlsx(49Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(ПН!$C$2:$C$100;НАИМЕНЬШИЙ(ЕСЛИ(B$1=ПН!$J$2:$J$100;СТРОКА(ПН!$J$2:$J$100)-1);A2));"")

Автор - Pelena
Дата добавления - 13.09.2016 в 18:34
Pickwik Дата: Среда, 14.09.2016, 12:20 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - Pickwik
Дата добавления - 14.09.2016 в 12:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подстановка значений через Индекс поискпоз (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!