Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет кол-ва человек одинакового года из полной даты рожд. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва человек одинакового года из полной даты рожд. (Формулы/Formulas)
Подсчет кол-ва человек одинакового года из полной даты рожд.
Nickolas Дата: Четверг, 15.09.2016, 05:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Друзья, помогите с формулой, для меня это сложновато.
Решения ни где не нашел пока.

Задача:

Есть две таблицы на разных вкладках.
В первой вкладке таблица с ФИО и полной датой рождения, на второй вкладке просто год от даты рождения и принадлежность к полу (мужчины и женщины).
Нужно с первой таблицы отсортировать во вторую таблицу кол-во людей по году и полу.

Заранее благодарю, надеюсь на вашу помощь.!
К сообщению приложен файл: 7495250.xlsx(9Kb)
 
Ответить
СообщениеДрузья, помогите с формулой, для меня это сложновато.
Решения ни где не нашел пока.

Задача:

Есть две таблицы на разных вкладках.
В первой вкладке таблица с ФИО и полной датой рождения, на второй вкладке просто год от даты рождения и принадлежность к полу (мужчины и женщины).
Нужно с первой таблицы отсортировать во вторую таблицу кол-во людей по году и полу.

Заранее благодарю, надеюсь на вашу помощь.!

Автор - Nickolas
Дата добавления - 15.09.2016 в 05:39
amfor Дата: Четверг, 15.09.2016, 07:29 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 36 ±
Замечаний: 0% ±

Excel 2010
Так?
К сообщению приложен файл: 7361634.xlsx(12Kb)


Семь бед - один RESET.
 
Ответить
СообщениеТак?

Автор - amfor
Дата добавления - 15.09.2016 в 07:29
китин Дата: Четверг, 15.09.2016, 07:33 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
может так? формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$5:$B$10;НАИМЕНЬШИЙ(ЕСЛИ((ГОД(Лист1!$D$5:$D$10)=Лист2!B$5)*(Лист1!$C$5:$C$10=C$5);СТРОКА(Лист1!$B$5:$B$10)-4);СТРОКА(A1)));"")

поиграйтесь с выпадающим списком в табл.2 где муж и жен
блин не то. надо посчитать, а я фамилии вытащил. Тогда пост повыше вам в помощь
К сообщению приложен файл: 444111.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 15.09.2016, 07:39
 
Ответить
Сообщениеможет так? формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$5:$B$10;НАИМЕНЬШИЙ(ЕСЛИ((ГОД(Лист1!$D$5:$D$10)=Лист2!B$5)*(Лист1!$C$5:$C$10=C$5);СТРОКА(Лист1!$B$5:$B$10)-4);СТРОКА(A1)));"")

поиграйтесь с выпадающим списком в табл.2 где муж и жен
блин не то. надо посчитать, а я фамилии вытащил. Тогда пост повыше вам в помощь

Автор - китин
Дата добавления - 15.09.2016 в 07:33
Nickolas Дата: Четверг, 15.09.2016, 08:16 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
китин, да, нужно именно считать. Но все равно спасибо.

amfor, да, так, благодарю, щас попытаюсь прикрутить его на свой файл, если что отпишусь...
 
Ответить
Сообщениекитин, да, нужно именно считать. Но все равно спасибо.

amfor, да, так, благодарю, щас попытаюсь прикрутить его на свой файл, если что отпишусь...

Автор - Nickolas
Дата добавления - 15.09.2016 в 08:16
Nickolas Дата: Четверг, 15.09.2016, 08:54 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Попробовал в документе, он 2010 год вроде правильно посчитал, а 2009 год с девочками не правильно.
Формулы вроде бы все правильные, в чем засада?
К сообщению приложен файл: 00111222.xlsx(16Kb)
 
Ответить
СообщениеПопробовал в документе, он 2010 год вроде правильно посчитал, а 2009 год с девочками не правильно.
Формулы вроде бы все правильные, в чем засада?

Автор - Nickolas
Дата добавления - 15.09.2016 в 08:54
Pelena Дата: Четверг, 15.09.2016, 09:08 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9873
Репутация: 2263 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Критерий >=01.01.2009 включает в себя и 2010 год. Поэтому надо либо использовать СЧЁТЕСЛИМН() с двумя условиями,
Код
=СЧЁТЕСЛИМН('1 класс'!$F$5:$F$34;">="&D4;'1 класс'!$F$5:$F$34;"<"&B4)

либо из полученного результата вычитать то, что получилось для 2010 года
Код
=СЧЁТЕСЛИ('1 класс'!$F$5:$F$34;">="&D4)-B5


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКритерий >=01.01.2009 включает в себя и 2010 год. Поэтому надо либо использовать СЧЁТЕСЛИМН() с двумя условиями,
Код
=СЧЁТЕСЛИМН('1 класс'!$F$5:$F$34;">="&D4;'1 класс'!$F$5:$F$34;"<"&B4)

либо из полученного результата вычитать то, что получилось для 2010 года
Код
=СЧЁТЕСЛИ('1 класс'!$F$5:$F$34;">="&D4)-B5

Автор - Pelena
Дата добавления - 15.09.2016 в 09:08
_Boroda_ Дата: Четверг, 15.09.2016, 09:11 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
И так еще можно
Код
=СУММПРОИЗВ(--(ГОД(Лист1!$D5:$D10)=B5))

Код
=СУММПРОИЗВ((Лист1!$C5:$C10="жен")*(ГОД(Лист1!$D5:$D10)=B5))
К сообщению приложен файл: 7495250_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИ так еще можно
Код
=СУММПРОИЗВ(--(ГОД(Лист1!$D5:$D10)=B5))

Код
=СУММПРОИЗВ((Лист1!$C5:$C10="жен")*(ГОД(Лист1!$D5:$D10)=B5))

Автор - _Boroda_
Дата добавления - 15.09.2016 в 09:11
amfor Дата: Четверг, 15.09.2016, 09:12 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 36 ±
Замечаний: 0% ±

Excel 2010
Замените в формулах на 2009 год ">="&D4 на "<"&B4.


Семь бед - один RESET.
 
Ответить
СообщениеЗамените в формулах на 2009 год ">="&D4 на "<"&B4.

Автор - amfor
Дата добавления - 15.09.2016 в 09:12
Nickolas Дата: Четверг, 15.09.2016, 15:04 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо друзья, буду дальше разбираться...
 
Ответить
СообщениеСпасибо друзья, буду дальше разбираться...

Автор - Nickolas
Дата добавления - 15.09.2016 в 15:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва человек одинакового года из полной даты рожд. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!