Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчитать кол-во дней с нулевым остатком и серию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчитать кол-во дней с нулевым остатком и серию (Формулы/Formulas)
Подсчитать кол-во дней с нулевым остатком и серию
vermut Дата: Четверг, 15.09.2016, 09:46 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Исходные данные содержат нулевые остатки в разрезе дней, как подсчитать кол-во дней с нулевым остатком, и максимальное кол-во дней нулевых подряд( максимальную серию)?Файлик приложила.
К сообщению приложен файл: 5670098.xls(56Kb)
 
Ответить
СообщениеИсходные данные содержат нулевые остатки в разрезе дней, как подсчитать кол-во дней с нулевым остатком, и максимальное кол-во дней нулевых подряд( максимальную серию)?Файлик приложила.

Автор - vermut
Дата добавления - 15.09.2016 в 09:46
_Boroda_ Дата: Четверг, 15.09.2016, 10:01 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Количество
Код
=СЧЁТЕСЛИ(D2:L2;)

а про серию нужно подумать

Добавлено
Вот такой вариант
Код
=МАКС(;МУМНОЖ({-1;1};НАИМЕНЬШИЙ(ЕСЛИ(D2:L2;(СТОЛБЕЦ(A:I)););(СТОЛБЕЦ(B:I))-{1:0}))-1)

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
К сообщению приложен файл: 5670098_1.xls(38Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Четверг, 15.09.2016, 10:35
 
Ответить
СообщениеКоличество
Код
=СЧЁТЕСЛИ(D2:L2;)

а про серию нужно подумать

Добавлено
Вот такой вариант
Код
=МАКС(;МУМНОЖ({-1;1};НАИМЕНЬШИЙ(ЕСЛИ(D2:L2;(СТОЛБЕЦ(A:I)););(СТОЛБЕЦ(B:I))-{1:0}))-1)

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер

Автор - _Boroda_
Дата добавления - 15.09.2016 в 10:01
vermut Дата: Четверг, 15.09.2016, 10:06 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
нужно подумать
СПАСИБО!
 
Ответить
Сообщение
нужно подумать
СПАСИБО!

Автор - vermut
Дата добавления - 15.09.2016 в 10:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчитать кол-во дней с нулевым остатком и серию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!