Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отоброжение нужных дат - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отоброжение нужных дат (Формулы/Formulas)
Отоброжение нужных дат
Nikitos79 Дата: Пятница, 16.09.2016, 11:15 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
В столбце А1:A31 стоят нужные мне даты, а допустим в строках С1:G1 даты за весь год.
Мне требуется чтобы если в строках А1:A31 есть даты какие указаны в С1:G1, то в цветных ячейках они бы отображались, а если нет, то оставались пустыми.
В цветных ячейках я указал какой должен быть результат при действии формулы.
К сообщению приложен файл: _Microsoft_Exce.xlsx(10Kb)
 
Ответить
СообщениеВ столбце А1:A31 стоят нужные мне даты, а допустим в строках С1:G1 даты за весь год.
Мне требуется чтобы если в строках А1:A31 есть даты какие указаны в С1:G1, то в цветных ячейках они бы отображались, а если нет, то оставались пустыми.
В цветных ячейках я указал какой должен быть результат при действии формулы.

Автор - Nikitos79
Дата добавления - 16.09.2016 в 11:15
Karataev Дата: Пятница, 16.09.2016, 11:23 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 890
Репутация: 336 ±
Замечаний: 0% ±

Excel
Формула для "C3":
Код
=ЕСЛИ(СЧЁТЕСЛИ($A:$A;C1)<>0;C1;"Пусто")
К сообщению приложен файл: 2659714.xlsx(10Kb)




Сообщение отредактировал Karataev - Пятница, 16.09.2016, 11:26
 
Ответить
СообщениеФормула для "C3":
Код
=ЕСЛИ(СЧЁТЕСЛИ($A:$A;C1)<>0;C1;"Пусто")

Автор - Karataev
Дата добавления - 16.09.2016 в 11:23
pabchek Дата: Пятница, 16.09.2016, 11:30 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 751
Репутация: 169 ±
Замечаний: 0% ±

Excel 2007
Как вариант
Код
=ЕСЛИОШИБКА(ЕСЛИ(ПОИСКПОЗ(C1;$A$1:$A$30;0);C1);"")

если вместо "" можно 0, еще вариант
Код
=СУММПРОИЗВ(--(C1=$A$1:$A$30))*C1

Код
=СУММПРОИЗВ(Ч(C1=$A$1:$A$30))*C1


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 16.09.2016, 11:41
 
Ответить
СообщениеКак вариант
Код
=ЕСЛИОШИБКА(ЕСЛИ(ПОИСКПОЗ(C1;$A$1:$A$30;0);C1);"")

если вместо "" можно 0, еще вариант
Код
=СУММПРОИЗВ(--(C1=$A$1:$A$30))*C1

Код
=СУММПРОИЗВ(Ч(C1=$A$1:$A$30))*C1

Автор - pabchek
Дата добавления - 16.09.2016 в 11:30
_Boroda_ Дата: Пятница, 16.09.2016, 11:52 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11546
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИЛИ(C1=$A1:$A30)*C1

И формат ячеек
ДД.ММ.ГГГГ;
К сообщению приложен файл: 6216082.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИЛИ(C1=$A1:$A30)*C1

И формат ячеек
ДД.ММ.ГГГГ;

Автор - _Boroda_
Дата добавления - 16.09.2016 в 11:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отоброжение нужных дат (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!