Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сбой функции просмотр если в диапазоне есть пустоты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбой функции просмотр если в диапазоне есть пустоты (Формулы/Formulas)
Сбой функции просмотр если в диапазоне есть пустоты
Arti Дата: Пятница, 23.09.2016, 10:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток товарищи!
Помогите пожалуйста понять, почему функция просмотр выдает #Н/Д, если в диапазоне присутствуют пустые ячейки.
Можно ли модифицировать ее, чтоб суммировалось корректно (файл во вложении).


Я не я и суета не моя
 
Ответить
СообщениеДоброго времени суток товарищи!
Помогите пожалуйста понять, почему функция просмотр выдает #Н/Д, если в диапазоне присутствуют пустые ячейки.
Можно ли модифицировать ее, чтоб суммировалось корректно (файл во вложении).

Автор - Arti
Дата добавления - 23.09.2016 в 10:11
Pelena Дата: Пятница, 23.09.2016, 10:14 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Файл не приложился


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл не приложился

Автор - Pelena
Дата добавления - 23.09.2016 в 10:14
Arti Дата: Пятница, 23.09.2016, 10:18 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Руки крюки! Почему не приложился, без понятия.
К сообщению приложен файл: Arti1.xls(24Kb)


Я не я и суета не моя
 
Ответить
СообщениеРуки крюки! Почему не приложился, без понятия.

Автор - Arti
Дата добавления - 23.09.2016 в 10:18
Karataev Дата: Пятница, 23.09.2016, 10:25 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
А зачем Вам что-то придумывать? Чем Вас сейчас не устраивают три формулы в AF6:AH6?
Эти три формулы можно так записать одной формулой:
Код
=СЧЁТЕСЛИ($D$6:$AD$6;$AF$5)*$AF$4+СЧЁТЕСЛИ($D$6:$AD$6;$AG$5)*$AG$4




Сообщение отредактировал Karataev - Пятница, 23.09.2016, 10:27
 
Ответить
СообщениеА зачем Вам что-то придумывать? Чем Вас сейчас не устраивают три формулы в AF6:AH6?
Эти три формулы можно так записать одной формулой:
Код
=СЧЁТЕСЛИ($D$6:$AD$6;$AF$5)*$AF$4+СЧЁТЕСЛИ($D$6:$AD$6;$AG$5)*$AG$4

Автор - Karataev
Дата добавления - 23.09.2016 в 10:25
AlexM Дата: Пятница, 23.09.2016, 10:26 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3048
Репутация: 739 ±
Замечаний: 0% ±

Формула массива
Код
=СУММ((ТРАНСП(D6:AD6)=AF5:AG5)*AF4:AG4)
К сообщению приложен файл: Arti1_01.xls(24Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 23.09.2016, 10:28
 
Ответить
СообщениеФормула массива
Код
=СУММ((ТРАНСП(D6:AD6)=AF5:AG5)*AF4:AG4)

Автор - AlexM
Дата добавления - 23.09.2016 в 10:26
_Boroda_ Дата: Пятница, 23.09.2016, 10:33 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Обычной формулой
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(D6:AD6;AF5:AG5)*AF4:AG4)
К сообщению приложен файл: Arti1_1.xls(25Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОбычной формулой
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(D6:AD6;AF5:AG5)*AF4:AG4)

Автор - _Boroda_
Дата добавления - 23.09.2016 в 10:33
Arti Дата: Пятница, 23.09.2016, 10:36 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Karataev, дело в том, что обозначений в диапазоне и значений гораздо больше, чем показаны в примере и создавать через "+" дело муторное.

AlexM очень оригинальное решение, даже не рассматривал вариант транспонировать! Супер! Большое человечье спасибо!


Я не я и суета не моя
 
Ответить
СообщениеKarataev, дело в том, что обозначений в диапазоне и значений гораздо больше, чем показаны в примере и создавать через "+" дело муторное.

AlexM очень оригинальное решение, даже не рассматривал вариант транспонировать! Супер! Большое человечье спасибо!

Автор - Arti
Дата добавления - 23.09.2016 в 10:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбой функции просмотр если в диапазоне есть пустоты (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!