Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отображение результата в зависимости от чисел после запятой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение результата в зависимости от чисел после запятой (Формулы/Formulas)
Отображение результата в зависимости от чисел после запятой
ivanov1974 Дата: Вторник, 27.09.2016, 14:17 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 138
Репутация: 1 ±
Замечаний: 0% ±

Здравствуйте знатоки Excel. Прошу помочь с формулой. В ячейке А1 число с точностью четыре знака после запятой. Нужна формула в В1, которая отображала бы: если в А1 третья и четвертая цыфра нули, отображаться должна 1, если не нули, тогда должно отображаться содержимое А1. У самого получается только с несколькими промежуточными формулами.
К сообщению приложен файл: 3250970.xls(15Kb)
 
Ответить
СообщениеЗдравствуйте знатоки Excel. Прошу помочь с формулой. В ячейке А1 число с точностью четыре знака после запятой. Нужна формула в В1, которая отображала бы: если в А1 третья и четвертая цыфра нули, отображаться должна 1, если не нули, тогда должно отображаться содержимое А1. У самого получается только с несколькими промежуточными формулами.

Автор - ivanov1974
Дата добавления - 27.09.2016 в 14:17
buchlotnik Дата: Вторник, 27.09.2016, 14:25 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2616
Репутация: 746 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
я может чего не догнал - нельзя просто формат Общий поставить?
К сообщению приложен файл: 7476840.xls(28Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениея может чего не догнал - нельзя просто формат Общий поставить?

Автор - buchlotnik
Дата добавления - 27.09.2016 в 14:25
_Boroda_ Дата: Вторник, 27.09.2016, 14:25 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вариант
Код
=ЕСЛИ(-ПРАВБ(ТЕКСТ(A1;",0000");2);A1;1)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вариант
Код
=ЕСЛИ(-ПРАВБ(ТЕКСТ(A1;",0000");2);A1;1)

Автор - _Boroda_
Дата добавления - 27.09.2016 в 14:25
ivanov1974 Дата: Вторник, 27.09.2016, 14:28 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 138
Репутация: 1 ±
Замечаний: 0% ±

Boroda, спасибо, то, что нужно. Вопрос закрыт
 
Ответить
СообщениеBoroda, спасибо, то, что нужно. Вопрос закрыт

Автор - ivanov1974
Дата добавления - 27.09.2016 в 14:28
ivanov1974 Дата: Вторник, 27.09.2016, 20:30 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 138
Репутация: 1 ±
Замечаний: 0% ±

buchlotnik, спасибо за участие, но надо так, как написал Boroda
 
Ответить
Сообщениеbuchlotnik, спасибо за участие, но надо так, как написал Boroda

Автор - ivanov1974
Дата добавления - 27.09.2016 в 20:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение результата в зависимости от чисел после запятой (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!