Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР для поиска по именованному диапазону (другой лист) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР для поиска по именованному диапазону (другой лист) (Формулы/Formulas)
ВПР для поиска по именованному диапазону (другой лист)
Selena Дата: Вторник, 27.09.2016, 14:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте!
Необходимо решить такую задачу для личных нужд: есть Лист1 с таблицей продуктов питания, для каждого продукта указана калорийность и содержание питательных веществ. Для названий продуктов создан именованный диапазон "Продукты". На Листе2 составляется меню, где из выпадающего списка выбираются продукты из данного диапазона. Нужно в соседних ячейках выводить соответствующие данному продукту параметры - калорийность, белки и т.д. (в дальнейшем эти даннные будут использоваться для суммирования)

Я пробую разные варианты формулы, но в ней ошибка, предполагаю что дело в формате номера столбца. Помогите, пожалуйста, исправить ошибку. Файл примера прилагаю.
К сообщению приложен файл: example.xlsx(12Kb)
 
Ответить
СообщениеЗдравствуйте!
Необходимо решить такую задачу для личных нужд: есть Лист1 с таблицей продуктов питания, для каждого продукта указана калорийность и содержание питательных веществ. Для названий продуктов создан именованный диапазон "Продукты". На Листе2 составляется меню, где из выпадающего списка выбираются продукты из данного диапазона. Нужно в соседних ячейках выводить соответствующие данному продукту параметры - калорийность, белки и т.д. (в дальнейшем эти даннные будут использоваться для суммирования)

Я пробую разные варианты формулы, но в ней ошибка, предполагаю что дело в формате номера столбца. Помогите, пожалуйста, исправить ошибку. Файл примера прилагаю.

Автор - Selena
Дата добавления - 27.09.2016 в 14:54
_Boroda_ Дата: Вторник, 27.09.2016, 15:01 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ВПР($A2;Table1[#Все];СТОЛБЕЦ();)
К сообщению приложен файл: example-5-1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ВПР($A2;Table1[#Все];СТОЛБЕЦ();)

Автор - _Boroda_
Дата добавления - 27.09.2016 в 15:01
SLAVICK Дата: Вторник, 27.09.2016, 15:01 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1834
Репутация: 613 ±
Замечаний: 0% ±

2007,2010,2013,2016
На сколько я понял нужно так:
[vba]
Код
=ВПР($A2;Table1[#Все];ПОИСКПОЗ(B$1;Table1[#Заголовки];0);0)
[/vba]
формула ломается в теге формул >(
К сообщению приложен файл: 7766922.xlsx(12Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеНа сколько я понял нужно так:
[vba]
Код
=ВПР($A2;Table1[#Все];ПОИСКПОЗ(B$1;Table1[#Заголовки];0);0)
[/vba]
формула ломается в теге формул >(

Автор - SLAVICK
Дата добавления - 27.09.2016 в 15:01
Selena Дата: Вторник, 27.09.2016, 15:21 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, SLAVICK, огромное спасибо! Оба варианта подходят! yes
 
Ответить
Сообщение_Boroda_, SLAVICK, огромное спасибо! Оба варианта подходят! yes

Автор - Selena
Дата добавления - 27.09.2016 в 15:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР для поиска по именованному диапазону (другой лист) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!