Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/значение null как результат формулы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » значение null как результат формулы (Формулы/Formulas)
значение null как результат формулы
softland Дата: Суббота, 08.10.2016, 15:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Очень хочется получить пустое значение в результате формулы:
Код
=if(A1<0;NULL;A1)

функция NA() не подходит -визуально не то!
вернуть 0 нельзя, статистика поплывёт.
конструкция
Код
=if(A1<0;"";A1)
визуально то, что надо, но дальше проблемы с графиками. Это не NULL это пустая текстовая строка!
Один вариант мне известен вариант но путь правильный только если нет других...
 
Ответить
СообщениеОчень хочется получить пустое значение в результате формулы:
Код
=if(A1<0;NULL;A1)

функция NA() не подходит -визуально не то!
вернуть 0 нельзя, статистика поплывёт.
конструкция
Код
=if(A1<0;"";A1)
визуально то, что надо, но дальше проблемы с графиками. Это не NULL это пустая текстовая строка!
Один вариант мне известен вариант но путь правильный только если нет других...

Автор - softland
Дата добавления - 08.10.2016 в 15:47
Nic70y Дата: Суббота, 08.10.2016, 15:54 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
проблемы с графиками
ну так покажите график (в файле-excel ессно) скорей всего надо
Код
=НД()
+ УФ
,а ну да, это уже написано
Цитата
функция NA()
, ну как я написал, возможно УФ поможет


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Суббота, 08.10.2016, 15:57
 
Ответить
Сообщение
проблемы с графиками
ну так покажите график (в файле-excel ессно) скорей всего надо
Код
=НД()
+ УФ
,а ну да, это уже написано
Цитата
функция NA()
, ну как я написал, возможно УФ поможет

Автор - Nic70y
Дата добавления - 08.10.2016 в 15:54
softland Дата: Суббота, 08.10.2016, 17:25 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Прикладываю файл. График с НД() правильный получаем, но
по колонке с НД() вообще даже сумму подсчитать невозможно...
К сообщению приложен файл: null.xls(73Kb)
 
Ответить
СообщениеПрикладываю файл. График с НД() правильный получаем, но
по колонке с НД() вообще даже сумму подсчитать невозможно...

Автор - softland
Дата добавления - 08.10.2016 в 17:25
Pelena Дата: Суббота, 08.10.2016, 17:33 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9869
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Как вариант, посчитать сумму другой формулой, например
Код
=АГРЕГАТ(9;6;E4:E11)

или массивная
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(E4:E11);E4:E11))

а #НД скрыть условным форматированием

UPD. В данном конкретном примере можно строить график по исходному диапазону В4:С11, и установить минимальное значение по оси 0
К сообщению приложен файл: 9852544.xls(44Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак вариант, посчитать сумму другой формулой, например
Код
=АГРЕГАТ(9;6;E4:E11)

или массивная
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(E4:E11);E4:E11))

а #НД скрыть условным форматированием

UPD. В данном конкретном примере можно строить график по исходному диапазону В4:С11, и установить минимальное значение по оси 0

Автор - Pelena
Дата добавления - 08.10.2016 в 17:33
softland Дата: Суббота, 08.10.2016, 18:03 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Да, агрегат срабатывает! соответственно колонку можно обрабатывать.
Скрыть #НД условным форматированием получилось, но как-то через задницу... см приложенный файл.
Можно считать - ложки нашлись, но осадочек остался... ну например не видно значения "min/max/средн/сумма и пр." в строке состояния (((
А может ещё будут предложения.

Я реально уже давно с этим страдаю, но всё руки не доходили и решения готового не попадалось.
К сообщению приложен файл: null.xlsx(20Kb)


Сообщение отредактировал softland - Суббота, 08.10.2016, 18:06
 
Ответить
СообщениеДа, агрегат срабатывает! соответственно колонку можно обрабатывать.
Скрыть #НД условным форматированием получилось, но как-то через задницу... см приложенный файл.
Можно считать - ложки нашлись, но осадочек остался... ну например не видно значения "min/max/средн/сумма и пр." в строке состояния (((
А может ещё будут предложения.

Я реально уже давно с этим страдаю, но всё руки не доходили и решения готового не попадалось.

Автор - softland
Дата добавления - 08.10.2016 в 18:03
Pelena Дата: Суббота, 08.10.2016, 18:09 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9869
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
УФ можно делать с точностью до наоборот. То есть если ячейка содержит значение ошибки, то белый шрифт.


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеУФ можно делать с точностью до наоборот. То есть если ячейка содержит значение ошибки, то белый шрифт.

Автор - Pelena
Дата добавления - 08.10.2016 в 18:09
softland Дата: Суббота, 08.10.2016, 18:12 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Вот это и не получилось :( , попробую ещё раз
ВСЕМ СПАСИБО


Сообщение отредактировал softland - Суббота, 08.10.2016, 18:13
 
Ответить
СообщениеВот это и не получилось :( , попробую ещё раз
ВСЕМ СПАСИБО

Автор - softland
Дата добавления - 08.10.2016 в 18:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » значение null как результат формулы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!