Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Дата устойчивого перехода через 0 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Дата устойчивого перехода через 0 (Формулы/Formulas)
Дата устойчивого перехода через 0
baneska Дата: Пятница, 14.10.2016, 11:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.

Помогите, пожалуйста придумать, наверное, формулу.

Есть база температурных данных с позициями: Год, месяц, день и температура. И нужно выделить строку с датами и температурой, когда впервые температура превышает 0, а затем впервые, когда становится ниже 0. Т.е. За год должно получиться две даты.

В документе представлена температура на каждый день за 1915 года. Получилось:

Переход в + 16.03.1915 = 2,3
Переход в - 01.10.1915 = -1,7.

Нужна формула, чтобы можно было находить эти переходы для каждого года, а не вручную искать. Помогите, пожалуйста.
К сообщению приложен файл: 5412711.xlsx(19Kb)


Новичок
 
Ответить
СообщениеДобрый день.

Помогите, пожалуйста придумать, наверное, формулу.

Есть база температурных данных с позициями: Год, месяц, день и температура. И нужно выделить строку с датами и температурой, когда впервые температура превышает 0, а затем впервые, когда становится ниже 0. Т.е. За год должно получиться две даты.

В документе представлена температура на каждый день за 1915 года. Получилось:

Переход в + 16.03.1915 = 2,3
Переход в - 01.10.1915 = -1,7.

Нужна формула, чтобы можно было находить эти переходы для каждого года, а не вручную искать. Помогите, пожалуйста.

Автор - baneska
Дата добавления - 14.10.2016 в 11:43
Manyasha Дата: Пятница, 14.10.2016, 12:20 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1590
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
baneska, для перехода в + можно так:
Код
=ИНДЕКС(A2:A366;ПОИСКПОЗ(1;--($D$2:$D$366>0);))

А для перехода в -, добавила условие месяц > 8, т.е. смотрим температуру только осеннюю и зимнюю
Код
=ИНДЕКС(A2:A366;ПОИСКПОЗ(1;($D$2:$D$366<0)*($B$2:$B$366>8);))

обе формулы массивные, вводятся через ctrl+shift+enter.
К сообщению приложен файл: 5412711-1.xlsx(19Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеbaneska, для перехода в + можно так:
Код
=ИНДЕКС(A2:A366;ПОИСКПОЗ(1;--($D$2:$D$366>0);))

А для перехода в -, добавила условие месяц > 8, т.е. смотрим температуру только осеннюю и зимнюю
Код
=ИНДЕКС(A2:A366;ПОИСКПОЗ(1;($D$2:$D$366<0)*($B$2:$B$366>8);))

обе формулы массивные, вводятся через ctrl+shift+enter.

Автор - Manyasha
Дата добавления - 14.10.2016 в 12:20
baneska Дата: Пятница, 14.10.2016, 12:54 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Manyasha, Замечательно, всё работает. Спасибо большое за помощь!!! :) )


Новичок
 
Ответить
СообщениеManyasha, Замечательно, всё работает. Спасибо большое за помощь!!! :) )

Автор - baneska
Дата добавления - 14.10.2016 в 12:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Дата устойчивого перехода через 0 (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!