Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Совпадение в ячейках по значению другой ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Совпадение в ячейках по значению другой ячейки (Формулы/Formulas)
Совпадение в ячейках по значению другой ячейки
ПАМ Дата: Вторник, 18.10.2016, 20:07 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Приветствую,дамы и господа! Помогите пожалуйста мне разобраться: мне нужно чтобы в ячейке E3 отображалась 1, если слово записанное в ячейку C3 совпало с любым из ячеек B1-B5 на втором листе, а если не совпадает 0.
Пробовал через формулу
Код
ПРОСМОТР
пишет ошибка, также формулой
Код
ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ
.
Также пробовал формулу
Код
=если (C3=ПРОСМОТР(Лист2! B1:B5); E3=1;E3=0))
, пишет что не правильно.

Скорее всего до конца не понимаю применение данных формул.

Очень прошу прощение за повтор! Заранее благодарен! Это самый лучший форум!
К сообщению приложен файл: 12.xlsx(9Kb)
 
Ответить
СообщениеПриветствую,дамы и господа! Помогите пожалуйста мне разобраться: мне нужно чтобы в ячейке E3 отображалась 1, если слово записанное в ячейку C3 совпало с любым из ячеек B1-B5 на втором листе, а если не совпадает 0.
Пробовал через формулу
Код
ПРОСМОТР
пишет ошибка, также формулой
Код
ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ
.
Также пробовал формулу
Код
=если (C3=ПРОСМОТР(Лист2! B1:B5); E3=1;E3=0))
, пишет что не правильно.

Скорее всего до конца не понимаю применение данных формул.

Очень прошу прощение за повтор! Заранее благодарен! Это самый лучший форум!

Автор - ПАМ
Дата добавления - 18.10.2016 в 20:07
Pelena Дата: Вторник, 18.10.2016, 20:16 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10445
Репутация: 2359 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
А СЧЁТЕСЛИ() не подойдёт?
Код
=--(СЧЁТЕСЛИ(Лист2!$B$1:$B$5;C3)>0)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
А СЧЁТЕСЛИ() не подойдёт?
Код
=--(СЧЁТЕСЛИ(Лист2!$B$1:$B$5;C3)>0)

Автор - Pelena
Дата добавления - 18.10.2016 в 20:16
Karataev Дата: Вторник, 18.10.2016, 20:17 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 733
Репутация: 262 ±
Замечаний: 0% ±

Excel
Формула для "E3":
Код
=ЕСЛИ(СЧЁТЕСЛИ(Лист2!B:B;C3);1;0)
К сообщению приложен файл: 1145271.xlsx(10Kb)




Сообщение отредактировал Karataev - Вторник, 18.10.2016, 20:18
 
Ответить
СообщениеФормула для "E3":
Код
=ЕСЛИ(СЧЁТЕСЛИ(Лист2!B:B;C3);1;0)

Автор - Karataev
Дата добавления - 18.10.2016 в 20:17
_Boroda_ Дата: Вторник, 18.10.2016, 22:22 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я бы сделал через ПОИСКПОЗ. Не проверял, но думаю, что так быстрее
Код
=--ЕЧИСЛО(ПОИСКПОЗ(C3;Лист2!B$1:B$5;))

[p.s.]У нас тут новшество - чтобы формула нормально отображалась, при создании/редактировании поста нужно снять галку "Включить смайлы"
К сообщению приложен файл: 1244444_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЯ бы сделал через ПОИСКПОЗ. Не проверял, но думаю, что так быстрее
Код
=--ЕЧИСЛО(ПОИСКПОЗ(C3;Лист2!B$1:B$5;))

[p.s.]У нас тут новшество - чтобы формула нормально отображалась, при создании/редактировании поста нужно снять галку "Включить смайлы"

Автор - _Boroda_
Дата добавления - 18.10.2016 в 22:22
ПАМ Дата: Среда, 19.10.2016, 19:27 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Pelena, Karataev, _Boroda_, всем огромное спасибо, будут применять на большом файле.
 
Ответить
СообщениеPelena, Karataev, _Boroda_, всем огромное спасибо, будут применять на большом файле.

Автор - ПАМ
Дата добавления - 19.10.2016 в 19:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Совпадение в ячейках по значению другой ячейки (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!