Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчёт площади, состоящей из равнобедренных трапеций - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт площади, состоящей из равнобедренных трапеций (Формулы/Formulas)
Расчёт площади, состоящей из равнобедренных трапеций
wolfire Дата: Суббота, 29.10.2016, 14:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Считаю сумму площадей равнобедренных трапеций, верхнее основание одной трапеции является нижним основанием для следющей (см. рисунок)

Допустим я прописал формулу для размера 1000 мм, но сейчас мне понадобилось посчитать только для 500 и получается что не нужная мне предпоследняя сумма считается (последняя тоже не нужная, но она не считается), потому что использует данные от предидущей трапеции. Как это можно обойти, исправить?
Чтобы правильно посчитать нужно удалить 2 последнии суммы или предпоследнюю. Можно как-то привзять строки к формулам? Например нет данных в строке 12 - сумма 11 блокируется и не считается, нет данных в строке 13 сумма 12 не считается. Может есть какие-то другие решения?


Сообщение отредактировал wolfire - Суббота, 29.10.2016, 14:49
 
Ответить
СообщениеСчитаю сумму площадей равнобедренных трапеций, верхнее основание одной трапеции является нижним основанием для следющей (см. рисунок)

Допустим я прописал формулу для размера 1000 мм, но сейчас мне понадобилось посчитать только для 500 и получается что не нужная мне предпоследняя сумма считается (последняя тоже не нужная, но она не считается), потому что использует данные от предидущей трапеции. Как это можно обойти, исправить?
Чтобы правильно посчитать нужно удалить 2 последнии суммы или предпоследнюю. Можно как-то привзять строки к формулам? Например нет данных в строке 12 - сумма 11 блокируется и не считается, нет данных в строке 13 сумма 12 не считается. Может есть какие-то другие решения?

Автор - wolfire
Дата добавления - 29.10.2016 в 14:47
Michael_S Дата: Суббота, 29.10.2016, 14:54 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
Какие фигуры в вашем варианте образуют равнобедренную трапецию?
Впрочем, не важно. Формула площади от равнобедренности не зависит.
По рисункам не лечим, файл нужен.


ЯД: 41001136675053
WM: R389613894253


Сообщение отредактировал Michael_S - Суббота, 29.10.2016, 14:57
 
Ответить
СообщениеКакие фигуры в вашем варианте образуют равнобедренную трапецию?
Впрочем, не важно. Формула площади от равнобедренности не зависит.
По рисункам не лечим, файл нужен.

Автор - Michael_S
Дата добавления - 29.10.2016 в 14:54
wolfire Дата: Суббота, 29.10.2016, 15:23 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Файл гугловский, надеюсь откроется.
В общем думаю проблема понятна. То есть я считаю площадь на длину 500 мм, но при этом к площади прибавляется сумма (B11+0)/2*(0-A11) - предназначена для 550, так как в ячейках B11 и A11 есть данные.
К сообщению приложен файл: 8073953.xlsx(4Kb)
 
Ответить
СообщениеФайл гугловский, надеюсь откроется.
В общем думаю проблема понятна. То есть я считаю площадь на длину 500 мм, но при этом к площади прибавляется сумма (B11+0)/2*(0-A11) - предназначена для 550, так как в ячейках B11 и A11 есть данные.

Автор - wolfire
Дата добавления - 29.10.2016 в 15:23
Michael_S Дата: Суббота, 29.10.2016, 15:40 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
По вашим данным считает правильно.
Если другая проблема - покажите в файле, что именно не так.


ЯД: 41001136675053
WM: R389613894253
 
Ответить
СообщениеПо вашим данным считает правильно.
Если другая проблема - покажите в файле, что именно не так.

Автор - Michael_S
Дата добавления - 29.10.2016 в 15:40
Udik Дата: Суббота, 29.10.2016, 15:47 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1201
Репутация: 152 ±
Замечаний: 0% ±

Excel 2013
может так подойдёт
Код

=СУММПРОИЗВ((B1:B12+B2:B13)/2*(A2:A13-A1:A12)*(A1:A12<B18))
К сообщению приложен файл: 2381863.xlsx(9Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениеможет так подойдёт
Код

=СУММПРОИЗВ((B1:B12+B2:B13)/2*(A2:A13-A1:A12)*(A1:A12<B18))

Автор - Udik
Дата добавления - 29.10.2016 в 15:47
wolfire Дата: Суббота, 29.10.2016, 16:03 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
По вашим данным считает правильно.
Если другая проблема - покажите в файле, что именно не так.

Считает правильно, но лишнее. Из за того что трапеции прилегают друг другу, имеем одни и теже ячейки для подсчёта разных площадей. И получается что формула предназначенная для следующей трапеции, которой нет по факту, выдаст какое-то целое значение, в то время как должен быть 0.
может так подойдёт

Очень даже) благодрю. Сам бы до такого не додумался, так как знания ексель ограничаваются формулой в моём файле :)


Сообщение отредактировал wolfire - Суббота, 29.10.2016, 16:04
 
Ответить
Сообщение
По вашим данным считает правильно.
Если другая проблема - покажите в файле, что именно не так.

Считает правильно, но лишнее. Из за того что трапеции прилегают друг другу, имеем одни и теже ячейки для подсчёта разных площадей. И получается что формула предназначенная для следующей трапеции, которой нет по факту, выдаст какое-то целое значение, в то время как должен быть 0.
может так подойдёт

Очень даже) благодрю. Сам бы до такого не додумался, так как знания ексель ограничаваются формулой в моём файле :)

Автор - wolfire
Дата добавления - 29.10.2016 в 16:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт площади, состоящей из равнобедренных трапеций (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!