Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Присвоение порядкового номера строке. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоение порядкового номера строке. (Формулы/Formulas)
Присвоение порядкового номера строке.
noFormat Дата: Вторник, 01.11.2016, 10:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Помогите пожалуйста с такой задачей: необходимо присвоить порядковые номера строкам(1,2,3,4.... и далее) в таком виде, чтобы у одинаковых значений были одинаковые номера. Т.е. например 1,2,3,3,3,4,4,5,6. Порядковый номер должен присваиваться на основе соседней ячейки, если текст в ячейке одинаковый, то и номер должен быть одинаковый. Пример во вложеном файле. Там я руками проставил номера (столбец product id). А как сделать это автоматически?
К сообщению приложен файл: primer.xls(74Kb)
 
Ответить
СообщениеДобрый день. Помогите пожалуйста с такой задачей: необходимо присвоить порядковые номера строкам(1,2,3,4.... и далее) в таком виде, чтобы у одинаковых значений были одинаковые номера. Т.е. например 1,2,3,3,3,4,4,5,6. Порядковый номер должен присваиваться на основе соседней ячейки, если текст в ячейке одинаковый, то и номер должен быть одинаковый. Пример во вложеном файле. Там я руками проставил номера (столбец product id). А как сделать это автоматически?

Автор - noFormat
Дата добавления - 01.11.2016 в 10:23
_Boroda_ Дата: Вторник, 01.11.2016, 10:29 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММ(D1;B2<>B1)
К сообщению приложен файл: primer-9-1.xls(75Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММ(D1;B2<>B1)

Автор - _Boroda_
Дата добавления - 01.11.2016 в 10:29
noFormat Дата: Вторник, 01.11.2016, 10:42 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Так нужно?


То что нужно! Спасибо!
 
Ответить
Сообщение
Так нужно?


То что нужно! Спасибо!

Автор - noFormat
Дата добавления - 01.11.2016 в 10:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоение порядкового номера строке. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!