Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция "ВПР". Поиск номера столбца. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция "ВПР". Поиск номера столбца. (Формулы/Formulas)
Функция "ВПР". Поиск номера столбца.
forall Дата: Вторник, 01.11.2016, 11:18 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Вот проблема:
Пытаюсь оформить выдачу диапазона данных по заданному имени листа и столбца. Не могу сообразить как искать столбец по имени, на определенном листе. Параметры а,б,в,г,д,е,ж,з - на каждом листе будут одинаковы, а вот набор значений по столбцам и количество столбцов, отличаться. Вообщем, нужно чтобы при вводе имени листа и столбца выводило соответствующий набор параметров.
Помогите плиз. Пример во вложении.
К сообщению приложен файл: 222.xlsx(10Kb)
 
Ответить
СообщениеВот проблема:
Пытаюсь оформить выдачу диапазона данных по заданному имени листа и столбца. Не могу сообразить как искать столбец по имени, на определенном листе. Параметры а,б,в,г,д,е,ж,з - на каждом листе будут одинаковы, а вот набор значений по столбцам и количество столбцов, отличаться. Вообщем, нужно чтобы при вводе имени листа и столбца выводило соответствующий набор параметров.
Помогите плиз. Пример во вложении.

Автор - forall
Дата добавления - 01.11.2016 в 11:18
Nic70y Дата: Вторник, 01.11.2016, 11:25 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3473
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ВПР(A3;ДВССЫЛ($B$1&"!$A$1:$F$9");ПОИСКПОЗ(B$2;ДВССЫЛ($B$1&"!$A$1:$F$1"););ЛОЖЬ)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ВПР(A3;ДВССЫЛ($B$1&"!$A$1:$F$9");ПОИСКПОЗ(B$2;ДВССЫЛ($B$1&"!$A$1:$F$1"););ЛОЖЬ)

Автор - Nic70y
Дата добавления - 01.11.2016 в 11:25
buchlotnik Дата: Вторник, 01.11.2016, 11:30 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ИНДЕКС(ДВССЫЛ($B$1&"!B2:F9");ПОИСКПОЗ(A3;ДВССЫЛ($B$1&"!A2:A9");0);ПОИСКПОЗ($B$2;ДВССЫЛ($B$1&"!B1:F1");0))
К сообщению приложен файл: 7086262.xlsx(11Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=ИНДЕКС(ДВССЫЛ($B$1&"!B2:F9");ПОИСКПОЗ(A3;ДВССЫЛ($B$1&"!A2:A9");0);ПОИСКПОЗ($B$2;ДВССЫЛ($B$1&"!B1:F1");0))

Автор - buchlotnik
Дата добавления - 01.11.2016 в 11:30
AlexM Дата: Вторник, 01.11.2016, 12:04 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3049
Репутация: 739 ±
Замечаний: 0% ±

Код
=ГПР(B$2;ДВССЫЛ(B$1&"!A$1:Z$9");СТРОКА(A2);)
К сообщению приложен файл: 222_01.xlsx(10Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Вторник, 01.11.2016, 12:41
 
Ответить
Сообщение
Код
=ГПР(B$2;ДВССЫЛ(B$1&"!A$1:Z$9");СТРОКА(A2);)

Автор - AlexM
Дата добавления - 01.11.2016 в 12:04
forall Дата: Вторник, 01.11.2016, 15:22 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо всем!
 
Ответить
СообщениеСпасибо всем!

Автор - forall
Дата добавления - 01.11.2016 в 15:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция "ВПР". Поиск номера столбца. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!