Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение Графика работы по данным Таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение Графика работы по данным Таблицы (Формулы/Formulas)
Заполнение Графика работы по данным Таблицы
VolTin Дата: Вторник, 01.11.2016, 14:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Помогите, пожалуйста. Условия в прикрепленном файле
К сообщению приложен файл: 9083817.xlsx(11Kb)


Владимир
 
Ответить
СообщениеПомогите, пожалуйста. Условия в прикрепленном файле

Автор - VolTin
Дата добавления - 01.11.2016 в 14:00
K-SerJC Дата: Вторник, 01.11.2016, 14:52 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 76
Репутация: 11 ±
Замечаний: 60% ±

Excel 2013
формула в синию сроку

Код
=ЕСЛИ(ВПР(E$3;$B$3:$C$32;2)=$D$5;ВПР(E$3;$B$3:$C$32;2);"")

так?

а это условие:
Цитата
5. При появлении новой фамилии, которой нет в графике - добавить новую строку по аналогии с верхними ( появилась Егорова, ее не было в графике - добавить новую фамилию

наверное через VBA


Благими намерениями выстелена дорога в АД.

Сообщение отредактировал K-SerJC - Вторник, 01.11.2016, 14:54
 
Ответить
Сообщениеформула в синию сроку

Код
=ЕСЛИ(ВПР(E$3;$B$3:$C$32;2)=$D$5;ВПР(E$3;$B$3:$C$32;2);"")

так?

а это условие:
Цитата
5. При появлении новой фамилии, которой нет в графике - добавить новую строку по аналогии с верхними ( появилась Егорова, ее не было в графике - добавить новую фамилию

наверное через VBA

Автор - K-SerJC
Дата добавления - 01.11.2016 в 14:52
VolTin Дата: Вторник, 01.11.2016, 22:08 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Серега, извини, только смог сеть за компьютер. Проверил, к сожалению ничего не происходит.
Все равно спасибо. Если есть время, посмотри , пожалуйста сам еще разок


Владимир
 
Ответить
СообщениеСерега, извини, только смог сеть за компьютер. Проверил, к сожалению ничего не происходит.
Все равно спасибо. Если есть время, посмотри , пожалуйста сам еще разок

Автор - VolTin
Дата добавления - 01.11.2016 в 22:08
VolTin Дата: Вторник, 01.11.2016, 22:59 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
K-SerJC - Серега, посмотрел внимательно сам, исправил на
Код
=ЕСЛИ(ВПР(E$3;$B$3:$C$32;2)=$D5;ВПР(E$3;$B$3:$C$32;2);"")

убрал знак $перед 5, он не нужен . И все заработало . Спасибо за логику.
Но не знаю что такое VBA. Наверно, какой-то инструмкет который сам добавляет строки. Кто сможет помочь?
Асы алгебры Буля !


Владимир

Сообщение отредактировал Manyasha - Среда, 02.11.2016, 12:41
 
Ответить
СообщениеK-SerJC - Серега, посмотрел внимательно сам, исправил на
Код
=ЕСЛИ(ВПР(E$3;$B$3:$C$32;2)=$D5;ВПР(E$3;$B$3:$C$32;2);"")

убрал знак $перед 5, он не нужен . И все заработало . Спасибо за логику.
Но не знаю что такое VBA. Наверно, какой-то инструмкет который сам добавляет строки. Кто сможет помочь?
Асы алгебры Буля !

Автор - VolTin
Дата добавления - 01.11.2016 в 22:59
K-SerJC Дата: Среда, 02.11.2016, 08:19 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 76
Репутация: 11 ±
Замечаний: 60% ±

Excel 2013
Но не знаю что такое VBA.

Владимир, есть ветка вопросы по Excel, это где ты сейчас тему сделал, и есть ветка вопросы по VBA? там создай тему с вопросом

можно на vba написать макрос, который при изменении списка проверит фамилии в графике и при необходимости добавит строки


Благими намерениями выстелена дорога в АД.
 
Ответить
Сообщение
Но не знаю что такое VBA.

Владимир, есть ветка вопросы по Excel, это где ты сейчас тему сделал, и есть ветка вопросы по VBA? там создай тему с вопросом

можно на vba написать макрос, который при изменении списка проверит фамилии в графике и при необходимости добавит строки

Автор - K-SerJC
Дата добавления - 02.11.2016 в 08:19
VolTin Дата: Среда, 02.11.2016, 12:23 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
K-SerJC, Спасибо


Владимир
 
Ответить
СообщениеK-SerJC, Спасибо

Автор - VolTin
Дата добавления - 02.11.2016 в 12:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение Графика работы по данным Таблицы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!