Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверить на наличие значений и подставить это значение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверить на наличие значений и подставить это значение (Формулы/Formulas)
Проверить на наличие значений и подставить это значение
TjRadenot Дата: Пятница, 04.11.2016, 08:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день,

Есть необходимость, проверить 4 ячейки (1 квартал, 2 квартал, 3 квартал, 4 квартал) и ЕСЛИ в одной из них есть значение (там только положительные или отрицательные числа), то необходимо это значение подставить в ячейку "12 мес или Прогноз" (выделена желтым).
При чём нужно проверять по убыванию сначала 4 квартал, затем 3 квартал и.т.д.

Буду рад кто подскажет, как правильно это реализовать?
Спасибо.
К сообщению приложен файл: 3922821.xlsx(12Kb)
 
Ответить
СообщениеДобрый день,

Есть необходимость, проверить 4 ячейки (1 квартал, 2 квартал, 3 квартал, 4 квартал) и ЕСЛИ в одной из них есть значение (там только положительные или отрицательные числа), то необходимо это значение подставить в ячейку "12 мес или Прогноз" (выделена желтым).
При чём нужно проверять по убыванию сначала 4 квартал, затем 3 квартал и.т.д.

Буду рад кто подскажет, как правильно это реализовать?
Спасибо.

Автор - TjRadenot
Дата добавления - 04.11.2016 в 08:33
Pelena Дата: Пятница, 04.11.2016, 08:45 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9842
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ЕЧИСЛО(A13:D13);A13:D13);"")
К сообщению приложен файл: 0185203.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ЕЧИСЛО(A13:D13);A13:D13);"")

Автор - Pelena
Дата добавления - 04.11.2016 в 08:45
andreika21 Дата: Пятница, 04.11.2016, 09:06 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

Здравствуйте. Еще как вариант
К сообщению приложен файл: 236598.xlsx(12Kb)
 
Ответить
СообщениеЗдравствуйте. Еще как вариант

Автор - andreika21
Дата добавления - 04.11.2016 в 09:06
Wasilich Дата: Пятница, 04.11.2016, 09:30 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 858
Репутация: 220 ±
Замечаний: 0% ±

2003
Интересно
ЕСЛИ в одной из них есть значение
Если значение бывает только в одной из них, то зачем
нужно проверять по убыванию


Сообщение отредактировал Wasilich - Пятница, 04.11.2016, 09:36
 
Ответить
СообщениеИнтересно
ЕСЛИ в одной из них есть значение
Если значение бывает только в одной из них, то зачем
нужно проверять по убыванию

Автор - Wasilich
Дата добавления - 04.11.2016 в 09:30
TjRadenot Дата: Пятница, 04.11.2016, 12:38 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Супер! Спасибо Pelena, andreika21.

Wasilich, Отчётность компаний выходит ежеквартально, сначала 1 потом 2, 3 и 4 кварталы. Мне важны самые свежие данные, а именно 4 квартал. Но т.к. сейчас отчётность будет выходить за 3 кв., то соответственно свежие данные будут за 3 квартал.
Надеюсь понятно объяснил :)
 
Ответить
СообщениеСупер! Спасибо Pelena, andreika21.

Wasilich, Отчётность компаний выходит ежеквартально, сначала 1 потом 2, 3 и 4 кварталы. Мне важны самые свежие данные, а именно 4 квартал. Но т.к. сейчас отчётность будет выходить за 3 кв., то соответственно свежие данные будут за 3 квартал.
Надеюсь понятно объяснил :)

Автор - TjRadenot
Дата добавления - 04.11.2016 в 12:38
Wasilich Дата: Пятница, 04.11.2016, 14:35 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 858
Репутация: 220 ±
Замечаний: 0% ±

2003
Надеюсь понятно объяснил
[offtop]Не, ну, включив логику, и я догадался. Я за то, чтобы не приходилось ответы строить на догадках. :)
[/offtop]
 
Ответить
Сообщение
Надеюсь понятно объяснил
[offtop]Не, ну, включив логику, и я догадался. Я за то, чтобы не приходилось ответы строить на догадках. :)
[/offtop]

Автор - Wasilich
Дата добавления - 04.11.2016 в 14:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверить на наличие значений и подставить это значение (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!