Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как два столбца выронить ровно по значениям в одну строку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как два столбца выронить ровно по значениям в одну строку (Формулы/Formulas)
Как два столбца выронить ровно по значениям в одну строку
Madi Дата: Пятница, 11.11.2016, 07:59 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день форумчане. Искал в форуме решение своей проблемы но не нашел. помогите мне пожалуйста.
короче у меня есть два списка (столбца) типа сумма продаж и поступление от клиентов за 2015 и 2016 год. клиенты указаны в виде цифр в столбце под названием "КОД".
количество клиентов в 2015 и 2016 разные. 2016 больше разумеется. и мне нужно два этих списка поставить рядом чтобы клиенты с 2015 года и 2016 года были в одной строке.
образец прилагаю, по нему будет все понятно
К сообщению приложен файл: 4760605.xlsx(98Kb)
 
Ответить
СообщениеДобрый день форумчане. Искал в форуме решение своей проблемы но не нашел. помогите мне пожалуйста.
короче у меня есть два списка (столбца) типа сумма продаж и поступление от клиентов за 2015 и 2016 год. клиенты указаны в виде цифр в столбце под названием "КОД".
количество клиентов в 2015 и 2016 разные. 2016 больше разумеется. и мне нужно два этих списка поставить рядом чтобы клиенты с 2015 года и 2016 года были в одной строке.
образец прилагаю, по нему будет все понятно

Автор - Madi
Дата добавления - 11.11.2016 в 07:59
китин Дата: Пятница, 11.11.2016, 08:11 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Добрый и вам. так надо?
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$3:B$1759;ПОИСКПОЗ($E3;$A$3:$A$1759;0));0)
К сообщению приложен файл: 555111.xlsb(89Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДобрый и вам. так надо?
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$3:B$1759;ПОИСКПОЗ($E3;$A$3:$A$1759;0));0)

Автор - китин
Дата добавления - 11.11.2016 в 08:11
_Boroda_ Дата: Пятница, 11.11.2016, 09:18 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У Вас куча клиентов (574 штуки), которые есть в 2015 году, но отсутствуют в 2016 (например, 120.41.003). Чтобы их не потерять, можно сделать так:
1. Встаем в А3, жмем Контрл Шифт СтрелкаВниз, выделяется всё вниз, копируем (Контрл С), встаем в Е3, жмем Контрл СтрелкаВниз, вставляем скопированное (Контрл V), жмем Контрл Home - переходим в ячейку А1, Встаем в Е3, жмем Контрл Шифт СтрелкаВниз, Вкладка Данные - Удалить дубликаты - В пределах указанного - Удалить - ОК, В Н3 пишем формулу
Код
=ЕСЛИОШИБКА(ВПР(E3;A$3:C$1760;2;);)
и протягиваем ее вниз
Аналогично в I3
Код
=ЕСЛИОШИБКА(ВПР(E3;A$3:C$1760;3;);)

В файле формула до конца вниз не протянута, иначе файл не влезает сюда. Протяните сами
К сообщению приложен файл: 4760605_1.xlsb(76Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ Вас куча клиентов (574 штуки), которые есть в 2015 году, но отсутствуют в 2016 (например, 120.41.003). Чтобы их не потерять, можно сделать так:
1. Встаем в А3, жмем Контрл Шифт СтрелкаВниз, выделяется всё вниз, копируем (Контрл С), встаем в Е3, жмем Контрл СтрелкаВниз, вставляем скопированное (Контрл V), жмем Контрл Home - переходим в ячейку А1, Встаем в Е3, жмем Контрл Шифт СтрелкаВниз, Вкладка Данные - Удалить дубликаты - В пределах указанного - Удалить - ОК, В Н3 пишем формулу
Код
=ЕСЛИОШИБКА(ВПР(E3;A$3:C$1760;2;);)
и протягиваем ее вниз
Аналогично в I3
Код
=ЕСЛИОШИБКА(ВПР(E3;A$3:C$1760;3;);)

В файле формула до конца вниз не протянута, иначе файл не влезает сюда. Протяните сами

Автор - _Boroda_
Дата добавления - 11.11.2016 в 09:18
Madi Дата: Пятница, 11.11.2016, 09:18 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, да так. а как ты это сделал?
 
Ответить
Сообщениекитин, да так. а как ты это сделал?

Автор - Madi
Дата добавления - 11.11.2016 в 09:18
китин Дата: Пятница, 11.11.2016, 09:27 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а как ты это сделал

формулой. в столбцах Н и I файлик то приложен


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
а как ты это сделал

формулой. в столбцах Н и I файлик то приложен

Автор - китин
Дата добавления - 11.11.2016 в 09:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как два столбца выронить ровно по значениям в одну строку (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!