Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверка ячеек по нескольким условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка ячеек по нескольким условиям (Формулы/Formulas)
Проверка ячеек по нескольким условиям
Vasek007 Дата: Вторник, 15.11.2016, 15:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Существует необходимость проверить тест. Для этого необходимо сравнить содержимое одной ячейки с содержимым другой ячейки и в зависимости от варианта засчитать как правильный или неправильный ответ (0 или 1). Эту формулу я прописал.
Код
=ЕСЛИ($A2=1;ЕСЛИ('Ввод ответов'!B2='Матрица ответов'!B$2;"1");"0")+ЕСЛИ($A2=2;ЕСЛИ('Ввод ответов'!B2='Матрица ответов'!B$3;"1");"0")
. Но теперь мне нужно прописать такую формулу, которая могла бы проверить задания с несколькими ответами. Задание считается выполненным, если правильно выбраны два варианта ответа и оценится в таком случае задание в 2 балла. За неполный ответ - правильно назван один из двух ответов или названы три ответа, из которых два верные, - выставляется 1 балл. Остальные варианты оценятся в 0. Все ответы даются в цифрах. Если есть решение этой проблемы, прошу помочь!

Пример: правильный ответ 34, ответ 43 тоже верный и оцениваются такие ответы в 2 балла. Ответы типа 13, 31, 32, 23, 53, 35, 42, 24, 45, 54 - где даны два ответа (две цифры), но правильный из них только один (там где встречаются цифры 3 или 4) и оцениваются такие ответы в 1 балл. Ответы типа 345, 435, 534, 341, 143, 431, 413, 453, 354 и т.д. (три цифры из которых обязательно встречаются цифры 3 и 4) тоже оцениваются в 1 балл. Положение цифры в числе не имеет значения, главное, чтобы она там была. Ответ, где указана лишь одна цифра 3 или 4 тоже верный и оценивается в 1 балл. Ответы типа 1234, 2345 и т.д., где 4 цифры и более оцениваются в 0 баллов в независимости от того, есть ли там цифры 3 и 4.
К сообщению приложен файл: 2731101.xlsx(12Kb)


Сообщение отредактировал Vasek007 - Среда, 16.11.2016, 05:22
 
Ответить
СообщениеСуществует необходимость проверить тест. Для этого необходимо сравнить содержимое одной ячейки с содержимым другой ячейки и в зависимости от варианта засчитать как правильный или неправильный ответ (0 или 1). Эту формулу я прописал.
Код
=ЕСЛИ($A2=1;ЕСЛИ('Ввод ответов'!B2='Матрица ответов'!B$2;"1");"0")+ЕСЛИ($A2=2;ЕСЛИ('Ввод ответов'!B2='Матрица ответов'!B$3;"1");"0")
. Но теперь мне нужно прописать такую формулу, которая могла бы проверить задания с несколькими ответами. Задание считается выполненным, если правильно выбраны два варианта ответа и оценится в таком случае задание в 2 балла. За неполный ответ - правильно назван один из двух ответов или названы три ответа, из которых два верные, - выставляется 1 балл. Остальные варианты оценятся в 0. Все ответы даются в цифрах. Если есть решение этой проблемы, прошу помочь!

Пример: правильный ответ 34, ответ 43 тоже верный и оцениваются такие ответы в 2 балла. Ответы типа 13, 31, 32, 23, 53, 35, 42, 24, 45, 54 - где даны два ответа (две цифры), но правильный из них только один (там где встречаются цифры 3 или 4) и оцениваются такие ответы в 1 балл. Ответы типа 345, 435, 534, 341, 143, 431, 413, 453, 354 и т.д. (три цифры из которых обязательно встречаются цифры 3 и 4) тоже оцениваются в 1 балл. Положение цифры в числе не имеет значения, главное, чтобы она там была. Ответ, где указана лишь одна цифра 3 или 4 тоже верный и оценивается в 1 балл. Ответы типа 1234, 2345 и т.д., где 4 цифры и более оцениваются в 0 баллов в независимости от того, есть ли там цифры 3 и 4.

Автор - Vasek007
Дата добавления - 15.11.2016 в 15:48
_Boroda_ Дата: Вторник, 15.11.2016, 16:14 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Формулу нужно обрамлять тегами (кнопка fx и снимите галку "Включить смайлы). Прочитайте Правила форума, там написано. И файл приложите.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФормулу нужно обрамлять тегами (кнопка fx и снимите галку "Включить смайлы). Прочитайте Правила форума, там написано. И файл приложите.

Автор - _Boroda_
Дата добавления - 15.11.2016 в 16:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка ячеек по нескольким условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!