Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск текста в массиве - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск текста в массиве (Формулы/Formulas)
Поиск текста в массиве
sekii Дата: Среда, 16.11.2016, 16:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день.
Есть массив строк. Нужно найти в этом массиве строку в части текста которой содержится слово (или фраза) (пример во вложении).
Помогите плиз.
Спасибо.
К сообщению приложен файл: 1325182.xlsx(10Kb)
 
Ответить
СообщениеДобрый день.
Есть массив строк. Нужно найти в этом массиве строку в части текста которой содержится слово (или фраза) (пример во вложении).
Помогите плиз.
Спасибо.

Автор - sekii
Дата добавления - 16.11.2016 в 16:40
Karataev Дата: Среда, 16.11.2016, 16:45 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
...




Сообщение отредактировал Karataev - Среда, 16.11.2016, 16:49
 
Ответить
Сообщение...

Автор - Karataev
Дата добавления - 16.11.2016 в 16:45
Nic70y Дата: Среда, 16.11.2016, 16:47 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3475
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ВПР("*"&A2&"*";D$2:E$5;2;)
вдруг правильно
К сообщению приложен файл: 1149502.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ВПР("*"&A2&"*";D$2:E$5;2;)
вдруг правильно

Автор - Nic70y
Дата добавления - 16.11.2016 в 16:47
_Boroda_ Дата: Среда, 16.11.2016, 16:51 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вариант
Код
=ПРОСМОТР(;-ПОИСК(" "&A2&",";" "&D2:D5&",");E2:E5)

Если есть тексты "один" и "одиннадцать", а ищем "один", то найдет именно "один"
если ищем фразу, в которой не должно быть запятых, то вот так
Код
=ПРОСМОТР(;-ПОИСК(", "&A2&",";", "&D2:D5&",");E2:E5)
К сообщению приложен файл: 1325182_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вариант
Код
=ПРОСМОТР(;-ПОИСК(" "&A2&",";" "&D2:D5&",");E2:E5)

Если есть тексты "один" и "одиннадцать", а ищем "один", то найдет именно "один"
если ищем фразу, в которой не должно быть запятых, то вот так
Код
=ПРОСМОТР(;-ПОИСК(", "&A2&",";", "&D2:D5&",");E2:E5)

Автор - _Boroda_
Дата добавления - 16.11.2016 в 16:51
sekii Дата: Среда, 16.11.2016, 17:09 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Nic70y,
Ну вот это конечно круто:

"*"&A2&"*"

Спасибо большое!
 
Ответить
СообщениеNic70y,
Ну вот это конечно круто:

"*"&A2&"*"

Спасибо большое!

Автор - sekii
Дата добавления - 16.11.2016 в 17:09
Nic70y Дата: Среда, 16.11.2016, 19:56 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3475
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
"один" и "одиннадцать"
двадцать один и т.д.
вот это я не учел :(
всё, ухожу на пенсию!


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
"один" и "одиннадцать"
двадцать один и т.д.
вот это я не учел :(
всё, ухожу на пенсию!

Автор - Nic70y
Дата добавления - 16.11.2016 в 19:56
sekii Дата: Четверг, 17.11.2016, 10:44 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Nic70y,
А вот только не пойму, в конце точка с запятой после 2-ки это зачем?

E$5;2 ;)
 
Ответить
СообщениеNic70y,
А вот только не пойму, в конце точка с запятой после 2-ки это зачем?

E$5;2 ;)

Автор - sekii
Дата добавления - 17.11.2016 в 10:44
Nic70y Дата: Четверг, 17.11.2016, 11:08 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3475
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
по правильному правилу должно быть
Код
;ЛОЖЬ
, что = точному поиску,
но можно ;0 или ;ничего - это равноценно.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 17.11.2016, 11:09
 
Ответить
Сообщениепо правильному правилу должно быть
Код
;ЛОЖЬ
, что = точному поиску,
но можно ;0 или ;ничего - это равноценно.

Автор - Nic70y
Дата добавления - 17.11.2016 в 11:08
buchlotnik Дата: Четверг, 17.11.2016, 11:10 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
в конце точка с запятой после 2-ки это зачем?
затем, что по умолчанию последний аргумент ИСТИНА, т.е. приблизительное совпадение, а нужно ЛОЖЬ (оно же ноль, оно же ничего) - точное совпадение.
Можно переписать формулу как
Код
=ВПР("*"&A2&"*";D$2:E$5;2;0)
Код
=ВПР("*"&A2&"*";D$2:E$5;2;ЛОЖЬ)
это всё одно и то же


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
в конце точка с запятой после 2-ки это зачем?
затем, что по умолчанию последний аргумент ИСТИНА, т.е. приблизительное совпадение, а нужно ЛОЖЬ (оно же ноль, оно же ничего) - точное совпадение.
Можно переписать формулу как
Код
=ВПР("*"&A2&"*";D$2:E$5;2;0)
Код
=ВПР("*"&A2&"*";D$2:E$5;2;ЛОЖЬ)
это всё одно и то же

Автор - buchlotnik
Дата добавления - 17.11.2016 в 11:10
sekii Дата: Четверг, 17.11.2016, 14:11 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
buchlotnik,
Ага, понял. Спасибо!
 
Ответить
Сообщениеbuchlotnik,
Ага, понял. Спасибо!

Автор - sekii
Дата добавления - 17.11.2016 в 14:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск текста в массиве (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!