Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск текста в массиве - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск текста в массиве (Формулы/Formulas)
Поиск текста в массиве
sekii Дата: Среда, 16.11.2016, 16:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день.
Есть массив строк. Нужно найти в этом массиве строку в части текста которой содержится слово (или фраза) (пример во вложении).
Помогите плиз.
Спасибо.
К сообщению приложен файл: 1325182.xlsx(10Kb)
 
Ответить
СообщениеДобрый день.
Есть массив строк. Нужно найти в этом массиве строку в части текста которой содержится слово (или фраза) (пример во вложении).
Помогите плиз.
Спасибо.

Автор - sekii
Дата добавления - 16.11.2016 в 16:40
Karataev Дата: Среда, 16.11.2016, 16:45 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 873
Репутация: 325 ±
Замечаний: 0% ±

Excel
...




Сообщение отредактировал Karataev - Среда, 16.11.2016, 16:49
 
Ответить
Сообщение...

Автор - Karataev
Дата добавления - 16.11.2016 в 16:45
Nic70y Дата: Среда, 16.11.2016, 16:47 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4045
Репутация: 861 ±
Замечаний: 0% ±

Excel 2013
Код
=ВПР("*"&A2&"*";D$2:E$5;2;)
вдруг правильно
К сообщению приложен файл: 1149502.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ВПР("*"&A2&"*";D$2:E$5;2;)
вдруг правильно

Автор - Nic70y
Дата добавления - 16.11.2016 в 16:47
_Boroda_ Дата: Среда, 16.11.2016, 16:51 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10995
Репутация: 4565 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вариант
Код
=ПРОСМОТР(;-ПОИСК(" "&A2&",";" "&D2:D5&",");E2:E5)

Если есть тексты "один" и "одиннадцать", а ищем "один", то найдет именно "один"
если ищем фразу, в которой не должно быть запятых, то вот так
Код
=ПРОСМОТР(;-ПОИСК(", "&A2&",";", "&D2:D5&",");E2:E5)
К сообщению приложен файл: 1325182_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вариант
Код
=ПРОСМОТР(;-ПОИСК(" "&A2&",";" "&D2:D5&",");E2:E5)

Если есть тексты "один" и "одиннадцать", а ищем "один", то найдет именно "один"
если ищем фразу, в которой не должно быть запятых, то вот так
Код
=ПРОСМОТР(;-ПОИСК(", "&A2&",";", "&D2:D5&",");E2:E5)

Автор - _Boroda_
Дата добавления - 16.11.2016 в 16:51
sekii Дата: Среда, 16.11.2016, 17:09 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Nic70y,
Ну вот это конечно круто:

"*"&A2&"*"

Спасибо большое!
 
Ответить
СообщениеNic70y,
Ну вот это конечно круто:

"*"&A2&"*"

Спасибо большое!

Автор - sekii
Дата добавления - 16.11.2016 в 17:09
Nic70y Дата: Среда, 16.11.2016, 19:56 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4045
Репутация: 861 ±
Замечаний: 0% ±

Excel 2013
"один" и "одиннадцать"
двадцать один и т.д.
вот это я не учел :(
всё, ухожу на пенсию!


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
"один" и "одиннадцать"
двадцать один и т.д.
вот это я не учел :(
всё, ухожу на пенсию!

Автор - Nic70y
Дата добавления - 16.11.2016 в 19:56
sekii Дата: Четверг, 17.11.2016, 10:44 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Nic70y,
А вот только не пойму, в конце точка с запятой после 2-ки это зачем?

E$5;2 ;)
 
Ответить
СообщениеNic70y,
А вот только не пойму, в конце точка с запятой после 2-ки это зачем?

E$5;2 ;)

Автор - sekii
Дата добавления - 17.11.2016 в 10:44
Nic70y Дата: Четверг, 17.11.2016, 11:08 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4045
Репутация: 861 ±
Замечаний: 0% ±

Excel 2013
по правильному правилу должно быть
Код
;ЛОЖЬ
, что = точному поиску,
но можно ;0 или ;ничего - это равноценно.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 17.11.2016, 11:09
 
Ответить
Сообщениепо правильному правилу должно быть
Код
;ЛОЖЬ
, что = точному поиску,
но можно ;0 или ;ничего - это равноценно.

Автор - Nic70y
Дата добавления - 17.11.2016 в 11:08
buchlotnik Дата: Четверг, 17.11.2016, 11:10 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2866
Репутация: 806 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
в конце точка с запятой после 2-ки это зачем?
затем, что по умолчанию последний аргумент ИСТИНА, т.е. приблизительное совпадение, а нужно ЛОЖЬ (оно же ноль, оно же ничего) - точное совпадение.
Можно переписать формулу как
Код
=ВПР("*"&A2&"*";D$2:E$5;2;0)
Код
=ВПР("*"&A2&"*";D$2:E$5;2;ЛОЖЬ)
это всё одно и то же


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
в конце точка с запятой после 2-ки это зачем?
затем, что по умолчанию последний аргумент ИСТИНА, т.е. приблизительное совпадение, а нужно ЛОЖЬ (оно же ноль, оно же ничего) - точное совпадение.
Можно переписать формулу как
Код
=ВПР("*"&A2&"*";D$2:E$5;2;0)
Код
=ВПР("*"&A2&"*";D$2:E$5;2;ЛОЖЬ)
это всё одно и то же

Автор - buchlotnik
Дата добавления - 17.11.2016 в 11:10
sekii Дата: Четверг, 17.11.2016, 14:11 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
buchlotnik,
Ага, понял. Спасибо!
 
Ответить
Сообщениеbuchlotnik,
Ага, понял. Спасибо!

Автор - sekii
Дата добавления - 17.11.2016 в 14:11
devray Дата: Воскресенье, 18.06.2017, 14:37 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Такой вариант

=ПРОСМОТР(;-ПОИСК(" "&A2&",";" "&D2:D5&",");E2:E5)

Здравствуйте!
Вижу, что формула рабочая, но мне в ней многое непонятно(( Не первый день пытаюсь понять синтаксис.
1)В формуле отсутствует Искомое_значение, хотя в описании функции оно является обязательным. Но ведь работает!
2)"-" перед функцией ПОИСК - что он означает?
3) Вижу, что определяющую роль так же играют записи " "&A2&"," и " "&D2:D5&",". Но логику понять не могу. Как я поняла, исходя из этого ПОИСК ищет запись " один,", но ведь нужен поиск просто "один".
В общем, нет мне покоя...мозг взорван(((
Помогите понять, пожалуйста!


Сообщение отредактировал devray - Воскресенье, 18.06.2017, 15:00
 
Ответить
Сообщение
Такой вариант

=ПРОСМОТР(;-ПОИСК(" "&A2&",";" "&D2:D5&",");E2:E5)

Здравствуйте!
Вижу, что формула рабочая, но мне в ней многое непонятно(( Не первый день пытаюсь понять синтаксис.
1)В формуле отсутствует Искомое_значение, хотя в описании функции оно является обязательным. Но ведь работает!
2)"-" перед функцией ПОИСК - что он означает?
3) Вижу, что определяющую роль так же играют записи " "&A2&"," и " "&D2:D5&",". Но логику понять не могу. Как я поняла, исходя из этого ПОИСК ищет запись " один,", но ведь нужен поиск просто "один".
В общем, нет мне покоя...мозг взорван(((
Помогите понять, пожалуйста!

Автор - devray
Дата добавления - 18.06.2017 в 14:37
_Boroda_ Дата: Воскресенье, 18.06.2017, 22:03 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10995
Репутация: 4565 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Наталья, прежде всего посмотрите мою объяснялку для ПРОСМОТРа вот здесь http://www.excelworld.ru/forum/2-16573-138042-16-1427281717
а) Для нашей формулы пункты а, б и в свернутся в один пункт - ПОИСК значения " "&A2&"," в диапазоне " "&D2:D5&"," даст нам или какое-то положительное число (если значение есть) или ошибку (если значения нет).
г) Минус переводит положительное число из п. а) в отрицательное (ошибки так ошибками и остаются)
д) "Искомое значение" не отсутствует, оно равно нулю. Такая запись ПРОСМОТР(;... подразумевает, что перед запятой стоит ноль. Это аналогично вот этому ПРОСМОТР(0;...

запись " "&A2&"," - мы прилепляем к искомому слева пробел и справа запятую. Аналогично и для записи " "&D2:D5&",". Зачем? А чтобы четко ограничить поиск - слева от слова должен быть пробел, а справа - запятая. Чтобы не найти "один" в "одиннадцать" или в "двадцать один".
Кстати, поэтому (для "двадцать один") лучше к пробелу слева добавить еще и запятую и использовать формулу
Код
=ПРОСМОТР(;-ПОИСК(", "&A2&",";", "&D2:D5&",");E2:E5)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНаталья, прежде всего посмотрите мою объяснялку для ПРОСМОТРа вот здесь http://www.excelworld.ru/forum/2-16573-138042-16-1427281717
а) Для нашей формулы пункты а, б и в свернутся в один пункт - ПОИСК значения " "&A2&"," в диапазоне " "&D2:D5&"," даст нам или какое-то положительное число (если значение есть) или ошибку (если значения нет).
г) Минус переводит положительное число из п. а) в отрицательное (ошибки так ошибками и остаются)
д) "Искомое значение" не отсутствует, оно равно нулю. Такая запись ПРОСМОТР(;... подразумевает, что перед запятой стоит ноль. Это аналогично вот этому ПРОСМОТР(0;...

запись " "&A2&"," - мы прилепляем к искомому слева пробел и справа запятую. Аналогично и для записи " "&D2:D5&",". Зачем? А чтобы четко ограничить поиск - слева от слова должен быть пробел, а справа - запятая. Чтобы не найти "один" в "одиннадцать" или в "двадцать один".
Кстати, поэтому (для "двадцать один") лучше к пробелу слева добавить еще и запятую и использовать формулу
Код
=ПРОСМОТР(;-ПОИСК(", "&A2&",";", "&D2:D5&",");E2:E5)

Автор - _Boroda_
Дата добавления - 18.06.2017 в 22:03
devray Дата: Воскресенье, 18.06.2017, 22:26 | Сообщение № 13
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, спасибо большое за пояснения! А то и сегодня полдня сижу над этой задачей и все без особых успехов... Попробую разобраться! :))


Сообщение отредактировал devray - Воскресенье, 18.06.2017, 22:38
 
Ответить
Сообщение_Boroda_, спасибо большое за пояснения! А то и сегодня полдня сижу над этой задачей и все без особых успехов... Попробую разобраться! :))

Автор - devray
Дата добавления - 18.06.2017 в 22:26
zs Дата: Понедельник, 19.06.2017, 15:51 | Сообщение № 14
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
Код
=ЕСЛИ(ЕОШ(ПОИСК(", один,";","&" "&D7&",";1)>0);"не верно";"верно")
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕОШ(ПОИСК(", один,";","&" "&D7&",";1)>0);"не верно";"верно")

Автор - zs
Дата добавления - 19.06.2017 в 15:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск текста в массиве (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!