Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычитание списков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычитание списков (Формулы/Formulas)
Вычитание списков
AmsterDam Дата: Среда, 23.11.2016, 19:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Здравствуйте.
Есть 2 листа.
Нужно удалить целые строки, если есть совпадения со вторым листом.
Сравнивать нужно только столбцы A.
Пример прикрепляю.
Подскажите пожалуйста как сделать.
К сообщению приложен файл: 9191835.xlsx(17Kb)
 
Ответить
СообщениеЗдравствуйте.
Есть 2 листа.
Нужно удалить целые строки, если есть совпадения со вторым листом.
Сравнивать нужно только столбцы A.
Пример прикрепляю.
Подскажите пожалуйста как сделать.

Автор - AmsterDam
Дата добавления - 23.11.2016 в 19:48
gling Дата: Среда, 23.11.2016, 19:54 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Здравствуйте. Формулу в столбец С на втором листе и тянуть до конца данных.
Код
=СЧЁТЕСЛИ(Лист2!A:A;A3)
В фильтре снимаете галку с 0, что осталось выделить и удалить строки.
К сообщению приложен файл: 2743421.xlsx(20Kb)


Сообщение отредактировал gling - Среда, 23.11.2016, 19:55
 
Ответить
СообщениеЗдравствуйте. Формулу в столбец С на втором листе и тянуть до конца данных.
Код
=СЧЁТЕСЛИ(Лист2!A:A;A3)
В фильтре снимаете галку с 0, что осталось выделить и удалить строки.

Автор - gling
Дата добавления - 23.11.2016 в 19:54
Saff Дата: Четверг, 24.11.2016, 08:18 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 20% ±

Добрый день!
Можно ещё через условное форматирование, потом применить фильтр по цвету и удалить.

Добавляем в правило условного форматирования
Код
=СЧЁТЕСЛИ(Лист2!$A:$A;A1)<>0


Применяется к ячейкам
Код
=$A:$A
К сообщению приложен файл: 4353260.xlsx(21Kb)
 
Ответить
СообщениеДобрый день!
Можно ещё через условное форматирование, потом применить фильтр по цвету и удалить.

Добавляем в правило условного форматирования
Код
=СЧЁТЕСЛИ(Лист2!$A:$A;A1)<>0


Применяется к ячейкам
Код
=$A:$A

Автор - Saff
Дата добавления - 24.11.2016 в 08:18
AVI Дата: Четверг, 24.11.2016, 08:41 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Думается мне, что что бы удалить именно эту строку именно на этом листе то нужно нужно VBAшить.
Можно предложить другой вариант с переносом данных несовпадающих строк на другой лист/диапазон. Если рабочий файл большой, то может медленно работать.
 
Ответить
СообщениеДумается мне, что что бы удалить именно эту строку именно на этом листе то нужно нужно VBAшить.
Можно предложить другой вариант с переносом данных несовпадающих строк на другой лист/диапазон. Если рабочий файл большой, то может медленно работать.

Автор - AVI
Дата добавления - 24.11.2016 в 08:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычитание списков (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!