Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММПРОИЗВ. Выборка из массива по 2 критериям в дин. массив - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ. Выборка из массива по 2 критериям в дин. массив (Формулы/Formulas)
СУММПРОИЗВ. Выборка из массива по 2 критериям в дин. массив
fillbear Дата: Воскресенье, 27.11.2016, 07:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Добрый день!

Помогите дополнить формулу. В прилагаемом варианте происходит составление нового массива с динамическим числом столбцов.
Подскажите, как организовать третий массив в формуле СУММПРОИЗВ для отсечения нулевых элеметов в листе данных.
Что-то вроде команды ИНДЕКС для формирования, но не хочется использовать Alt-Shift-Enter.
Не судите строго, раньше мало занимался Excel'ем.

Спасибо.
С уважением, fillbear.
К сообщению приложен файл: _2016-11-27.xls(17Kb)
 
Ответить
СообщениеДобрый день!

Помогите дополнить формулу. В прилагаемом варианте происходит составление нового массива с динамическим числом столбцов.
Подскажите, как организовать третий массив в формуле СУММПРОИЗВ для отсечения нулевых элеметов в листе данных.
Что-то вроде команды ИНДЕКС для формирования, но не хочется использовать Alt-Shift-Enter.
Не судите строго, раньше мало занимался Excel'ем.

Спасибо.
С уважением, fillbear.

Автор - fillbear
Дата добавления - 27.11.2016 в 07:40
Pelena Дата: Воскресенье, 27.11.2016, 09:18 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
не хочется использовать Alt-Shift-Enter

Почему?
Вариант без массивного ввода, но зато с летучей СМЕЩ(). Даже не знаю, что лучше
Код
=СУММПРОИЗВ(C6:G6*(Ч(СМЕЩ(Данные!$B$3;ПОИСКПОЗ(Лист1!$B6;магазин;0);ПОИСКПОЗ(C$5:G$5;фрукты;)))>0))
К сообщению приложен файл: 6559806.xls(28Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
не хочется использовать Alt-Shift-Enter

Почему?
Вариант без массивного ввода, но зато с летучей СМЕЩ(). Даже не знаю, что лучше
Код
=СУММПРОИЗВ(C6:G6*(Ч(СМЕЩ(Данные!$B$3;ПОИСКПОЗ(Лист1!$B6;магазин;0);ПОИСКПОЗ(C$5:G$5;фрукты;)))>0))

Автор - Pelena
Дата добавления - 27.11.2016 в 09:18
fillbear Дата: Воскресенье, 27.11.2016, 10:30 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Pelena,
Не работает. Чего-то не хватает (помимо скобок в конце). Результат функции Ч: {20;20;20;20;20} , т. е. весь массив умножается на 20. Результат 4000.
А вообще, идея интересная, я в этом направлении не думал.
Ввод массива не желателен по причине нежелания вдаваться в объяснения с теми, кто с массивами не работает, но файлом пользоваться будет. Пусть громоздко, но без A+Sh+E.
Спасибо за понимание.
 
Ответить
СообщениеPelena,
Не работает. Чего-то не хватает (помимо скобок в конце). Результат функции Ч: {20;20;20;20;20} , т. е. весь массив умножается на 20. Результат 4000.
А вообще, идея интересная, я в этом направлении не думал.
Ввод массива не желателен по причине нежелания вдаваться в объяснения с теми, кто с массивами не работает, но файлом пользоваться будет. Пусть громоздко, но без A+Sh+E.
Спасибо за понимание.

Автор - fillbear
Дата добавления - 27.11.2016 в 10:30
Pelena Дата: Воскресенье, 27.11.2016, 10:40 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
В смысле "не хватает"?
В моём файле неверный результат?

----
Поняла. Это я исправляла формулу в сообщении и поломала. Исправила


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816


Сообщение отредактировал Pelena - Воскресенье, 27.11.2016, 10:42
 
Ответить
СообщениеВ смысле "не хватает"?
В моём файле неверный результат?

----
Поняла. Это я исправляла формулу в сообщении и поломала. Исправила

Автор - Pelena
Дата добавления - 27.11.2016 в 10:40
fillbear Дата: Воскресенье, 27.11.2016, 11:21 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Pelena, Спасибо большое!! Работает как нужно.

Подскажите, а для второй формулы (для стоимости), в чем моя ошибка? Массивы вроде бы одной размерности, что не так?
Код
=СУММПРОИЗВ(C6:G6;СМЕЩ(Данные!$B$3;ПОИСКПОЗ(Лист1!$B6;магазин;0);ПОИСКПОЗ(C$5:G$5;фрукты;0)))


В константах работает: 2080
Код
=СУММПРОИЗВ({50;10;80;20;40};{20;40;0;14;10})


Сообщение отредактировал fillbear - Воскресенье, 27.11.2016, 11:22
 
Ответить
СообщениеPelena, Спасибо большое!! Работает как нужно.

Подскажите, а для второй формулы (для стоимости), в чем моя ошибка? Массивы вроде бы одной размерности, что не так?
Код
=СУММПРОИЗВ(C6:G6;СМЕЩ(Данные!$B$3;ПОИСКПОЗ(Лист1!$B6;магазин;0);ПОИСКПОЗ(C$5:G$5;фрукты;0)))


В константах работает: 2080
Код
=СУММПРОИЗВ({50;10;80;20;40};{20;40;0;14;10})

Автор - fillbear
Дата добавления - 27.11.2016 в 11:21
Pelena Дата: Воскресенье, 27.11.2016, 11:57 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
в чем моя ошибка?

В отсутствии функции Ч() перед СМЕЩ().
СМЕЩ() - она такая капризная :)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
в чем моя ошибка?

В отсутствии функции Ч() перед СМЕЩ().
СМЕЩ() - она такая капризная :)

Автор - Pelena
Дата добавления - 27.11.2016 в 11:57
fillbear Дата: Воскресенье, 27.11.2016, 12:10 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Pelena, еще одно Спасибо!!! То, что нужно.
Посыпаю голову пеплом, ни за что бы не догадался.
Отныне буду следить за очевидной, но непредсказуемой СМЕЩ(). Пристально. ))
 
Ответить
СообщениеPelena, еще одно Спасибо!!! То, что нужно.
Посыпаю голову пеплом, ни за что бы не догадался.
Отныне буду следить за очевидной, но непредсказуемой СМЕЩ(). Пристально. ))

Автор - fillbear
Дата добавления - 27.11.2016 в 12:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ. Выборка из массива по 2 критериям в дин. массив (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!