Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подсчет в столбце одинак. знач. с условием соседней сточки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет в столбце одинак. знач. с условием соседней сточки (Формулы/Formulas)
подсчет в столбце одинак. знач. с условием соседней сточки
mega Дата: Вторник, 29.11.2016, 19:41 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Excel 2003
Ребята, всем привет.
Кипит голова над вот какой заморочкой, помогите знаниями.
Раньше у меня был столбец с выпадающим текстовым меню (1красный, 2красный, 3красный, 1синий, 2синий, 3 синий). От него мне требовался подсчет нужных значений выпадающего меню с присвоением ему нужного мне значения. Т.е. простой подсчет количества красного в ячейке итого для красного. В ячейке для итого синего считал количество синего.
Теперь у меня добавился рядом еще один столбец, тоже с выпадающим текстовым меню. И условие подсчета усложнилось.
Нужно, чтобы он так-же из всего диапазона столбца выискивал те-же значения (как и прежде), но при этом соблюдалось второе условие, он должен смотреть что указано в считаемой сточке во втором столбце. И соответсвенно уже считать, только если нужное значение, "Нового(появившегося)" столбца.


Сообщение отредактировал mega - Среда, 30.11.2016, 00:20
 
Ответить
СообщениеРебята, всем привет.
Кипит голова над вот какой заморочкой, помогите знаниями.
Раньше у меня был столбец с выпадающим текстовым меню (1красный, 2красный, 3красный, 1синий, 2синий, 3 синий). От него мне требовался подсчет нужных значений выпадающего меню с присвоением ему нужного мне значения. Т.е. простой подсчет количества красного в ячейке итого для красного. В ячейке для итого синего считал количество синего.
Теперь у меня добавился рядом еще один столбец, тоже с выпадающим текстовым меню. И условие подсчета усложнилось.
Нужно, чтобы он так-же из всего диапазона столбца выискивал те-же значения (как и прежде), но при этом соблюдалось второе условие, он должен смотреть что указано в считаемой сточке во втором столбце. И соответсвенно уже считать, только если нужное значение, "Нового(появившегося)" столбца.

Автор - mega
Дата добавления - 29.11.2016 в 19:41
Pelena Дата: Вторник, 29.11.2016, 19:56 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9842
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
mega, формулу надо заключать в теги (кнопка fx) и файл прикладывать в формате Excel


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеmega, формулу надо заключать в теги (кнопка fx) и файл прикладывать в формате Excel

Автор - Pelena
Дата добавления - 29.11.2016 в 19:56
gling Дата: Вторник, 29.11.2016, 21:56 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Здравствуйте mega, если Вы на сфотографированном листе разместите по столбцам число в столбец В, текст в столбец С и этот файл приложите к сообщению на форуме, помочь Вам будет гораздо легче. чем сейчас глядя на картинку 3764039.jpg(43Kb). После изменений в файле можно будет использовать СУММЕСЛИМН.


Сообщение отредактировал gling - Вторник, 29.11.2016, 21:57
 
Ответить
СообщениеЗдравствуйте mega, если Вы на сфотографированном листе разместите по столбцам число в столбец В, текст в столбец С и этот файл приложите к сообщению на форуме, помочь Вам будет гораздо легче. чем сейчас глядя на картинку 3764039.jpg(43Kb). После изменений в файле можно будет использовать СУММЕСЛИМН.

Автор - gling
Дата добавления - 29.11.2016 в 21:56
mega Дата: Вторник, 29.11.2016, 23:45 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Excel 2003
gling, здравствуйте.
Постараюсь внести ясность.
У меня есть два длинных столбца А, B и С.
Первое условие!!!
В столбце B (Организатор) у данных вот такие значения будут
1красный = 1
2красный = 2
3красный = 3
1синий = 1
2синий = 2
3синий =3
т.е. нужен подсчет общего числа красных, это получается 6 (1+2+3=6). И подсчет синих (соответственно тоже 6). ЭТО КАСАЕМО ПРИНЦИПА ПОДСЧЕТА ПО УСЛОВИЮ "ОРГАНИЗАТОР"

Второе условие!!!
Есть столбец А (Вид).
Он нужен как раз таки только для выборки значений. Т.е. для отдельного подсчета по каждому из его уникальных значений (Пульт, Плазма, Игра, Дерево, Инструмент) столбца "Организатор"

Если с этим разберемся, то условие для подсчета столбца "Число" я уже по аналогии сделаю. Там просто +еще одно условие будет.

Все дело в том, что такую выборку просто сделать для одной стоки (Если в ячейке такой значение то, и в другой ячейке то, то вот это, если нет то другое). А у меня таких строк бесконечность. Вот и нужно как то это написать для всего диапазона
К сообщению приложен файл: 4276264.xls(19Kb)
 
Ответить
Сообщениеgling, здравствуйте.
Постараюсь внести ясность.
У меня есть два длинных столбца А, B и С.
Первое условие!!!
В столбце B (Организатор) у данных вот такие значения будут
1красный = 1
2красный = 2
3красный = 3
1синий = 1
2синий = 2
3синий =3
т.е. нужен подсчет общего числа красных, это получается 6 (1+2+3=6). И подсчет синих (соответственно тоже 6). ЭТО КАСАЕМО ПРИНЦИПА ПОДСЧЕТА ПО УСЛОВИЮ "ОРГАНИЗАТОР"

Второе условие!!!
Есть столбец А (Вид).
Он нужен как раз таки только для выборки значений. Т.е. для отдельного подсчета по каждому из его уникальных значений (Пульт, Плазма, Игра, Дерево, Инструмент) столбца "Организатор"

Если с этим разберемся, то условие для подсчета столбца "Число" я уже по аналогии сделаю. Там просто +еще одно условие будет.

Все дело в том, что такую выборку просто сделать для одной стоки (Если в ячейке такой значение то, и в другой ячейке то, то вот это, если нет то другое). А у меня таких строк бесконечность. Вот и нужно как то это написать для всего диапазона

Автор - mega
Дата добавления - 29.11.2016 в 23:45
buchlotnik Дата: Вторник, 29.11.2016, 23:54 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
зачем же так кричать?

как понял:
Код
=СУММПРОИЗВ(ЛЕВСИМВ($B$2:$B$12)*ЕЧИСЛО(ПОИСК($E2;$B$2:$B$12))*($A$2:$A$12=F$1))
Код
=СУММЕСЛИ($A$2:$A$12;F1;$C$2:$C$12)
К сообщению приложен файл: 3824682.xls(44Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениезачем же так кричать?

как понял:
Код
=СУММПРОИЗВ(ЛЕВСИМВ($B$2:$B$12)*ЕЧИСЛО(ПОИСК($E2;$B$2:$B$12))*($A$2:$A$12=F$1))
Код
=СУММЕСЛИ($A$2:$A$12;F1;$C$2:$C$12)

Автор - buchlotnik
Дата добавления - 29.11.2016 в 23:54
buchlotnik Дата: Среда, 30.11.2016, 00:26 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
mega, зачем в личку писать? это форум - см. правила. Проверяйте (массивка):
Код
=СУММ(ЕСЛИ(ЕТЕКСТ($B$2:$B$20);ЛЕВСИМВ($B$2:$B$20))*ЕЧИСЛО(ПОИСК($E2;$B$2:$B$20))*($A$2:$A$20=F$1))
К сообщению приложен файл: 3824682-1-.xls(36Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеmega, зачем в личку писать? это форум - см. правила. Проверяйте (массивка):
Код
=СУММ(ЕСЛИ(ЕТЕКСТ($B$2:$B$20);ЛЕВСИМВ($B$2:$B$20))*ЕЧИСЛО(ПОИСК($E2;$B$2:$B$20))*($A$2:$A$20=F$1))

Автор - buchlotnik
Дата добавления - 30.11.2016 в 00:26
mega Дата: Среда, 30.11.2016, 16:47 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Excel 2003
buchlotnik, получилось, спасибо. Большую часть сделал по вашему примеру.
Вот только теперь выяснилось, что алгоритм подсчета немного изменился и формат записей выборки то-же.
*В прикрепленной таблице я указал образец и способ подсчета.
Сможете снова подсобить?
К сообщению приложен файл: 3257738.xls(20Kb)


Сообщение отредактировал mega - Среда, 30.11.2016, 23:33
 
Ответить
Сообщениеbuchlotnik, получилось, спасибо. Большую часть сделал по вашему примеру.
Вот только теперь выяснилось, что алгоритм подсчета немного изменился и формат записей выборки то-же.
*В прикрепленной таблице я указал образец и способ подсчета.
Сможете снова подсобить?

Автор - mega
Дата добавления - 30.11.2016 в 16:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет в столбце одинак. знач. с условием соседней сточки (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!