Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подсчёт данных по столбцам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчёт данных по столбцам (Формулы/Formulas)
подсчёт данных по столбцам
solomon Дата: Вторник, 29.11.2016, 20:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Не пинайте :D Только учусь. Необходимо подсчитать кол-во заполненных ячеек в столбце ,потом разделить число (кол-во ячеек)на число в этом столбце в определённой ячейке.Затем в конечных столбцах в каждой строке сложить полученные результаты. Можно формулами или макросом.
К сообщению приложен файл: 2476908.xlsx(12Kb)
 
Ответить
СообщениеНе пинайте :D Только учусь. Необходимо подсчитать кол-во заполненных ячеек в столбце ,потом разделить число (кол-во ячеек)на число в этом столбце в определённой ячейке.Затем в конечных столбцах в каждой строке сложить полученные результаты. Можно формулами или макросом.

Автор - solomon
Дата добавления - 29.11.2016 в 20:53
Pelena Дата: Вторник, 29.11.2016, 21:15 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9857
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Формула массива
Код
=СУММПРОИЗВ(ЕЧИСЛО($C2:$AG2)*ЕСЛИОШИБКА($C$9:$AG$9/МУМНОЖ(ТРАНСП(СТРОКА($B$2:$B$7))^0;--ЕЧИСЛО($C$2:$AG$7));0))
К сообщению приложен файл: 6640547.xlsx(13Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива
Код
=СУММПРОИЗВ(ЕЧИСЛО($C2:$AG2)*ЕСЛИОШИБКА($C$9:$AG$9/МУМНОЖ(ТРАНСП(СТРОКА($B$2:$B$7))^0;--ЕЧИСЛО($C$2:$AG$7));0))

Автор - Pelena
Дата добавления - 29.11.2016 в 21:15
AlexM Дата: Вторник, 29.11.2016, 21:31 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Без функции ЕСЛИОШИБКА(), формула массива
Код
=СУММ((C2:AG2>0)*C$9:AG$9/ТЕКСТ(МУМНОЖ(ТРАНСП(СТРОКА(B2:B7))^0;Ч(C$2:AG$7>0));"0;;1"))


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Вторник, 29.11.2016, 23:29
 
Ответить
СообщениеБез функции ЕСЛИОШИБКА(), формула массива
Код
=СУММ((C2:AG2>0)*C$9:AG$9/ТЕКСТ(МУМНОЖ(ТРАНСП(СТРОКА(B2:B7))^0;Ч(C$2:AG$7>0));"0;;1"))

Автор - AlexM
Дата добавления - 29.11.2016 в 21:31
solomon Дата: Вторник, 29.11.2016, 22:01 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Без функции ЕСЛИОШИБКА(), формула массива

вставил- выдает -ошибка в значении(значение используемое в формуле имеет неправильный тип данных)
 
Ответить
Сообщение
Без функции ЕСЛИОШИБКА(), формула массива

вставил- выдает -ошибка в значении(значение используемое в формуле имеет неправильный тип данных)

Автор - solomon
Дата добавления - 29.11.2016 в 22:01
buchlotnik Дата: Вторник, 29.11.2016, 22:13 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
solomon, а вы точно ввели формулу как формулу массива?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеsolomon, а вы точно ввели формулу как формулу массива?

Автор - buchlotnik
Дата добавления - 29.11.2016 в 22:13
solomon Дата: Вторник, 29.11.2016, 22:20 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
вы точно ввели формулу как формулу массива?
учусь %) вводил не так надо было Ctrl + Shift + Enter


Сообщение отредактировал solomon - Вторник, 29.11.2016, 22:23
 
Ответить
Сообщение
вы точно ввели формулу как формулу массива?
учусь %) вводил не так надо было Ctrl + Shift + Enter

Автор - solomon
Дата добавления - 29.11.2016 в 22:20
AlexM Дата: Среда, 30.11.2016, 02:09 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Еще вариант
Код
=СУММ(ЕСЛИ(C2:AG2;C$9:AG$9/МУМНОЖ(ТРАНСП(СТРОКА(B2:B7))^0;Ч(C$2:AG$7>0))))


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще вариант
Код
=СУММ(ЕСЛИ(C2:AG2;C$9:AG$9/МУМНОЖ(ТРАНСП(СТРОКА(B2:B7))^0;Ч(C$2:AG$7>0))))

Автор - AlexM
Дата добавления - 30.11.2016 в 02:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчёт данных по столбцам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!