Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение места крайней НЕнулевой ячейки в столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение места крайней НЕнулевой ячейки в столбце (Формулы/Formulas)
Определение места крайней НЕнулевой ячейки в столбце
Arkanzas Дата: Вторник, 25.04.2017, 13:05 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте уважаемы знатоки MS Exel!

Снова вынужден к Вам обратиться за помощью т.к сам не осилил и на других форумах не нашел подходящего решения.
Прошу набраться терпения и дочитать до конца, зайду издалека т.к не знаю как это объяснить коротко:)
Есть рабочая таблица в которой я каждый день отмечаю детали которые были смонтированы, по датам (столбцы E-G). В ячейке I1 есть открывающийся список дат. Я выбираю нужную мне дату и в том же столбце появляются марки с их количеством в скобках и запятой после скобки - II-ФО-41 (1шт),

Мне нужно чтобы формула (которя вписана в ячейках столбца I) проверяла, является ли проверяемая ячейка последней НЕНУЛЕВОЙ в этом столце и выводила то же значение, но без запятой т.е вот так II-ФО-41 (1шт)

Очень надеюсь на Вашу помощь
К сообщению приложен файл: 5093787.xlsx(12Kb)
 
Ответить
СообщениеЗдравствуйте уважаемы знатоки MS Exel!

Снова вынужден к Вам обратиться за помощью т.к сам не осилил и на других форумах не нашел подходящего решения.
Прошу набраться терпения и дочитать до конца, зайду издалека т.к не знаю как это объяснить коротко:)
Есть рабочая таблица в которой я каждый день отмечаю детали которые были смонтированы, по датам (столбцы E-G). В ячейке I1 есть открывающийся список дат. Я выбираю нужную мне дату и в том же столбце появляются марки с их количеством в скобках и запятой после скобки - II-ФО-41 (1шт),

Мне нужно чтобы формула (которя вписана в ячейках столбца I) проверяла, является ли проверяемая ячейка последней НЕНУЛЕВОЙ в этом столце и выводила то же значение, но без запятой т.е вот так II-ФО-41 (1шт)

Очень надеюсь на Вашу помощь

Автор - Arkanzas
Дата добавления - 25.04.2017 в 13:05
китин Дата: Вторник, 25.04.2017, 13:16 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4420
Репутация: 698 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну как то так примерно
Код
=ЕСЛИ(ИНДЕКС($E3:$G3;;ПОИСКПОЗ($K$1;$E$1:$G$1;0))=0;"";$D3&"("&ИНДЕКС($E3:$G3;;ПОИСКПОЗ($K$1;$E$1:$G$1;0))&") шт.")

я тут просто убрал доп.столбец Н
а если вам надо просто убрать запятую, то
Код
=ЕСЛИ(H3=0;"";" "&D3&" ("&H3&"шт)")
К сообщению приложен файл: 222333.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 25.04.2017, 13:22
 
Ответить
Сообщениену как то так примерно
Код
=ЕСЛИ(ИНДЕКС($E3:$G3;;ПОИСКПОЗ($K$1;$E$1:$G$1;0))=0;"";$D3&"("&ИНДЕКС($E3:$G3;;ПОИСКПОЗ($K$1;$E$1:$G$1;0))&") шт.")

я тут просто убрал доп.столбец Н
а если вам надо просто убрать запятую, то
Код
=ЕСЛИ(H3=0;"";" "&D3&" ("&H3&"шт)")

Автор - китин
Дата добавления - 25.04.2017 в 13:16
Perfect2You Дата: Вторник, 25.04.2017, 13:16 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 234
Репутация: 59 ±
Замечаний: 0% ±

Excel 2010
Такая формула решает задачу:
Код
=ЕСЛИ(H3=0;"";" "&D3&" ("&H3&"шт)"&ЕСЛИ(СЧЁТЕСЛИ($H:$H;">0")=СЧЁТЕСЛИ($H$1:$H3;">0");"";","))
К сообщению приложен файл: _5093787.xlsx(12Kb)
 
Ответить
СообщениеТакая формула решает задачу:
Код
=ЕСЛИ(H3=0;"";" "&D3&" ("&H3&"шт)"&ЕСЛИ(СЧЁТЕСЛИ($H:$H;">0")=СЧЁТЕСЛИ($H$1:$H3;">0");"";","))

Автор - Perfect2You
Дата добавления - 25.04.2017 в 13:16
AlexM Дата: Вторник, 25.04.2017, 13:52 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3602
Репутация: 903 ±
Замечаний: 0% ±

Excel 2003
Еще варианты. Дополнительный столбец Н не нужен
Код
=ЕСЛИ(СУММЕСЛИ(E$1:G$1;H$1;E3:G3);D3&" ("&СУММЕСЛИ(E$1:G$1;H$1;E3:G3)&"шт)";"")
или
Код
=ТЕКСТ(СУММЕСЛИ(E$1:G$1;H$1;E3:G3);D3&"\ (0\ шт);;")
К сообщению приложен файл: 5093787_01.xlsx(12Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще варианты. Дополнительный столбец Н не нужен
Код
=ЕСЛИ(СУММЕСЛИ(E$1:G$1;H$1;E3:G3);D3&" ("&СУММЕСЛИ(E$1:G$1;H$1;E3:G3)&"шт)";"")
или
Код
=ТЕКСТ(СУММЕСЛИ(E$1:G$1;H$1;E3:G3);D3&"\ (0\ шт);;")

Автор - AlexM
Дата добавления - 25.04.2017 в 13:52
Arkanzas Дата: Вторник, 25.04.2017, 14:18 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Perfect2You, формула работает. Спасибо большое!! Не ожидал, что так быстро получу ответ. Спасибо!)
Есть небольшая просьба к Вам, не могли бы вы объяснить как она работает?
Я просто стараюсь развиваться, но с формулой СЧЕТЕСЛИ не сталкивался вовсе.
А особенно интересно, почему в уравнении вторая функций "Счетесли") ссылается на закрепленный диапазон H1:H3? Это принципиально влияет на результат?
Буду премного благодарен!)


Сообщение отредактировал Arkanzas - Вторник, 25.04.2017, 14:19
 
Ответить
СообщениеPerfect2You, формула работает. Спасибо большое!! Не ожидал, что так быстро получу ответ. Спасибо!)
Есть небольшая просьба к Вам, не могли бы вы объяснить как она работает?
Я просто стараюсь развиваться, но с формулой СЧЕТЕСЛИ не сталкивался вовсе.
А особенно интересно, почему в уравнении вторая функций "Счетесли") ссылается на закрепленный диапазон H1:H3? Это принципиально влияет на результат?
Буду премного благодарен!)

Автор - Arkanzas
Дата добавления - 25.04.2017 в 14:18
Perfect2You Дата: Вторник, 25.04.2017, 14:31 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 234
Репутация: 59 ±
Замечаний: 0% ±

Excel 2010
$H$1:$H3 - не совсем закрепленный диапазон. Столбец закреплен везде, 1 - тоже, а вот 3 - нет. При копировании диапазон проверки увеличивается. Когда доходит до последнего заполненного значения, количество заполненных ячеек по столбцу $H:$H сравнивается с количеством заполненных ячеек до текущей строки и это тот моммент, когда запятая по Вашему условию не нужна.
 
Ответить
Сообщение$H$1:$H3 - не совсем закрепленный диапазон. Столбец закреплен везде, 1 - тоже, а вот 3 - нет. При копировании диапазон проверки увеличивается. Когда доходит до последнего заполненного значения, количество заполненных ячеек по столбцу $H:$H сравнивается с количеством заполненных ячеек до текущей строки и это тот моммент, когда запятая по Вашему условию не нужна.

Автор - Perfect2You
Дата добавления - 25.04.2017 в 14:31
Arkanzas Дата: Среда, 26.04.2017, 16:30 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Perfect2You, Спасибо! Все понятно и главное просто!
Я немного надстроил эту формулу и получилось все как надо! Спасибо!

P/S Всегда когда ставлю себе какую-либо "сложную" задачу, голова закипает при поиске решения, в итоге когда решаюсь написать вопрос на форуме, в голове уже представляется, что если ответ будет (в этом случает я себе так голову заморочил, что начал думать, что задача не имеет решения), то это будет какая-то нереально длинная и сложная формула их 100-500 различных функций, но когда вижу ответ улыбаюсь и плачу от простоты и доступности.
Обожаю Exel)))
 
Ответить
СообщениеPerfect2You, Спасибо! Все понятно и главное просто!
Я немного надстроил эту формулу и получилось все как надо! Спасибо!

P/S Всегда когда ставлю себе какую-либо "сложную" задачу, голова закипает при поиске решения, в итоге когда решаюсь написать вопрос на форуме, в голове уже представляется, что если ответ будет (в этом случает я себе так голову заморочил, что начал думать, что задача не имеет решения), то это будет какая-то нереально длинная и сложная формула их 100-500 различных функций, но когда вижу ответ улыбаюсь и плачу от простоты и доступности.
Обожаю Exel)))

Автор - Arkanzas
Дата добавления - 26.04.2017 в 16:30
vikttur Дата: Суббота, 29.04.2017, 15:55 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2521
Репутация: 452 ±
Замечаний: 0% ±

Код
=ЕСЛИОШИБКА(D3&" ("&1/ПРОСМОТР(999;1/($E$1:$G$1=$I$1);E3:G3)&"шт.)";"")
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(D3&" ("&1/ПРОСМОТР(999;1/($E$1:$G$1=$I$1);E3:G3)&"шт.)";"")

Автор - vikttur
Дата добавления - 29.04.2017 в 15:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение места крайней НЕнулевой ячейки в столбце (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!