Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/автоматический расчет по тексту - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » автоматический расчет по тексту (Формулы/Formulas)
автоматический расчет по тексту
gorodgrehov Дата: Пятница, 28.04.2017, 14:40 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день друзья, необходимо, чтобы в листе протокол в текст автоматически копировалось количество и сумма, так же снизу чтобы автоматически считала и выводила итог.
Пример во вложении: указал 3 цветом где и что должно копироваться и считать.

Спасибо.
К сообщению приложен файл: _2.xlsx(17Kb)
 
Ответить
СообщениеДобрый день друзья, необходимо, чтобы в листе протокол в текст автоматически копировалось количество и сумма, так же снизу чтобы автоматически считала и выводила итог.
Пример во вложении: указал 3 цветом где и что должно копироваться и считать.

Спасибо.

Автор - gorodgrehov
Дата добавления - 28.04.2017 в 14:40
Фомулист Дата: Пятница, 28.04.2017, 15:07 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 137
Репутация: 2 ±
Замечаний: 60% ±

Excel 2003
указал 3 цветом где

Что-то я так и не понял
где и что должно копироваться и считать.


Терпение и труд всё перетрут!
 
Ответить
Сообщение
указал 3 цветом где

Что-то я так и не понял
где и что должно копироваться и считать.

Автор - Фомулист
Дата добавления - 28.04.2017 в 15:07
gorodgrehov Дата: Пятница, 28.04.2017, 15:19 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
1. входе инвентаризации количество и сумма.
а. Излишки
б. недостачи
в. пересортица
должно копировать количество и сумму в тексте *по результатам инвентаризации и т.д. .... (по цвету показано что и где должно копироваться)
ещё ниже указано Излишки* и недостачи* нужно чтобы автоматически считало (не с текста а 1. входе инвентаризации количество и сумма. )
 
Ответить
Сообщение1. входе инвентаризации количество и сумма.
а. Излишки
б. недостачи
в. пересортица
должно копировать количество и сумму в тексте *по результатам инвентаризации и т.д. .... (по цвету показано что и где должно копироваться)
ещё ниже указано Излишки* и недостачи* нужно чтобы автоматически считало (не с текста а 1. входе инвентаризации количество и сумма. )

Автор - gorodgrehov
Дата добавления - 28.04.2017 в 15:19
Sancho Дата: Пятница, 28.04.2017, 15:48 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 9 ±
Замечаний: 0% ±

2007, 2010, 2013
gorodgrehov, добрый день!

Код
="* По результатам инвентаризации, проведенной в магазине выявленны недостачи в количестве "&ОКРУГЛ(A23;0)&" шт. на сумму "&ЦЕЛОЕ(A24)&" долларов "&ОКРУГЛ(ОСТАТ(A24;1)*100;0)&" центов, излишки в количестве "&ОКРУГЛ(A20;0)&" шт. на сумму "&ЦЕЛОЕ(A21)&" долларов "&ОКРУГЛ(ОСТАТ(A21;1)*100;0)&" центов, из них пересортица в количестве "&ОКРУГЛ(A26;1)&" шт. на сумму "&ЦЕЛОЕ(A27)&" долларов "&ОКРУГЛ(ОСТАТ(A27;1)*100;0)&" центов. Согласно временного стандарта  осуществляется взаимный зачет излишков и недостач  в отношении ТМЦ одного и того же наименования, т.е. :"


штуки дробными числами это как? если нужны все же дроби в штуках то нужно в ОКРУГЛ(A23;0) 0 заменить на нужное количество знаков после запятой, соответственно в других подобных значениях также.

вторую часть сделаете так же, ничего сложного. прям формулу расчета и подставите, например
Код
=ОКРУГЛ(A20;0)&" - "&ОКРУГЛ(A27;0)&" = "&ОКРУГЛ(A20-A27;0)&" шт."
К сообщению приложен файл: 6535648.xlsx(16Kb)


Сообщение отредактировал Sancho - Пятница, 28.04.2017, 15:59
 
Ответить
Сообщениеgorodgrehov, добрый день!

Код
="* По результатам инвентаризации, проведенной в магазине выявленны недостачи в количестве "&ОКРУГЛ(A23;0)&" шт. на сумму "&ЦЕЛОЕ(A24)&" долларов "&ОКРУГЛ(ОСТАТ(A24;1)*100;0)&" центов, излишки в количестве "&ОКРУГЛ(A20;0)&" шт. на сумму "&ЦЕЛОЕ(A21)&" долларов "&ОКРУГЛ(ОСТАТ(A21;1)*100;0)&" центов, из них пересортица в количестве "&ОКРУГЛ(A26;1)&" шт. на сумму "&ЦЕЛОЕ(A27)&" долларов "&ОКРУГЛ(ОСТАТ(A27;1)*100;0)&" центов. Согласно временного стандарта  осуществляется взаимный зачет излишков и недостач  в отношении ТМЦ одного и того же наименования, т.е. :"


штуки дробными числами это как? если нужны все же дроби в штуках то нужно в ОКРУГЛ(A23;0) 0 заменить на нужное количество знаков после запятой, соответственно в других подобных значениях также.

вторую часть сделаете так же, ничего сложного. прям формулу расчета и подставите, например
Код
=ОКРУГЛ(A20;0)&" - "&ОКРУГЛ(A27;0)&" = "&ОКРУГЛ(A20-A27;0)&" шт."

Автор - Sancho
Дата добавления - 28.04.2017 в 15:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » автоматический расчет по тексту (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!