Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск наибольшего количества каких букв в строке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск наибольшего количества каких букв в строке (Формулы/Formulas)
Поиск наибольшего количества каких букв в строке
ales2206 Дата: Понедельник, 01.05.2017, 10:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Простейшую формулу долго не могу правильно составить! Нужно у каждого ребенка найти чего больше (высокого, низкого или среднего уровня (в,н,с)) вывести эту букву в столбец I, не количество, а именно букву.
К сообщению приложен файл: 3230676.xlsx(12Kb)


Сообщение отредактировал ales2206 - Понедельник, 01.05.2017, 10:10
 
Ответить
СообщениеПростейшую формулу долго не могу правильно составить! Нужно у каждого ребенка найти чего больше (высокого, низкого или среднего уровня (в,н,с)) вывести эту букву в столбец I, не количество, а именно букву.

Автор - ales2206
Дата добавления - 01.05.2017 в 10:07
gling Дата: Понедельник, 01.05.2017, 10:11 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1568
Репутация: 385 ±
Замечаний: 0% ±

2010
Нужен пример с расположением данных и куда выводить результат.
 
Ответить
СообщениеНужен пример с расположением данных и куда выводить результат.

Автор - gling
Дата добавления - 01.05.2017 в 10:11
ales2206 Дата: Понедельник, 01.05.2017, 10:14 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Результат выводится в столбец I, в каждую строчку отдельно, все что зеленым выделено, получается на каждого ребенка !
 
Ответить
СообщениеРезультат выводится в столбец I, в каждую строчку отдельно, все что зеленым выделено, получается на каждого ребенка !

Автор - ales2206
Дата добавления - 01.05.2017 в 10:14
ales2206 Дата: Понедельник, 01.05.2017, 10:17 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Общее количество этих букв отдельно вывела в каждом столбце, а вот теперь построчно у каждого, чего больше (в или с или н) сообразить не могу
 
Ответить
СообщениеОбщее количество этих букв отдельно вывела в каждом столбце, а вот теперь построчно у каждого, чего больше (в или с или н) сообразить не могу

Автор - ales2206
Дата добавления - 01.05.2017 в 10:17
gling Дата: Понедельник, 01.05.2017, 10:25 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1568
Репутация: 385 ±
Замечаний: 0% ±

2010
Попробуйте так
Код
=ИНДЕКС({"в";"с";"н"};СУММПРОИЗВ(ПОИСКПОЗ(МАКС(СЧЁТЕСЛИ(B3:H3;{"в";"с";"н"}));СЧЁТЕСЛИ(B3:H3;{"в";"с";"н"});)))
или так
Код
=ИНДЕКС({"в";"с";"н"};ПОИСКПОЗ(МАКС(СЧЁТЕСЛИ(B4:H4;{"в";"с";"н"}));СЧЁТЕСЛИ(B4:H4;{"в";"с";"н"});))


Сообщение отредактировал gling - Понедельник, 01.05.2017, 10:27
 
Ответить
СообщениеПопробуйте так
Код
=ИНДЕКС({"в";"с";"н"};СУММПРОИЗВ(ПОИСКПОЗ(МАКС(СЧЁТЕСЛИ(B3:H3;{"в";"с";"н"}));СЧЁТЕСЛИ(B3:H3;{"в";"с";"н"});)))
или так
Код
=ИНДЕКС({"в";"с";"н"};ПОИСКПОЗ(МАКС(СЧЁТЕСЛИ(B4:H4;{"в";"с";"н"}));СЧЁТЕСЛИ(B4:H4;{"в";"с";"н"});))

Автор - gling
Дата добавления - 01.05.2017 в 10:25
ales2206 Дата: Понедельник, 01.05.2017, 10:30 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо большое !!!! Все выводит! yes hands
 
Ответить
СообщениеСпасибо большое !!!! Все выводит! yes hands

Автор - ales2206
Дата добавления - 01.05.2017 в 10:30
vikttur Дата: Понедельник, 01.05.2017, 12:01 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2199
Репутация: 382 ±
Замечаний: 0% ±

Код
=СИМВОЛ(ПРАВБ(МАКС(СЧЁТЕСЛИ(B3:H3;{"с";"в";"н"})+КОДСИМВ({"с";"в";"н"})/1000);3))
 
Ответить
Сообщение
Код
=СИМВОЛ(ПРАВБ(МАКС(СЧЁТЕСЛИ(B3:H3;{"с";"в";"н"})+КОДСИМВ({"с";"в";"н"})/1000);3))

Автор - vikttur
Дата добавления - 01.05.2017 в 12:01
AlexM Дата: Понедельник, 01.05.2017, 14:27 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3528
Репутация: 892 ±
Замечаний: 0% ±

Еще вариант
Код
=ИНДЕКС(B3:H3;МОДА(ПОИСКПОЗ(B3:H3;B3:H3;)))
К сообщению приложен файл: 3230676_01.xlsx(13Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 01.05.2017, 14:34
 
Ответить
СообщениеЕще вариант
Код
=ИНДЕКС(B3:H3;МОДА(ПОИСКПОЗ(B3:H3;B3:H3;)))

Автор - AlexM
Дата добавления - 01.05.2017 в 14:27
vikttur Дата: Понедельник, 01.05.2017, 14:38 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2199
Репутация: 382 ±
Замечаний: 0% ±

Отлично! Я МОДА отбросил сразу, т.к. нечисловые значения )
 
Ответить
СообщениеОтлично! Я МОДА отбросил сразу, т.к. нечисловые значения )

Автор - vikttur
Дата добавления - 01.05.2017 в 14:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск наибольшего количества каких букв в строке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!