Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автозаполнение формул вниз с шагом не равным 1 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение формул вниз с шагом не равным 1 (Формулы/Formulas)
Автозаполнение формул вниз с шагом не равным 1
korsar22 Дата: Вторник, 02.05.2017, 14:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
Возникла проблема при автозаполнении формул вниз с шагом ячеек не равным 1. Суть проблемы:
в столбце А2:А4001 находятся числовые значения, требуется провести их агрегацию с шагом 2, 4, 10. Т.е. надо чтобы была формула (шаг 4):
Код
B2=АГРЕГАТ(1,6,А2:А5)

Код
B3=АГРЕГАТ(1,6,А6:А10)

Код
B4=АГРЕГАТ(1,6,А11:А14)

а Excel при автозаполнении делает:
Код
B2=АГРЕГАТ(1,6,А2:А5)

Код
B3=АГРЕГАТ(1,6,А3:А6)

Код
B4=АГРЕГАТ(1,6,А4:А7)


Попытки написания формул с использованием СМЕЩ, ИНДЕКС выдают либо ошибку, либо не верный ответ, либо шаг меняется на 1.
К сообщению приложен файл: data_r.xlsx(78Kb)


Сообщение отредактировал korsar22 - Вторник, 02.05.2017, 14:51
 
Ответить
СообщениеДобрый день!
Возникла проблема при автозаполнении формул вниз с шагом ячеек не равным 1. Суть проблемы:
в столбце А2:А4001 находятся числовые значения, требуется провести их агрегацию с шагом 2, 4, 10. Т.е. надо чтобы была формула (шаг 4):
Код
B2=АГРЕГАТ(1,6,А2:А5)

Код
B3=АГРЕГАТ(1,6,А6:А10)

Код
B4=АГРЕГАТ(1,6,А11:А14)

а Excel при автозаполнении делает:
Код
B2=АГРЕГАТ(1,6,А2:А5)

Код
B3=АГРЕГАТ(1,6,А3:А6)

Код
B4=АГРЕГАТ(1,6,А4:А7)


Попытки написания формул с использованием СМЕЩ, ИНДЕКС выдают либо ошибку, либо не верный ответ, либо шаг меняется на 1.

Автор - korsar22
Дата добавления - 02.05.2017 в 14:49
Nic70y Дата: Вторник, 02.05.2017, 15:00 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4023
Репутация: 856 ±
Замечаний: 0% ±

Excel 2013
Код
=СРЗНАЧ(ИНДЕКС(A:A;(СТРОКА(A1)-1)*2+2):ИНДЕКС(A:A;(СТРОКА(A1)-1)*2+3))
Код
=СРЗНАЧ(ИНДЕКС(A:A;(СТРОКА(A1)-1)*4+2):ИНДЕКС(A:A;(СТРОКА(A1)-1)*4+5))
Код
=СРЗНАЧ(ИНДЕКС(A:A;(СТРОКА(A1)-1)*10+2):ИНДЕКС(A:A;(СТРОКА(A1)-1)*10+11))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СРЗНАЧ(ИНДЕКС(A:A;(СТРОКА(A1)-1)*2+2):ИНДЕКС(A:A;(СТРОКА(A1)-1)*2+3))
Код
=СРЗНАЧ(ИНДЕКС(A:A;(СТРОКА(A1)-1)*4+2):ИНДЕКС(A:A;(СТРОКА(A1)-1)*4+5))
Код
=СРЗНАЧ(ИНДЕКС(A:A;(СТРОКА(A1)-1)*10+2):ИНДЕКС(A:A;(СТРОКА(A1)-1)*10+11))

Автор - Nic70y
Дата добавления - 02.05.2017 в 15:00
sboy Дата: Вторник, 02.05.2017, 15:04 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 775
Репутация: 203 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
шаг 2
Код
=СРЗНАЧ(СМЕЩ(A$2:A$3;(СТРОКА(A1)-1)*2;))

шаг 4
Код
=СРЗНАЧ(СМЕЩ(A$2:A$5;(СТРОКА(A1)-1)*4;))

шаг 10
Код
=СРЗНАЧ(СМЕЩ(A$2:A$11;(СТРОКА(A1)-1)*10;))
 
Ответить
СообщениеДобрый день.
шаг 2
Код
=СРЗНАЧ(СМЕЩ(A$2:A$3;(СТРОКА(A1)-1)*2;))

шаг 4
Код
=СРЗНАЧ(СМЕЩ(A$2:A$5;(СТРОКА(A1)-1)*4;))

шаг 10
Код
=СРЗНАЧ(СМЕЩ(A$2:A$11;(СТРОКА(A1)-1)*10;))

Автор - sboy
Дата добавления - 02.05.2017 в 15:04
korsar22 Дата: Вторник, 02.05.2017, 21:36 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Большое спасибо, оба варианта работают!
 
Ответить
СообщениеБольшое спасибо, оба варианта работают!

Автор - korsar22
Дата добавления - 02.05.2017 в 21:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение формул вниз с шагом не равным 1 (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!