Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Условное форматирование не видит равенство значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условное форматирование не видит равенство значений (Формулы/Formulas)
Условное форматирование не видит равенство значений
Kattey Дата: Среда, 03.05.2017, 10:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
[r]Доброго времени суток!
Проблема следующая: в условном форматировании для ячейки F3 стоит условие: красить в зеленый, если значение ячейки равно сумме других ячеек.
Конкретно так:
Код
=СУММ(B3:D3)=F3
.

Формат ячеек - время.

К конкретном примере имею следующую ситуацию:

Сумма B3:D3 - 00:27:56 (сам excel так и считает, если отдельно вывести)
Значение F3 - 00:27:56

Сумма и значение совпадают, excel видит их как разные, и красит в красный.
Другие равные значение воспринимает адекватно, красит в зеленый при равенстве. Конкретно с этими - почему-то не видит равенство.

Подскажите, пожалуйста, как исправить форматирование?
К сообщению приложен файл: 3588199.xls(16Kb)


Сообщение отредактировал Kattey - Среда, 03.05.2017, 10:56
 
Ответить
Сообщение[r]Доброго времени суток!
Проблема следующая: в условном форматировании для ячейки F3 стоит условие: красить в зеленый, если значение ячейки равно сумме других ячеек.
Конкретно так:
Код
=СУММ(B3:D3)=F3
.

Формат ячеек - время.

К конкретном примере имею следующую ситуацию:

Сумма B3:D3 - 00:27:56 (сам excel так и считает, если отдельно вывести)
Значение F3 - 00:27:56

Сумма и значение совпадают, excel видит их как разные, и красит в красный.
Другие равные значение воспринимает адекватно, красит в зеленый при равенстве. Конкретно с этими - почему-то не видит равенство.

Подскажите, пожалуйста, как исправить форматирование?

Автор - Kattey
Дата добавления - 03.05.2017 в 10:45
_Boroda_ Дата: Среда, 03.05.2017, 10:52 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Евгений, ответ уже есть, но от Вас нужно, чтобы Вы немного поправили свой пост - формулы нужно обрамлять спецтегами (в Правилах есть ссылка на пояснялку)
Войдите в правку своего поста, выделите формулу и нажмите кнопку Fx


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕвгений, ответ уже есть, но от Вас нужно, чтобы Вы немного поправили свой пост - формулы нужно обрамлять спецтегами (в Правилах есть ссылка на пояснялку)
Войдите в правку своего поста, выделите формулу и нажмите кнопку Fx

Автор - _Boroda_
Дата добавления - 03.05.2017 в 10:52
SLAVICK Дата: Среда, 03.05.2017, 10:52 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1962
Репутация: 669 ±
Замечаний: 0% ±

2007,2010,2013,2016
Оформите формулы тегами:
Правка - выделить формулу - нажать кнопку Fx


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеОформите формулы тегами:
Правка - выделить формулу - нажать кнопку Fx

Автор - SLAVICK
Дата добавления - 03.05.2017 в 10:52
vikttur Дата: Среда, 03.05.2017, 10:52 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2123
Репутация: 374 ±
Замечаний: 0% ±

Ошибка формата вычислений
Почитать можно здесь:
https://www.google.com.ua/search?....e=UTF-8

В файле значения с отображением 20 знаков после запятой
К сообщению приложен файл: 8731441.xls(26Kb)


Сообщение отредактировал vikttur - Среда, 03.05.2017, 11:00
 
Ответить
СообщениеОшибка формата вычислений
Почитать можно здесь:
https://www.google.com.ua/search?....e=UTF-8

В файле значения с отображением 20 знаков после запятой

Автор - vikttur
Дата добавления - 03.05.2017 в 10:52
sboy Дата: Среда, 03.05.2017, 10:52 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 595
Репутация: 155 ±
Замечаний: 0% ±

Excel 2010
Удалено администрацией


Сообщение отредактировал sboy - Среда, 03.05.2017, 10:54
 
Ответить
СообщениеУдалено администрацией

Автор - sboy
Дата добавления - 03.05.2017 в 10:52
_Boroda_ Дата: Среда, 03.05.2017, 11:00 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такое безобразие из-за неверного округления в значащей 14-15 цифре. Майкрософт объясняет это вот так https://support.microsoft.com/ru-ru/kb/78113
Попробуйте такой вариант формулы
Код
=ОКРУГЛ(СУММ(B3:D3)-F3;9)

А зеленый в Условное форматирование можно вообще не класть, просто покрасьте зеленым саму ячейку F3
К сообщению приложен файл: 3588199_1.xls(30Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакое безобразие из-за неверного округления в значащей 14-15 цифре. Майкрософт объясняет это вот так https://support.microsoft.com/ru-ru/kb/78113
Попробуйте такой вариант формулы
Код
=ОКРУГЛ(СУММ(B3:D3)-F3;9)

А зеленый в Условное форматирование можно вообще не класть, просто покрасьте зеленым саму ячейку F3

Автор - _Boroda_
Дата добавления - 03.05.2017 в 11:00
Kattey Дата: Среда, 03.05.2017, 11:06 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
_Boroda_, спасибо за помощь!
 
Ответить
Сообщение_Boroda_, спасибо за помощь!

Автор - Kattey
Дата добавления - 03.05.2017 в 11:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условное форматирование не видит равенство значений (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!