Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выделить совпадение по трём значениям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выделить совпадение по трём значениям (Формулы/Formulas)
выделить совпадение по трём значениям
andron359 Дата: Среда, 03.05.2017, 15:07 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Добрый день ! Есть две таблицы 1 и 2 , если в 1 и 2 таблице есть точные совпадения по 3 значениям , то в 1 таблице эти 3 совпадения закрашиваются в цвет.
К сообщению приложен файл: 1232507.xlsx(12Kb)
 
Ответить
СообщениеДобрый день ! Есть две таблицы 1 и 2 , если в 1 и 2 таблице есть точные совпадения по 3 значениям , то в 1 таблице эти 3 совпадения закрашиваются в цвет.

Автор - andron359
Дата добавления - 03.05.2017 в 15:07
vikttur Дата: Среда, 03.05.2017, 15:26 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2121
Репутация: 374 ±
Замечаний: 0% ±

Условное_форматирование-Использовать_формулу:
Код
=И($B4<>"";$B4=$G4;$C4=$H4;$D4=$I4)

С отсечением лишних вычислений
Код
=ЕСЛИ($B4<>"";ЕСЛИ($B4=$G4;ЕСЛИ($C4=$H4;$D4=$I4)))
 
Ответить
СообщениеУсловное_форматирование-Использовать_формулу:
Код
=И($B4<>"";$B4=$G4;$C4=$H4;$D4=$I4)

С отсечением лишних вычислений
Код
=ЕСЛИ($B4<>"";ЕСЛИ($B4=$G4;ЕСЛИ($C4=$H4;$D4=$I4)))

Автор - vikttur
Дата добавления - 03.05.2017 в 15:26
sboy Дата: Среда, 03.05.2017, 15:41 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 583
Репутация: 154 ±
Замечаний: 0% ±

Excel 2010
[offtop] vikttur, Это не совсем то, что просил ТС и я не знаю, можно ли давать ответ, т.к. ТС нарушил пункт 5f. Ждем модераторов
 
Ответить
Сообщение[offtop] vikttur, Это не совсем то, что просил ТС и я не знаю, можно ли давать ответ, т.к. ТС нарушил пункт 5f. Ждем модераторов

Автор - sboy
Дата добавления - 03.05.2017 в 15:41
Pelena Дата: Среда, 03.05.2017, 15:42 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10996
Репутация: 2455 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Отвечайте здесь. Ту тему закрою.


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеОтвечайте здесь. Ту тему закрою.

Автор - Pelena
Дата добавления - 03.05.2017 в 15:42
andron359 Дата: Среда, 03.05.2017, 15:45 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

vikttur, Вставил Ваши формулы что то не получатся
 
Ответить
Сообщениеvikttur, Вставил Ваши формулы что то не получатся

Автор - andron359
Дата добавления - 03.05.2017 в 15:45
sboy Дата: Среда, 03.05.2017, 15:52 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 583
Репутация: 154 ±
Замечаний: 0% ±

Excel 2010
Проверяйте
Код
=ПОИСКПОЗ($B4&$C4&$D4;$H$4:$H$75&$I$4:$I$75&$G$4:$G$75;)

[p.s.]файл из первой темы
К сообщению приложен файл: 6902457.xlsx(14Kb)
 
Ответить
СообщениеПроверяйте
Код
=ПОИСКПОЗ($B4&$C4&$D4;$H$4:$H$75&$I$4:$I$75&$G$4:$G$75;)

[p.s.]файл из первой темы

Автор - sboy
Дата добавления - 03.05.2017 в 15:52
andron359 Дата: Среда, 03.05.2017, 20:19 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

sboy, Спасибо , очень помогли !!!!!!!!!!!
 
Ответить
Сообщениеsboy, Спасибо , очень помогли !!!!!!!!!!!

Автор - andron359
Дата добавления - 03.05.2017 в 20:19
andron359 Дата: Среда, 03.05.2017, 21:30 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

sboy, Рано радоваться начал , не получается почему то . Вложил файл
К сообщению приложен файл: 9377932.xlsx(21Kb)
 
Ответить
Сообщениеsboy, Рано радоваться начал , не получается почему то . Вложил файл

Автор - andron359
Дата добавления - 03.05.2017 в 21:30
Che79 Дата: Среда, 03.05.2017, 21:44 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 359
Репутация: 52 ±
Замечаний: 0% ±

Excel 2007, 2010, 2016 RUS
andron359, а так? в УФ
Код
=ПОИСКПОЗ($E5&$F5;$H$5:$H$363&$I$5:$I$363;)
К сообщению приложен файл: 9377932_1.xlsx(21Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщениеandron359, а так? в УФ
Код
=ПОИСКПОЗ($E5&$F5;$H$5:$H$363&$I$5:$I$363;)

Автор - Che79
Дата добавления - 03.05.2017 в 21:44
jakim Дата: Четверг, 04.05.2017, 17:17 | Сообщение № 10
Группа: Друзья
Ранг: Ветеран
Сообщений: 762
Репутация: 195 ±
Замечаний: 0% ±

Формула УФ

Код
=COUNTIFS($G$4:$G$800;B4;$H$4:$H$800;C4;$I$4:$I$800;D4)>=1
К сообщению приложен файл: 4875710.xlsx(15Kb)
 
Ответить
Сообщение
Формула УФ

Код
=COUNTIFS($G$4:$G$800;B4;$H$4:$H$800;C4;$I$4:$I$800;D4)>=1

Автор - jakim
Дата добавления - 04.05.2017 в 17:17
gling Дата: Четверг, 04.05.2017, 23:36 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 1506
Репутация: 374 ±
Замечаний: 0% ±

2010
не получается почему то
Ваша формула, начало
Цитата
ПОИСКПОЗ($E$5&$F$5;
Формула sboy
Цитата
ПОИСКПОЗ($B4&$C4&$D4;
Есть разница?
 
Ответить
Сообщение
не получается почему то
Ваша формула, начало
Цитата
ПОИСКПОЗ($E$5&$F$5;
Формула sboy
Цитата
ПОИСКПОЗ($B4&$C4&$D4;
Есть разница?

Автор - gling
Дата добавления - 04.05.2017 в 23:36
andron359 Дата: Воскресенье, 07.05.2017, 10:50 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

gling, Да увидел ошибку , Всё получилось . Спасибо всем !!!!!!
 
Ответить
Сообщениеgling, Да увидел ошибку , Всё получилось . Спасибо всем !!!!!!

Автор - andron359
Дата добавления - 07.05.2017 в 10:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выделить совпадение по трём значениям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!