Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Значения одних ячеек по условию из других - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Значения одних ячеек по условию из других (Формулы/Formulas)
Значения одних ячеек по условию из других
Awallon Дата: Пятница, 05.05.2017, 08:59 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем привет!
Есть таблица с тремя столбцами. Необходимо в четвертом столбце (Результат) проставить значения из первого столбца (ID1 Документ) по условию из третьего (ID3 Менеджер). В файле выделил желтым, какой должен получится результат.
Например, в приложенном файле надо отметить в столбце "Результат" все документы (ID1 XXX), в которых есть хоть одна номенклатура по менеджеру "ID3 3".
Весь свой голова-башка сломал. Может есть какая-нибудь формула массива, в которые я до сих не могу =/
К сообщению приложен файл: 9941923.xlsx(33Kb)
 
Ответить
СообщениеВсем привет!
Есть таблица с тремя столбцами. Необходимо в четвертом столбце (Результат) проставить значения из первого столбца (ID1 Документ) по условию из третьего (ID3 Менеджер). В файле выделил желтым, какой должен получится результат.
Например, в приложенном файле надо отметить в столбце "Результат" все документы (ID1 XXX), в которых есть хоть одна номенклатура по менеджеру "ID3 3".
Весь свой голова-башка сломал. Может есть какая-нибудь формула массива, в которые я до сих не могу =/

Автор - Awallon
Дата добавления - 05.05.2017 в 08:59
_Boroda_ Дата: Пятница, 05.05.2017, 09:07 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10853
Репутация: 4483 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А немассивной пойдет?
Код
=ЕСЛИ(СЧЁТЕСЛИМН(A$2:A$1000;A2;C$2:C$1000;"ID3 3");A2;"")

Если все-таки массивную хочется, то такой вариант
Код
=ТЕКСТ(СЧЁТ(1/(A2&"ID3 3"=A$2:A$1000&C$2:C$1000));A2&";;")
К сообщению приложен файл: 9941923_1.xlsx(33Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА немассивной пойдет?
Код
=ЕСЛИ(СЧЁТЕСЛИМН(A$2:A$1000;A2;C$2:C$1000;"ID3 3");A2;"")

Если все-таки массивную хочется, то такой вариант
Код
=ТЕКСТ(СЧЁТ(1/(A2&"ID3 3"=A$2:A$1000&C$2:C$1000));A2&";;")

Автор - _Boroda_
Дата добавления - 05.05.2017 в 09:07
Awallon Дата: Пятница, 05.05.2017, 09:44 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, по традиции, строк сотни тысяч, таблиц, как и обычно, несколько, поэтому я думал, что массивная формула будет выходом, т.к. если применять СЧЁТЕСЛИ(МН)(), нужно ждать несколько часов =/
массивная тоже медленно работает...
Можно ли придумать что-нибудь еще или лучше переадресовать вопрос в VBA?
 
Ответить
Сообщение_Boroda_, по традиции, строк сотни тысяч, таблиц, как и обычно, несколько, поэтому я думал, что массивная формула будет выходом, т.к. если применять СЧЁТЕСЛИ(МН)(), нужно ждать несколько часов =/
массивная тоже медленно работает...
Можно ли придумать что-нибудь еще или лучше переадресовать вопрос в VBA?

Автор - Awallon
Дата добавления - 05.05.2017 в 09:44
_Boroda_ Дата: Пятница, 05.05.2017, 10:01 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10853
Репутация: 4483 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
по традиции, строк сотни тысяч

И также по традиции, автор вспоминает о существенных уточнениях уже после того, как получен ответ. И почему я не удивлен? :D :D
Кстати, Вам вообще зачем это нужно-то? Что дальше делать будете?
Можно сделать рядом сводную таблицу и искать по ней уже. Намного быстрее должно получиться.
Код
=ЕСЛИ(СЧЁТЕСЛИ(K:K;A2);A2;"")
К сообщению приложен файл: 9941923_2.xlsx(47Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
по традиции, строк сотни тысяч

И также по традиции, автор вспоминает о существенных уточнениях уже после того, как получен ответ. И почему я не удивлен? :D :D
Кстати, Вам вообще зачем это нужно-то? Что дальше делать будете?
Можно сделать рядом сводную таблицу и искать по ней уже. Намного быстрее должно получиться.
Код
=ЕСЛИ(СЧЁТЕСЛИ(K:K;A2);A2;"")

Автор - _Boroda_
Дата добавления - 05.05.2017 в 10:01
Awallon Дата: Пятница, 05.05.2017, 10:38 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, прошу извинить, за неполную информацию...
Если работать со сводной таблицей, то можно и ВПР использовать. Так же медленно, как и СЧЁТЕСЛИ() выходит.

Сюда нельзя вставить сгенерированный файл для тестов (24Мб). Я сделал такой:
Столбец А
Код
="ID"&ТЕКСТ(СЛУЧМЕЖДУ(1;999999);"000000")

Столбец В
Код
="ID"&ТЕКСТ(СЛУЧМЕЖДУ(1;999);"000")

Столбец С
Код
=ВЫБОР(ЧАСТНОЕ(ЗНАЧЕН(ПРАВСИМВ(B2;3))+1;200);"ID1";"ID2";"ID3";"ID4";"ID5")

Диапазон (A2:C1000000)

Конечная же задача такая:
выяснить с какими Номенклатурами Менеджера 3 встречаются в документах другие номенклатуры и в каком процентном соотношении встречается подобная частота.
 
Ответить
Сообщение_Boroda_, прошу извинить, за неполную информацию...
Если работать со сводной таблицей, то можно и ВПР использовать. Так же медленно, как и СЧЁТЕСЛИ() выходит.

Сюда нельзя вставить сгенерированный файл для тестов (24Мб). Я сделал такой:
Столбец А
Код
="ID"&ТЕКСТ(СЛУЧМЕЖДУ(1;999999);"000000")

Столбец В
Код
="ID"&ТЕКСТ(СЛУЧМЕЖДУ(1;999);"000")

Столбец С
Код
=ВЫБОР(ЧАСТНОЕ(ЗНАЧЕН(ПРАВСИМВ(B2;3))+1;200);"ID1";"ID2";"ID3";"ID4";"ID5")

Диапазон (A2:C1000000)

Конечная же задача такая:
выяснить с какими Номенклатурами Менеджера 3 встречаются в документах другие номенклатуры и в каком процентном соотношении встречается подобная частота.

Автор - Awallon
Дата добавления - 05.05.2017 в 10:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Значения одних ячеек по условию из других (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!