Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создать код товара - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создать код товара (Формулы/Formulas)
Создать код товара
unio Дата: Понедельник, 08.05.2017, 10:41 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
В столбце А разного товара может быть 10000 или больше наименований.
В столбец B можно вставить какую формулу, чтобы выводился такой код вместо значений?
К сообщению приложен файл: _0781709.xls(35Kb)


Сообщение отредактировал unio - Понедельник, 08.05.2017, 10:47
 
Ответить
СообщениеВ столбце А разного товара может быть 10000 или больше наименований.
В столбец B можно вставить какую формулу, чтобы выводился такой код вместо значений?

Автор - unio
Дата добавления - 08.05.2017 в 10:41
gling Дата: Понедельник, 08.05.2017, 11:21 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1506
Репутация: 374 ±
Замечаний: 0% ±

2010
А попробуйте так
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$1:C1;ПОИСКПОЗ(A2;$A$1:A1;));МАКС($C$1:C1)+1)
Это формула для С2.


Сообщение отредактировал gling - Понедельник, 08.05.2017, 11:22
 
Ответить
СообщениеА попробуйте так
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$1:C1;ПОИСКПОЗ(A2;$A$1:A1;));МАКС($C$1:C1)+1)
Это формула для С2.

Автор - gling
Дата добавления - 08.05.2017 в 11:21
vikttur Дата: Понедельник, 08.05.2017, 11:30 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2123
Репутация: 374 ±
Замечаний: 0% ±

Код
=ЕСЛИ(СЧЁТЕСЛИ($A$1:A1;A2);ВПР(A2;$A$1:B1;2;);МАКС($B$1:B1)+1)
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$1:A1;A2);ВПР(A2;$A$1:B1;2;);МАКС($B$1:B1)+1)

Автор - vikttur
Дата добавления - 08.05.2017 в 11:30
AlexM Дата: Понедельник, 08.05.2017, 19:27 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3446
Репутация: 873 ±
Замечаний: 0% ±

unio, У вас Excel 2013, тогда можно так
Код
=ЕСЛИОШИБКА(ВПР(A2;$A$1:B1;2;);МАКС($B$1:B1)+1)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеunio, У вас Excel 2013, тогда можно так
Код
=ЕСЛИОШИБКА(ВПР(A2;$A$1:B1;2;);МАКС($B$1:B1)+1)

Автор - AlexM
Дата добавления - 08.05.2017 в 19:27
unio Дата: Вторник, 09.05.2017, 03:02 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Все формулы испытал на большом списке - работают! Всем большое Спасибо!
Не подскажите, - из этих формул какая попроще для компа будет или без-разницы? - у меня таблица большая, уже ок. 7000 наименований, перегружена разными формулами, долго открывается.
 
Ответить
СообщениеВсе формулы испытал на большом списке - работают! Всем большое Спасибо!
Не подскажите, - из этих формул какая попроще для компа будет или без-разницы? - у меня таблица большая, уже ок. 7000 наименований, перегружена разными формулами, долго открывается.

Автор - unio
Дата добавления - 09.05.2017 в 03:02
vikttur Дата: Вторник, 09.05.2017, 08:20 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2123
Репутация: 374 ±
Замечаний: 0% ±

Код
ИНДЕКС(ПОИСКПОЗ()); ВПР(...)

эти практически одинаково шустрые

Сначала считаем количество, потом определяем, что делать:
Код
=ЕСЛИ(СЧЁТЕСЛИ())

Сразу ищем значение, при ошибке переходим к другому варианту:
Код
=ЕСЛИОШИБКА(ВПР())

Наверное, из трех показанных вариант от AlexM быстрее. Но это теоретическая догадка.


Сообщение отредактировал vikttur - Вторник, 09.05.2017, 08:24
 
Ответить
Сообщение
Код
ИНДЕКС(ПОИСКПОЗ()); ВПР(...)

эти практически одинаково шустрые

Сначала считаем количество, потом определяем, что делать:
Код
=ЕСЛИ(СЧЁТЕСЛИ())

Сразу ищем значение, при ошибке переходим к другому варианту:
Код
=ЕСЛИОШИБКА(ВПР())

Наверное, из трех показанных вариант от AlexM быстрее. Но это теоретическая догадка.

Автор - vikttur
Дата добавления - 09.05.2017 в 08:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создать код товара (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!