Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Эксель некорректно выделяет повторяющиеся значения. Почему? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Эксель некорректно выделяет повторяющиеся значения. Почему? (Формулы/Formulas)
Эксель некорректно выделяет повторяющиеся значения. Почему?
Alex_Word Дата: Понедельник, 08.05.2017, 21:15 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте все!

Мне нужно выделить и удалить все дубликаты в одном из столбцов книги.
Я для этого использую "Условное форматирование - правила выделения ячеек - повторяющиеся значения"
Загвоздка вышла в том, что выделяются почему-то не только повторяющиеся значения, но ещё и уникальные, причем какой-то закономерности я не вижу.

Подскажите, как это починить?
К сообщению приложен файл: 0203264.xlsx(13Kb)


Сообщение отредактировал Alex_Word - Понедельник, 08.05.2017, 21:16
 
Ответить
СообщениеЗдравствуйте все!

Мне нужно выделить и удалить все дубликаты в одном из столбцов книги.
Я для этого использую "Условное форматирование - правила выделения ячеек - повторяющиеся значения"
Загвоздка вышла в том, что выделяются почему-то не только повторяющиеся значения, но ещё и уникальные, причем какой-то закономерности я не вижу.

Подскажите, как это починить?

Автор - Alex_Word
Дата добавления - 08.05.2017 в 21:15
gling Дата: Понедельник, 08.05.2017, 21:34 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1661
Репутация: 406 ±
Замечаний: 0% ±

2010
Попробуйте формулу в УФ
Код
=СЧЁТЕСЛИ($A$1:A1;A1)>1
К сообщению приложен файл: 0868727.xlsx(17Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Понедельник, 08.05.2017, 21:35
 
Ответить
СообщениеПопробуйте формулу в УФ
Код
=СЧЁТЕСЛИ($A$1:A1;A1)>1

Автор - gling
Дата добавления - 08.05.2017 в 21:34
Pelena Дата: Понедельник, 08.05.2017, 21:42 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11829
Репутация: 2604 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Так происходит, потому что Excel преобразует текст в числа и учитывает только первые 15 знаков.
Попробуйте формулой УФ
Код
=СУММПРОИЗВ(--($A$1:$A$79=$A1))>1
К сообщению приложен файл: 2104597.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак происходит, потому что Excel преобразует текст в числа и учитывает только первые 15 знаков.
Попробуйте формулой УФ
Код
=СУММПРОИЗВ(--($A$1:$A$79=$A1))>1

Автор - Pelena
Дата добавления - 08.05.2017 в 21:42
Alex_Word Дата: Понедельник, 08.05.2017, 22:08 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
gling, Pelena
Большое спасибо!
 
Ответить
Сообщениеgling, Pelena
Большое спасибо!

Автор - Alex_Word
Дата добавления - 08.05.2017 в 22:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Эксель некорректно выделяет повторяющиеся значения. Почему? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!