Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет кв.м исходя из размеров в другой ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кв.м исходя из размеров в другой ячейки (Формулы/Formulas)
Подсчет кв.м исходя из размеров в другой ячейки
dolch89 Дата: Четверг, 11.05.2017, 10:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, я не бухгалтер но тут срочно пришлось составить отчет, отчет огромен и нужно как то автоматизировать подсчет кв.м исходя из размеров, прошу помощи.
К сообщению приложен файл: ._-2017.xlsx(10Kb)
 
Ответить
СообщениеЗдравствуйте, я не бухгалтер но тут срочно пришлось составить отчет, отчет огромен и нужно как то автоматизировать подсчет кв.м исходя из размеров, прошу помощи.

Автор - dolch89
Дата добавления - 11.05.2017 в 10:10
and_evg Дата: Четверг, 11.05.2017, 10:14 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 119
Репутация: 26 ±
Замечаний: 0% ±

Excel 2007
dolch89, Здравствуйте. нужны доп колонки!
К сообщению приложен файл: -2017.xlsx(11Kb)
 
Ответить
Сообщениеdolch89, Здравствуйте. нужны доп колонки!

Автор - and_evg
Дата добавления - 11.05.2017 в 10:14
vikttur Дата: Четверг, 11.05.2017, 10:14 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2199
Репутация: 382 ±
Замечаний: 0% ±

Код
=ЛЕВБ(D2;ПОИСК("х";D2)-1)*ПСТР(D2;ПОИСК("х";D2)+1;5)*E2

Вообще, лучше размеры вводить в отдельные ячейки, а не через разделитель

Вариант: примнить макрофункцию ВЫЧИСЛИТЬ:
Код
=ВЫЧИСЛИТЬ(ПОДСТАВИТЬ(Sheet1!$D12;"х";"*"))
К сообщению приложен файл: 1522360.xlsm(11Kb)


Сообщение отредактировал vikttur - Четверг, 11.05.2017, 10:20
 
Ответить
Сообщение
Код
=ЛЕВБ(D2;ПОИСК("х";D2)-1)*ПСТР(D2;ПОИСК("х";D2)+1;5)*E2

Вообще, лучше размеры вводить в отдельные ячейки, а не через разделитель

Вариант: примнить макрофункцию ВЫЧИСЛИТЬ:
Код
=ВЫЧИСЛИТЬ(ПОДСТАВИТЬ(Sheet1!$D12;"х";"*"))

Автор - vikttur
Дата добавления - 11.05.2017 в 10:14
buchlotnik Дата: Четверг, 11.05.2017, 10:17 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2742
Репутация: 782 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
я не бухгалтер
я тоже :) Навскидку вот такой формулой (см. диспетчер имён)
Код
=ВЫЧИСЛИТЬ(ПОДСТАВИТЬ(Sheet1!D2;"х";"*"))*Sheet1!E2

ну или вот так:
Код
=ЛЕВБ(ПОДСТАВИТЬ(D2;"х";"         ");9)*ПРАВБ(ПОДСТАВИТЬ(D2;"х";"         ");9)*E2
К сообщению приложен файл: -2017.xlsm(11Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 11.05.2017, 10:22
 
Ответить
Сообщение
Цитата
я не бухгалтер
я тоже :) Навскидку вот такой формулой (см. диспетчер имён)
Код
=ВЫЧИСЛИТЬ(ПОДСТАВИТЬ(Sheet1!D2;"х";"*"))*Sheet1!E2

ну или вот так:
Код
=ЛЕВБ(ПОДСТАВИТЬ(D2;"х";"         ");9)*ПРАВБ(ПОДСТАВИТЬ(D2;"х";"         ");9)*E2

Автор - buchlotnik
Дата добавления - 11.05.2017 в 10:17
Nic70y Дата: Четверг, 11.05.2017, 10:17 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3989
Репутация: 845 ±
Замечаний: 0% ±

Excel 2013
макрофункция
Код
=ВЫЧИСЛИТЬ()
включите макросы,
см. диспетчер имен
К сообщению приложен файл: 6274273.xlsm(11Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениемакрофункция
Код
=ВЫЧИСЛИТЬ()
включите макросы,
см. диспетчер имен

Автор - Nic70y
Дата добавления - 11.05.2017 в 10:17
Pelena Дата: Четверг, 11.05.2017, 10:17 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11161
Репутация: 2486 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ещё вариант
Код
=ЕСЛИОШИБКА(ПРОИЗВЕД(--ПСТР(ПОДСТАВИТЬ(D2;"х";ПОВТОР(" ";9));{1;9};9))*E2;"")
К сообщению приложен файл: 1273277.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант
Код
=ЕСЛИОШИБКА(ПРОИЗВЕД(--ПСТР(ПОДСТАВИТЬ(D2;"х";ПОВТОР(" ";9));{1;9};9))*E2;"")

Автор - Pelena
Дата добавления - 11.05.2017 в 10:17
dolch89 Дата: Четверг, 11.05.2017, 10:32 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Большое спасибо, буду мучить Excel :)
 
Ответить
СообщениеБольшое спасибо, буду мучить Excel :)

Автор - dolch89
Дата добавления - 11.05.2017 в 10:32
AlexM Дата: Четверг, 11.05.2017, 11:27 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3528
Репутация: 892 ±
Замечаний: 0% ±

Еще можно так
Код
=ПРОИЗВЕД(-ПСТР(ПОДСТАВИТЬ(0&D2&"х0";"х";ПОВТОР(" ";9));{1;9};9))*E2
и форматом скрыть нули.


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Четверг, 11.05.2017, 12:34
 
Ответить
СообщениеЕще можно так
Код
=ПРОИЗВЕД(-ПСТР(ПОДСТАВИТЬ(0&D2&"х0";"х";ПОВТОР(" ";9));{1;9};9))*E2
и форматом скрыть нули.

Автор - AlexM
Дата добавления - 11.05.2017 в 11:27
vikttur Дата: Четверг, 11.05.2017, 11:40 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2199
Репутация: 382 ±
Замечаний: 0% ±

Красиво.
Но для вычислений лучше:
Код
=ЕСЛИ(D2="";;ПРОИЗВЕД(--ПСТР(ПОДСТАВИТЬ(D2;"х"...))))
 
Ответить
СообщениеКрасиво.
Но для вычислений лучше:
Код
=ЕСЛИ(D2="";;ПРОИЗВЕД(--ПСТР(ПОДСТАВИТЬ(D2;"х"...))))

Автор - vikttur
Дата добавления - 11.05.2017 в 11:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кв.м исходя из размеров в другой ячейки (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!