Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция Суммпроизв () - условие-список - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция Суммпроизв () - условие-список (Формулы/Formulas)
Функция Суммпроизв () - условие-список
Viper25 Дата: Пятница, 12.05.2017, 10:48 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 4 ±
Замечаний: 20% ±

Excel 2007
Здравствуйте.
Есть список городов и выручка помесячно.
По одному месяцу по списку городов с помощью СУММПРОИЗВ нужна выручка.
По месяцу функция работает, а по списку городов нет.
К сообщению приложен файл: 6609059.xls(27Kb)
 
Ответить
СообщениеЗдравствуйте.
Есть список городов и выручка помесячно.
По одному месяцу по списку городов с помощью СУММПРОИЗВ нужна выручка.
По месяцу функция работает, а по списку городов нет.

Автор - Viper25
Дата добавления - 12.05.2017 в 10:48
buchlotnik Дата: Пятница, 12.05.2017, 10:52 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2607
Репутация: 744 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
попробуйте так:
Код
=СУММПРОИЗВ((B2:B16=F2)*(1-ЕОШИБКА(ПОИСКПОЗ(A2:A16;Город;0)))*(C2:C16))
а лучше так:
Код
=СУММПРОИЗВ((B2:B16=F2)*(СЧЁТЕСЛИ(Город;A2:A16)>0)*(C2:C16))
пятница - туплю:
Код
=СУММПРОИЗВ((B2:B16=F2)*СЧЁТЕСЛИ(Город;A2:A16)*(C2:C16))
К сообщению приложен файл: 12243.xls(29Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 12.05.2017, 11:22
 
Ответить
Сообщениепопробуйте так:
Код
=СУММПРОИЗВ((B2:B16=F2)*(1-ЕОШИБКА(ПОИСКПОЗ(A2:A16;Город;0)))*(C2:C16))
а лучше так:
Код
=СУММПРОИЗВ((B2:B16=F2)*(СЧЁТЕСЛИ(Город;A2:A16)>0)*(C2:C16))
пятница - туплю:
Код
=СУММПРОИЗВ((B2:B16=F2)*СЧЁТЕСЛИ(Город;A2:A16)*(C2:C16))

Автор - buchlotnik
Дата добавления - 12.05.2017 в 10:52
vikttur Дата: Пятница, 12.05.2017, 11:40 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2121
Репутация: 374 ±
Замечаний: 0% ±

Так быстрее:
Код
=СУММПРОИЗВ(--(B2:B16=F2);СЧЁТЕСЛИ(Город;A2:A16);C2:C16)
 
Ответить
СообщениеТак быстрее:
Код
=СУММПРОИЗВ(--(B2:B16=F2);СЧЁТЕСЛИ(Город;A2:A16);C2:C16)

Автор - vikttur
Дата добавления - 12.05.2017 в 11:40
_Boroda_ Дата: Пятница, 12.05.2017, 11:50 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так, думаю, еще быстрее
Код
=СУММПРОИЗВ(СУММЕСЛИМН(C2:C16;B2:B16;F2;A2:A16;Город))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак, думаю, еще быстрее
Код
=СУММПРОИЗВ(СУММЕСЛИМН(C2:C16;B2:B16;F2;A2:A16;Город))

Автор - _Boroda_
Дата добавления - 12.05.2017 в 11:50
Viper25 Дата: Пятница, 12.05.2017, 14:10 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 4 ±
Замечаний: 20% ±

Excel 2007
Спасибо.
 
Ответить
СообщениеСпасибо.

Автор - Viper25
Дата добавления - 12.05.2017 в 14:10
vikttur Дата: Пятница, 12.05.2017, 16:37 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2121
Репутация: 374 ±
Замечаний: 0% ±

Так, думаю, еще быстрее

Мимо. +функция, ее еще надо посчитать... Медленнее в 6 раз.
Прогнал по три раза каждую на диапазоне 100*1000.
buchlotnik - 0 мин 20 сек
vikttur - 0 мин 18 сек
_Boroda_ - 1 мин 19 сек

Понятно, что на таких диарпазонах никто работать не будет. Но сколько реальных примеров, когда прибегают на форум за оптимизацией ("рабол много и долго, а сейчас не хочет и думает долго")


Сообщение отредактировал vikttur - Пятница, 12.05.2017, 16:39
 
Ответить
Сообщение
Так, думаю, еще быстрее

Мимо. +функция, ее еще надо посчитать... Медленнее в 6 раз.
Прогнал по три раза каждую на диапазоне 100*1000.
buchlotnik - 0 мин 20 сек
vikttur - 0 мин 18 сек
_Boroda_ - 1 мин 19 сек

Понятно, что на таких диарпазонах никто работать не будет. Но сколько реальных примеров, когда прибегают на форум за оптимизацией ("рабол много и долго, а сейчас не хочет и думает долго")

Автор - vikttur
Дата добавления - 12.05.2017 в 16:37
buchlotnik Дата: Пятница, 12.05.2017, 16:44 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2607
Репутация: 744 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Виктор, а вот так не быстрее будет?
Код
=-СУММПРОИЗВ(-(B2:B16=F2);СЧЁТЕСЛИ(Город;A2:A16);C2:C16)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеВиктор, а вот так не быстрее будет?
Код
=-СУММПРОИЗВ(-(B2:B16=F2);СЧЁТЕСЛИ(Город;A2:A16);C2:C16)

Автор - buchlotnik
Дата добавления - 12.05.2017 в 16:44
vikttur Дата: Пятница, 12.05.2017, 22:11 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2121
Репутация: 374 ±
Замечаний: 0% ±

Вряд ли. Двойное отрицание обрабатывается как оператор (могу ошибаться). А минус по скорости стоит после суммирования и умножения.


Сообщение отредактировал vikttur - Пятница, 12.05.2017, 22:38
 
Ответить
СообщениеВряд ли. Двойное отрицание обрабатывается как оператор (могу ошибаться). А минус по скорости стоит после суммирования и умножения.

Автор - vikttur
Дата добавления - 12.05.2017 в 22:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция Суммпроизв () - условие-список (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!