Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения - путем пересечения строк и столбцов. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения - путем пересечения строк и столбцов. (Формулы/Formulas)
Поиск значения - путем пересечения строк и столбцов.
odeon16 Дата: Суббота, 13.05.2017, 00:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте форумчане.
Помогите разобраться.

У меня на листе есть таблица, в которой - пронумерованы строки и столбцы.

Как формулой - извлечь значение той ячейки, которая оказывается в пересечении заданных строки-столбца ?
(возможно в этой формуле - могут использоваться ВПР и ГПР - для горизонтального и вертикального поиска.)
К сообщению приложен файл: 43543.xls(28Kb)
 
Ответить
СообщениеЗдравствуйте форумчане.
Помогите разобраться.

У меня на листе есть таблица, в которой - пронумерованы строки и столбцы.

Как формулой - извлечь значение той ячейки, которая оказывается в пересечении заданных строки-столбца ?
(возможно в этой формуле - могут использоваться ВПР и ГПР - для горизонтального и вертикального поиска.)

Автор - odeon16
Дата добавления - 13.05.2017 в 00:54
buchlotnik Дата: Суббота, 13.05.2017, 01:08 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2742
Репутация: 782 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
а чем просто ИНДЕКС не гож?
Код
=ИНДЕКС(D6:J18;O6;O7)
К сообщению приложен файл: 1183643.xls(29Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениеа чем просто ИНДЕКС не гож?
Код
=ИНДЕКС(D6:J18;O6;O7)

Автор - buchlotnik
Дата добавления - 13.05.2017 в 01:08
vikttur Дата: Суббота, 13.05.2017, 08:14 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2199
Репутация: 382 ±
Замечаний: 0% ±

Код
=ВПР(O6;C6:J18;O7+1;)

Код
=ГПР(O7;D5:J18;O6+1;)
 
Ответить
Сообщение
Код
=ВПР(O6;C6:J18;O7+1;)

Код
=ГПР(O7;D5:J18;O6+1;)

Автор - vikttur
Дата добавления - 13.05.2017 в 08:14
китин Дата: Суббота, 13.05.2017, 09:02 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4180
Репутация: 657 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а поизвращаться? :D
Код
=СМЕЩ($C$5;ПОИСКПОЗ($O$6;$C$6:$C$18;0);ПОИСКПОЗ($O$7;$D$5:$J$5;0);;)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа поизвращаться? :D
Код
=СМЕЩ($C$5;ПОИСКПОЗ($O$6;$C$6:$C$18;0);ПОИСКПОЗ($O$7;$D$5:$J$5;0);;)

Автор - китин
Дата добавления - 13.05.2017 в 09:02
buchlotnik Дата: Суббота, 13.05.2017, 09:13 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2742
Репутация: 782 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
а поизвращаться?
ну вообще, с точки зрения МШ, через СМЕЩ() самый короткий вариант выходит :D :D :D
Код
=СМЕЩ(C5;O6;O7)
а поизвращаться, это вот так:
Код
=ПРОСМОТР(O6;C6:C18;ИНДЕКС(D6:J18;;O7))
а лучше:
Код
=ИНДЕКС(D6:J18;O6;) ИНДЕКС(D6:J18;;O7)
К сообщению приложен файл: 1183643-1-.xls(29Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Суббота, 13.05.2017, 10:25
 
Ответить
Сообщение
Цитата
а поизвращаться?
ну вообще, с точки зрения МШ, через СМЕЩ() самый короткий вариант выходит :D :D :D
Код
=СМЕЩ(C5;O6;O7)
а поизвращаться, это вот так:
Код
=ПРОСМОТР(O6;C6:C18;ИНДЕКС(D6:J18;;O7))
а лучше:
Код
=ИНДЕКС(D6:J18;O6;) ИНДЕКС(D6:J18;;O7)

Автор - buchlotnik
Дата добавления - 13.05.2017 в 09:13
odeon16 Дата: Суббота, 13.05.2017, 12:52 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
vikttur, спасибо подходит.
 
Ответить
Сообщениеvikttur, спасибо подходит.

Автор - odeon16
Дата добавления - 13.05.2017 в 12:52
odeon16 Дата: Суббота, 13.05.2017, 12:52 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, Подходит.
Спасибо.
 
Ответить
Сообщениеbuchlotnik, Подходит.
Спасибо.

Автор - odeon16
Дата добавления - 13.05.2017 в 12:52
odeon16 Дата: Суббота, 13.05.2017, 12:53 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, тоже подходит, но очень длинная формула.
 
Ответить
Сообщениекитин, тоже подходит, но очень длинная формула.

Автор - odeon16
Дата добавления - 13.05.2017 в 12:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения - путем пересечения строк и столбцов. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!